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Introduction 

At a glance  

Fidesys Bundle is a software package for strength analysis. The package comprises the following types of 

analysis: 

 Static 

 Dynamic (transient) 

 Buckling 

 Modal 

The package also includes a program Fidesys Viewer for visualization and analysis of the obtained results: 

 Visualization of scalar and vector fields 

 Graph 

 Time dependency analysis 
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Getting Started  

System requirements 

CAE Fidesys from the beginning has been designed in such a way that the system requirements of the 

package are low: it can be run on an ordinary personal computer. If the computer has one or more multi-

core processors calculations will be automatically parallelized on all cores. Starting version 1.5, calculation 

paralleization to several nodes connected to a local network or a cluster are available in the 64-bit version 

of the program package.  

Fidesys Bundle software package has the following minimal requirements for software and hardware. 

Hardware requirements 

 CPU: Dual-core 1,7 GHz minimum 

 RAM: 2GB minimum 

 Free hard drive space: 5 GB 

 Video card NVIDIA GeForce GTX 460 or faster 

 Screen resolution: 1024х768 or higher 

Operating system 

The following Windows versions 32-*/64-bit are supported: 

 Windows XP SP3; 

 Windows Vista SP2; 

 Windows 7; 

 Windows 8; 

 Windows Server 2008 (including R2); 

 Windows Server 2012 (including R2). 

The following Linux versions (only 64-bit) are supported: 

 OpenSUSE 12.3; 

 Red Hat EL 5.9, 6.4; 

 Ubuntu Server 10.04; 

 Ubuntu Desktop and Server 12.04; 

 Debian 6.0.x; 

 CentOS 6.5. 

Spectral element method calculations and parallel calculations based on MPI technologies are available 

only in the 64bit version of the program package.  
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Installation  

Microsoft Windows 

The user installing the software on a computer must have administrator rights on that PC. Please, close all 

the Fidesys Bundle windows before installation if there’s another version of CAE Fidesys installed. 

1. Download the CAE Fidesys installer from the site http://www.cae-fidesys.com/ru/download/login 

and run it for the architecture you are interested in (Windows x64 or Windows x32), or run the 

installation from the DVD-ROM.  

If any other version of Fidesys Bundle is already installed on a computer, it will be suggested to remove it or to cancel 

the installation while starting the installation program. 

2. Click Next in a pop-up window.  

 

3. Please, read the license agreement. If you do not agree with any of its paragraphs, interrupt the 

installer by clicking Cancel. If you totally agree with its terms, click Agree to proceed the 

installation. 

 

4. Select a folder for installation and click Next. 

http://www.cae-fidesys.com/ru/download/login
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5. In the Start menu enter the name of the folder where a shortcut for running the program will be 

created. If you do not want to create a folder in the Start menu, choose Do not create shortcuts. Click 

Install. 

 

6. The process of installation may take some time. Click Ready after installing. 

Linux 

Only 64-bit Linux distribution kits are currently supported. 

1. Please, download the CAE Fidesys file for Linux x64 from http://www.cae-

fidesys.com/ru/download/login. 

2. Right-click on the downloaded file and select Properties item from the contextual menu. 

3. In the opened window, go to the tab Permissions and tick Allow executing file as program. Click 

Close.  

http://www.cae-fidesys.com/ru/download/login
http://www.cae-fidesys.com/ru/download/login
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4. Run the installer by double-clicking on the installer file. When the dialog box appears, click Run in 

Terminal button: 

 

Activation and trial period  

When you first run the preprocessor, the Fidesys Licensing window appears with a proposal to purchase a 

license or to activate a trial period.  

Trial period  

30-day trial period activates automatically on package installation. The trial period starts at the moment 

when application installation is completed. The trial period is intended for familiarization with the product 

and is not for any commercial calculations (related directly or indirectly to getting a profit out of them). The 

trial period can not be activated on a virtual machine, and a trial version is not dedicated to work with via 

remote desktop. 

To activate a trial period, click the button Trial period in the start window.  
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As long as the program is running in trial mode, the Fidesys Licensing window will appear each time you 

launch it. Please, press the button Try to continue working in a trial mode. 

Activation  

To activate the product: 

1. Press the button Activate in the Fidesys Licensing window.  

2. Select I do not have a V2C file and click Generate C2V. Save File dialog window will be opened. Save 

the C2V file and send it to the organization where the product was purchased. 

3. In response, you will get a file containing an activation key with V2C extension. Having received the 

V2C file, select I have V2C file and click Apply V2C. You will see an Open File dialog window. Specify 

a path to the received V2C file. 

 
4. Your product is activated. 

Information on the purchased license 

On selecting Help → About in the Main Menu, you will see a window with the following information: 

 The full software version number; 

 License type and its expiration date; 

 The list of features available in the purchased license. 

Removing the software 

The user removing the software must have administrator rights. 

Please, finish all the running copies of the application before removing the software: both preprocessor 

(Fidesys) and postprocessor (Fidesys Viewer). 
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To remove the software, open Windows Control Panel and select Programs and Features (Add or Remove 

Programs in the earlier versions of Windows). Select Fidesys Bundle #.#.#.# xNN in the list of installed 

programs, where #.#.#.# are the four numbers standing for the number of the version and xNN is the 

architecture (x64 or x32). Right-click it and choose Delete/Change. Confirm your choice by clicking Delete in 

the opened window. 

Removing the software does not involve removing its activation data. 
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Overview  

Package structure 

Fidesys Bundle comprises two main components: 

 Fidesys — preprocessing and analysis (computational kernels). 

 Fidesys Viewer — postprocessing and visualization of results. 

Running the software 

You can run the program in either of the following ways: 

 Using the Start menu (if you chose creating shortcuts in it when installing): choose Fidesys in the 

folder where you installed the program (FidesysBundle by default). 

 Using any file manager for Windows from the list where the program was installed 

(C:\Program Files\Fidesys\FidesysBundle by default): run the file fidesys.exe (it is in the folder 

preprocessor\bin). 

Several copies of the program can be run on the same PC at a time. 

If the license fee for the program is activated, after running the program you see its Main window. If the 

trial period is activated, a Fidesys Licensing window appears in which you should either click the button 

Activate in order to purchase a license or click Try to continue working in trial mode and go to the Main 

window. 

Main Window  

Fidesys Bundle has an intuitive graphic interface providing communication between the user and the 

software, and it allows the user to perform the full cycle of calculations step-by-step. 

 

 

 

Workbench (1) displays the model and visual effects. 
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Main Menu (2) includes standard operations for working with files and projects, managing the visualization 

modes, panel display settings, help, and other functionality available in the drop-down lists of the menu. 

Power Tools (3) comprise the Model Tree, as well as the tools for geometry and mesh analysis. 

Command Panel (4) contains most of commands for working with the program. Panel display buttons are 

logically located, and it allows the user to perform the full cycle of calculations step-by-step. 

Toolbar (5) comprises the buttons for calling the most frequently used commands while working with the 

program. 

Properties Page (6) displays the properties of the selected object in the Workbench or in the Model Tree. 

Console (7) is used for the input of commands of Fidesys Bundle and for the output of the messages for the 

user. 
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Software history  

Version 1.6 R2 

Released: April, 2015  

 

Updates and improvements in the preprocessor  

 The possibility to automatically process the calculation results of composites effective properties. 

 The stability of the operations is increased. 

 

Updates and improvements in the processor  

 Elastoplastic deformation by the Drucker-Prager model  

 Calculation of the effective properties of composite materials  

 HPC and Dynamics modules are available in Standard and Professional  

 

Updates and improvements in the postprocessor (3D-vizualization module)  

 Programming interface operation based on Python Shell is improved. 

Version 1.6 

Released: February, 2015 

 

 The support for importing geometry in the following CAD-formats is added: 

– SolidWorks; 

– Parasolid; 

– Pro/Engineer. 

 The support of APREPRO (An Algebraic Preprocessor for Parameterizing Finite Element Analyses) is 

added 

 New profiles of beam cross section are added: 

– Channel (C-shape); 

– Corner (L-shape); 

– Taurus (T-shape); 

– Z-shape; 

– Hollow rectangle. 

 The possibility to set the boundary conditions using tabular and formular dependency on the 

coordinates and temperature for static analysis is added. 

 The new generator of adaptive tetrahedral meshes is added. 

 In accordance with the users wishes, the panel of nonlinear solver settings is changed. 

 Contact problems in 3D and 2D 

 Contact surface binding in 3D and the contact curves binding in 2D 

 Modal analysis for prestressed bodies  

 The automatic adaptive calculation of the loading steps size is added. 

 The output of intermediate results and calculation log (textual information on the status of the 

calculation by stages) are added for nonlinear problems.  

 Thermoelastic problems for 2nd order shell elements: TRISHELL6, SHELL8, SHELL9. 

 The support for multiprocessor calculations based on MPI technology for the following calculations 

is added: 

– Spectral element method; 
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– Plasticity for small and finite deformations; 

– Dynamic analysis for the explicit and implicit time schemes. 

 The incorporation of plastic deformation using finite element method and spectral element method 

is modified taking into account: 

– Finite deformations; 

– Thermoelasticity. 

 Dynamic analysis perfomance is improved 

 Performance of spectral element method on hybrid meshes in buckling problems is improved 

 The solution tolerance of static problem with shear loading using 4-node plane and 8-node 

volumetric elements is increased. 

 Fidesys Viewer 1.6: focusing of model elements in the current position of the mouse pointer is 

added. 

 Fidesys Viewer 1.6: strength analysis filter operation is improved. 

 Fidesys Viewer 1.6: operation of the “Agreed resultants” filter for shell structures is improved. 

 The compatibility with Windows 8 and Windows 8.1 is improved. 

 The Progress Bar operation is improved. 

 The Fidesys Bundle licensing system is added. 

 

Version 1.5 R2 

Released: July, 2014 

 The ability to set the analytic spatial coordinates dependence of the boundary conditions is added. 

 The possibility of producing graphs of the spatial coordinates and time dependency of the boundary 

conditions is added. 

 The generation of console commands for setting up and running the calculation of the graphical 

interface widgets is added. 

 Import/export of materials from the graphical interface are added. 

 The package includes a new version of Fidesys Viewer with a number of improvements. 

Version 1.5 

Released: June, 2014 

 Static analysis for elastoplastic material models 

 Orthotropic materials 

 Physically nonlinear hyperelastic materials: Mooney-Rivlin and Murnaghan. 

 Calculations by spectral element method for hybrid meshes.  

 The possibility of parallel calculations on one or more computers using the MPI technology (linear 

statics, modal analysis, buckling) is added.  

 The calculation of the margin of safety in accordance with various strength theories. 

 8-node shell elements SHELL8. 

 Console commands to set analysis parameters and to run the calculation. 

 The ability to set the time dependence individually for each boundary condition in dynamic 

problems. 

 Windows XP compatibility issues are fixed. 

Version 1.4 

Released: December, 2013 
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 Buckling problems  

 Thermal conductivity and thermoelastic problems. 

 Curvilinear finite elements. 

 Geometrically nonlinear problems 

 The spectral element method for linear and nonlinear two-and three-dimensional static problems 

and modal analysis 

 Support for hybrid meshes 

 Bug fixing 

Version 1.3 

Released: July, 2013 

 Beam elements 

 Shell elements 

 Geometry creation of high-speed processes by the spectral element method is added. 

 Static and dynamic nonlinear problems 

 High-order finite elements 

 Bug fixing 

Version 1.2 

Released: February, 2013 

 Computational performance is improved. 

 Plane-stress and plane-strain problems 

 The translation into cylindrical and spherical systems is added in the postprocessor. 

 The calculation of tensors invariants is added in the postprocessor.  

 The visualization of the calculation results as contour lines is added in the postprocessor. 

Version 1.1 

Released: November, 2012 

 Parameter setting and calculation launch from the Main Menu of the preprocessor are added. 

 Dynamic transient problems 

 Modal analysis 

 Hexahedral meshes support 

 The operation with projects and the calculation control system are added. 

 The postprocessor’s localization support 

 The postprocessor performance is improved. 
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Using the Program 

Performing calculations with the use of Fidesys Bundle implies the following steps: 

 Setting the geometry 

 Meshing 

 Setting boundary conditions 

 Setting the material 

 Starting calculation 

 Visualizing and analyzing results 

All of the steps except for the last one are made in preprocessor; the last step is made in postprocessor. 

Geometry 

Fidesys Bundle allows one to generate volume geometry on your own due to the built-in functionality, as 

well as to import 3D models created in different CAD-systems. 

Geometry import 

For geometry import choose File → Import in the Main menu. Fidesys Bundle supports the import of the 

following formats: 

 ACIS (*.sat, *.sab); 

 IGES (*.igs, *.iges); 

 STEP (*.stp, *.step); 

 AVS (*.avs); 

 Genesis/Exodus (*.g, *.gen, *.e, *.exo); 

 Facets (*.fac); 

 STL Files (*.stl); 

 Patran (*.pat, *.neu, *.out); 

 Ideas (*.unv); 

 Abaqus (*.inp); 

 Fluent (*.msh); 

 Nastran (*.bdf); 

 Cubit (*.cub); 

 Catia (*.CATPart, *.CATProduct, *.ncgm). 

Geometry generation 

For geometry generation Fidesys Bundle provides the user with large numbers of volume geometric 

elements (parallelepiped, cylinder, prism, cone, pyramid, sphere, torus). It also allows uniting the surfaces in 

closed volume bodies. For complex geometry generation you can use Boolean operations (Intersect, 
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Subtract, Unite volumes) and different transformations of the object (Rotate, Move, Scale, Reflect). All of the 

described functionality is available on Command Panel in Geometry section. 
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Meshing  

Fidesys Bundle supports the following types of the finite elements for meshes: 

 3D: 4-noded tetrahedron (TETRA/TETRA4), 10-noded tetrahedron (TETRA10), 8-noded hexahedron 

(HEX/HEX8), 20-noded hexahedron (HEX20), 27-noded hexahedron (HEX27), 5-noded pyramid 

(PYRAMID/PYRAMID5), 13-noded pyramid (PYRAMID13), 6-noded wedge (WEDGE/WEDGE6), 15-

noded wedge (WEDGE15); 

 2D: 3-noded triangle (TRI/TRI3), 6-noded triangle (TRI6), 4-noded quadrilateral (QUAD/QUAD4), 8-

noded quadrilateral (QUAD8), 9-noded quadrilateral (QUAD9); 

 Shells: 3-noded triangle (TRISHELL/TRISHELL3), 4-noded quadrilateral (SHELL/SHELL4), 6-noded 

triangle (TRISHELL6), 8-noded quadrilateral (SHELL8), 9-noded quadrilateral (SHELL9); 

 Beams: 2-noded beam (BEAM/BEAM2) 

 

Fidesys Bundle supports the following types of the spectral elements for meshes (see the section Spectral 

element method): 

 3D: 4-noded tetrahedron (TETRA/TETRA4), 10-noded tetrahedron (TETRA10), 8-noded hexahedron 

(HEX/HEX8), 20-noded hexahedron (HEX20), 27-noded hexahedron (HEX27), 5-noded pyramid 

(PYRAMID/PYRAMID5), 13-noded pyramid (PYRAMID13), 6- noded wedge (WEDGE/WEDGE6),15-

noded wedge(WEDGE15); 

 2D: 3-noded triangle (TRI/TRI3), 6-noded triangle (TRI6), 4-noded quadrilateral (QUAD/QUAD4), 8-

noded quadrilateral (QUAD8), 9-noded quadrilateral (QUAD9); 

Volume mesh generation 

Select volume mesh generation section on Command Panel (Mode — Mesh, Entity — Volume). 
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1. Specify the degree of mesh refinement (Action — Intervals) for each volume: 

 Select the volumes (specify their ID). You can enumerate several volumes using space after each of 

them. All of the volumes can be set by the command all. 

 Select the way of mesh generation (Auto, Approximate size, Geometry-adaptive, Interval or Sizing 

function). 

 Click Apply Scheme. 

2. Specify the type of the elements for each volume: 

 Select the entities for mesh generation (specify their ID). You can enumerate several volumes using 

space after each of them. All of the volumes can be set by the command all; 

 Select meshing scheme (tetrahedral (Tetmesh) or hexahedral elements (Automatically calculate); 

 For tetrahedral mesh generation select the level of optimization (Extreme, Strong, Heavy, Standard, 

Medium, Light, or None) and set the checkboxes in front of the corresponding points, if you need to 

minimize the over-constrained and/or sliver tets. 

 Click Apply Scheme; 

 Click Mesh. 

For complex geometry it is recommended to set the scheme of surface mesh generation first (triangular or 

quadrangular elements). 

 

Surface mesh generation 

To generate a surface mesh, follow these steps. 

1. Select surface mesh generation section on Command Panel (Mode — Mesh, Entity — Surface). 

 

2. Specify the degree of mesh refinement (Action — Intervals) for each surface: 

 Select surfaces (specify their ID). You can enumerate several surfaces using space after each of them. 

All of the surfaces can be set by the command all; 

 Select the way of mesh generation (Auto, Approximate size, Geometry-adaptive, Interval or Sizing 

function); 

 Click Apply Scheme. 
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3. Specify the type of the elements for each surface: 

 Select the entities for mesh generation (specify their ID). You can enumerate several surfaces using 

space after each of them. All of the surfaces can be set by the command all; 

 Select meshing scheme (triangular elements (Trimesh or TriDelaunay) or quadrangular elements 

(Automatically calculate); 

 Click Apply Scheme. 

To generate an irregular mesh (e.g. make it finer in the vicinity of stress concentrators), you can add nodes 

on the boundaries near geometry features, as well as split curves, surfaces and volumes in the vicinity of the 

features. 

Using the functionality available on Command Panel you can: 

 Check the mesh quality (including checking the mesh quality of individual elements: volumes, 

surfaces, curves); 

 Modify the generated mesh (Refine, Smooth, Cleanup); 

 Renumber the elements and delete the generated mesh. 

 

Setting material and element type 

Element types  

 

Fidesys Bundle makes analysis using the model made of linear isotropic material subject to Hook’s law. 

Fidesys Bundle supports the following types of the finite and spectral elements for meshes: 

 1st order 3D: 4-noded tetrahedron (TETRA/TETRA4), 8-noded hexahedron (HEX/HEX8), 5-noded 

pyramid PYRAMID5, 6-noded wedge WEDGE6; 

 2nd order 3D: 10-noded tetrahedron (TETRA10), 20-noded hexahedron (HEX20), 27-noded 

hexahedron (HEX27), 13-noded pyramid PYRAMID13, 15-noded wedge WEDGE15; 

 1st  order 2D: 3-noded triangle (TRI/TRI3), 4-noded quadrilateral (QUAD/QUAD4); 

 2nd order 2D: 8-noded quadrilateral (QUAD8), 9-noded quadrilateral (QUAD9), 6-noded triangle 

(TRI6). 

Fidesys Bundle supports the following types of the only finite elements for meshes: 

 1st order shell elements: 3-noded triangle (TRISHELL/TRISHELL3), 4-noded quadrilateral 

(SHELL/SHELL4); 

 2nd order shell elements: 6-noded triangle (TRISHELL6), 8-noded quadrilateral (SHELL8), 9-noded 

quadrilateral (SHELL9); 

 Beam elements: 2-noded beam (BEAM/BEAM2). 

Fidesys Bundle supports the following permissible combinations of elements in one model: 

 HEX/HEX8, TETRA/TETRA4, PYRAMID/PYRAMID5, WEDGE/WEDGE6, SHELL/SHELL4, 

TRISHELL/TRISHELL3, BEAM/BEAM2; 

 HEX20, TETRA10, PYRAMID13, WEDGE15, SHELL8, TRISHELL6; 

 HEX27, SHELL9; 
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 QUAD/QUAD4, TRI/TRI3; 

 QUAD8/QUAD9, TRI6. 

By default the surface element type is a shell element (SHELL 4 or TRISHELL3). Thus, in case of 2D problem, 

it is necessary to change element type to QUAD4 or TRI3. 

In case of 3D problems the element type is HEX8 or TETRA4 by default. 

By default the beam element type is BAR2 that is not supported in the current version of Fidesys Bundle. 

Thus, in this case it is necessary to change element type to BEAM/BEAM2. 

 

Note: you can find out the type of element and statistics on the specific model. For this purpose, please 

right-click on the model and select Mesh info from the drop-down list. The required information will be 

displayed in the Console. 

Material groups  

Fidesys Bundle supports the following materials: 

 Hook’s material; 

 Orthotropic material; 

 Mooney-Rivlin material; 

 Murnaghan material. 

For Mooney-Rivlin and Murnaghan materials, the following defining relations are used. 

Mooney-Rivlin potential: 

, 

where D, С1, С2 are Mooney-Rivlin material constants. 

Relation of D, С1, С2 and Poisson's ratio : 

. 

Murnaghan potential: 

 

where λ, G, C3, C4, C5 are Murnaghan material constants. 

To set the new material, select the setting material properties section on Command Panel (Mode – Blocks 

and materials, Entity – Material, Action – Create material). 
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Select a group of material properties from the drop-down list; specify the name of the material and the 

corresponding constants: 

 

 
 

Note: In order to link the material and the model, Block is used. 
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Blocks operations  

A block must contain an element type, ID and the name of the geometric model of the material. 

The sequence of operations with blocks can be schematically represented as follows:  

 To create block specifying geometric object ID; 

 To assign the material to the block; 

 To assign the element type to the block. 

Let us consider these steps in detail.  

1. To create a new block, please, go to Mode – Blocks and materials, Entity – Block, Action – 

Create. 

 

 

On the Panel below, select Action – Add, choose the entity type to be united into the block. 
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You can find out the ID of the geometrical entities united into the block as follows:  

 in the Model Tree on the left; 

 

 

 
 

 

 by clicking on geometrical objects you are interested in – their ID will automatically appear in the 

appropriate field. 

The block ID field is filled automatically. 

Click Apply.  

  

 Note: Created block must be displayed in the Model Tree on the left in the section Blocks.  

 

 

 
 

 

To look through the list of the geometric entities united into the block, enter in Command Line  
List block 1 

 In the Console, you will see the list of entities united into the block. 
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2. To assign the material to the block, select Assign Material to Block in the drop-down list. 

 

 

 

 
 

 

 

To enter the block ID, you can do it manually or click on the corresponding geometric entity. 

Available material is selected from the drop-down list. 

 

 

 

 
 

 

 

Click Apply.  
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3. To set the element type, select Element Type in the drop-down list. 

 

 

 
 

 

To enter the block ID, you can do it manually or click on the corresponding geometric entity. 

Available material is selected from the drop-down list. 

Click Apply. 

 

 



 CAE Fidesys — User Guide (version 1.6) 

 

 
  



 CAE Fidesys — User Guide (version 1.6) 

 

Changing element type chosen for the block  

 You can change the element type previously assigned to the block on the Properties page on the left.  

For this purpose, select the required block in the Model Tree and specify the new element type below in the 

drop-down list on the property page. 
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Changing material properties  

You can change the material properties previously assigned to the block on the Properties page on the left.  

For this purpose, select the required material in the Model Tree and change the constants of the material 

properties page below. After the change, message on the material editing must appear on the command 

line. For example,  

modify material 1 density 7800 
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The material properties can be also changed by using Mode – 

Blocks and materials, Entity – Material, Action – Change 

Material). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Import/Export Material 

 

To import or to export the material, click on the section Import/Export Materials on the Command Panel 

(Mode – Blocks and materials, Entity – Material, Action – Import/Export Materials). 

 

 

Moreover, Fidesys Bundle supports the import of the material in XML format. 
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Setting shell properties  

 

Fidesys Bundle supports shell elements 

SHELL/SHELL4/SHELL8/SHELL9/TRISHELL/TRISHELL3/ 

TRISHELL6.  

To specify shell properties – thickness and loft factor – go to 

Mode – Blocks and materials, Entity – Block, Action – 

Management. Further in the drop-down list, select Shell 

thickness. 

On the appeared panel, specify: 

 Block(s) ID 

 Shell thickness  

 Loft Factor 

Note: Loft Factor by default must be equal to 0.5. 

 

 

 

3D shell cross section view is possible in the Fidesys Viewer postprocessor by clicking 3D-view button 

in the default string. 

 

Setting beam properties  

 

Fidesys Bundle supports beam elements BEAM/BEAM2.  

To specify beam cross section using geometric features and moments of inertia, go to Mode – Blocks and 

materials, Entity – Beam parameters.  

On the appeared Panel, specify: 

 Block ID;  

 Coordinate System Rotation Angle; 

 cross section profile and the appropriate dimensions to it. 

Click Apply. 

Fidesys Bundle supports beam cross section of the following 

types: 

 Rectangle; 

 Ellipse; 

 I-Beam; 

 Chan-Beam; 

 T-Beam; 

 Z-Beam; 
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 Hollow Rectangle; 

 Circle With Offset Hole. 

 

 

 

3D beam cross section view is possible in the Fidesys Viewer postprocessor by clicking 3D-view 

button in the default string after the calculation is complete. 

 

To set the beam properties using inertia moments, change the 

checkbox Cross Section Profile to Set parameters.  Then the 

fields for the inertia moments will be available for editing. 

 

 

 

 

 

 

 

 

 

Setting boundary conditions  

Types of boundary conditions  

Fidesys Bundle supports boundary conditions of the following types: 

 Point Force, 

 Stress, 

 Displacement, 

 Heat Flux, 

 Convection,  

 Temperature,  

 Acceleration, 

 Speed, 

 Contact Regions, 

 Contact Pairs. 

 

 

 

To set boundary conditions, follow these steps: 
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1. Select Mode— Boundary conditions on Command Panel. 

2. Select Boundary Condition Type in Entity block. 

3. Select Action — Create. Set the following parameters: 

 ID/Name (assign a new ID, enter a name using letters and/or numbers, or use the system assigned 

ID); 

 Entity where the boundary condition is applied (Volume, Surface, Curve, Edge, Vertex, Node, 

Nodeset, Element, Side, Sideset); 

 Entity ID(s) (point mouse cursor at the field Entity ID(s) and select the necessary entities with a 

mouse, their numbers will be entered into the field automatically. If you need to specify several 

entities, mark them holding down the Ctrl key); 

 Other parameters (Value, DOFs, etc.). 

4. Click Apply. 

Using the functionality available on Command Panel you can also see the list of Boundary Conditions, 

modify or delete the boundary condition you previously set. 

Time/coordinate dependency 

The time/coordinate dependency can be specified separately for each type of boundary conditions using 

tabular and formulaic dependencies.  

The boundary conditions must be set in advance (Mode – Boundary Conditions)..  

To set the formulaic dependency on Command Panel, select the section of the boundary conditions (Mode - 

Boundary Conditions, Entity – Time dependency) and in the appeared form: 

 Select BC Type; 

 Select an individual component or an entire vector for time dependency application; 

 Select Dependency Type (formula can be entered manually, you can use the standard formulae for 

the time dependency); 

 Set Dependency Parameters. 

Click Apply. 

To view a tabular data or graphs plotted by a given formula, go to the corresponding tabs in the window 

BC Dependency. In addition, there is a possibility to export tabular data or to import new tables. 
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Here are standard formulae for the time dependency: 
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 Viewing of the tabular data corresponding to the formula -100*sin(x): 

 

 
Viewing of the graph corresponding to the formula -100*sin(x) 
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Setting contact interaction  

Contact problems are highly nonlinear and require significant computer resources to be solved. Thus, to 

select the model resulting in the most effective solution, it is very important to understand the physical 

content of the problem. Two factors determine nonlinear nature of contact problems. Firstly, it is the 

contact area and consequently, the boundary conditions are unknown until the solutions. Secondly, it is 

necessary to take into account the friction in many contact problems. Effects related to the friction can 

result in poorly converging problems. 

Contact region  

To specify contact areas, choose the setting Contact area section (Mode — Boundary Conditions, Entity — 

Contact region). 

 
The node-to-surface and node-to-curve contact interactions are realized in Fidesys Bundle 1.6. 

Note: if the contact conditions are not specified, parts in an assembly do not interact. The interaction of 

parts in the assembly at set contact areas is an obstacle to mutual penetration of parts and to the load 

transmission. 

The areas for which it is planned to set the boundary conditions for the contact, should be allocated to 

individual surfaces for volume bodies or lines in the 2D case. Contact regions should be sufficient to make 

the bodies interaction process not come out their limits but it is recommended to minimize these regions to 

save computer resources. 
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Contact pair  

To set contact interaction, it is necessary to specify Contact pair (Mode — Boundary conditions, Entity — 

Contact Pair). 

Please indicate the existing contact regions which will serve as the Master region and which will serve as 

the Slave region. 

It should be noted that the Master region is modeled by surfaces and the Slave region – by nodes. 

 

 

 

The contact regions and their numbers are displayed in the Model Tree on the left. For visualization, click 

on the name of the desired contact region in the Model Tree and it will be highlighted on the model. 
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Individual number (ID) and a set of properties are ascribed to each contact pair. The number of contact pairs 

is unlimited. To visualize a created contact pair, click on the name of the required contact pair in the same 

Model Tree on the left. The selected pair will be highlighted in yellow on the model. 
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When you create a contact pair, please keep in mind that the choice of the Master and Slave regions may 

cause different modeling results and affect the solution tolerance.  

 
In Fidesys Bundle 1.6, the following contact pair settings are available: 

 

 
 

To model the inseparable connection, please establish a tick Tied, then the Master and Slave regions 

engage in all directions until the end of the analysis if the contact has been set. 

If the motion of a solid body is limited only by the contact conditions, it is important to ensure the 

interaction elements of the contact pair in the initial state. However, in some cases, it may be difficult to 

identify the interaction. This may occur in the following cases: 

 the contours of the body can be quite complex and it is difficult to accurately determine the point at 

which the first contact happens; 
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 despite the fact that the geometric model is constructed without discontinuities, arising when 

meshing rounding errors can lead to the appearance of small gaps between the elements. 

For similar reasons, too high initial penetration of the Master region into the Slave region may occur. In 

these cases, it may cause excessively large reactive forces in the contact elements which may result in the 

divergence of solutions. Therefore, the definition of the initial contact represents perhaps the most 

important meshing aspect for the contact analysis. 

Contact algorithm  

In Fidesys Bundle 1.6 the contact algorithm Penalty Method is applied. 

 

This method requires settings for both normal and tangential stiffnesses (see Contact pair settings). The 

main disadvantage of this method is that the penetration between the two surfaces depends on these 

stiffnesses. Higher stiffness values can reduce the penetration but can lead to ill-conditioning of the global 

stiffness matrix and to the poor convergence. Ideally, sufficiently high stiffnesses must be chosen for the 

contact penetration to stay sufficiently small. At the same time, sufficiently low stiffnesses provide better 

convergence of the problem.  

In addition, when you run the task for the calculation, it is recommended to use at least 2 steps of loading 

in Nonlinear Solver Settings. 

 

 

 
 

Element Types  

Fidesys Bundle 1.6 computational algorithms allow simulating the contact without specifying an exact 

match of mesh nodes on the boundary. It does not require using any special finite elements in the contact 

area to describe the interaction details. In the process, it is not required to use any special finite elements in 

the contact area to describe the interaction details. Such approach makes it easy to set the conditions for 

interaction in contact or for tied surfaces. 
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Fidesys Bundle 1.6 supports a solution of contact problems for the following already existing finite elements: 

– 1st and 2nd order quadrilateral 2D elements QUAD/QUAD4/QUAD8/QUAD9; 

– 1st and 2nd order triangular 2D elements TRI/TRI3/TRI6; 

– 1st and 2nd order 3D hexahedron HEX/HEX8/HEX27; 

– 1st and 2nd order 3D tetrahedron TETRA/TETRA4/TETRA10; 

– 1st order 3D elements to construct hybrid meshes (pyramid PYRAMID/PYRAMID5 and wedge 

WEDGE/WEDGE6) 

Contact Status 

 
In Fidesys Viewer directly after the calculation the behavior of each contact element can be evaluated by the 

assigned status in the field Contact Status. 

This field has one component that can assume the following values: 

 STATUS = 0 – far; 

 STATUS = 2 – contact with slip; 

 STATUS = 3 – without slip (or without friction). 
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Setting the yielding model  

The choice of the correct model of the material plastic flux is very important to obtain a proper solution of 

the problem. Plasticity problems are nonlinear, therefore, they require substantial computer resources and 

solving problems with large plastic strains may take a long time. The Fidesys system of strength analysis for 

the Hook material realizes two criteria of transition into plasticity: the Mises criterion and the Drucker-

Prager criterion. Problems are solved both for perfectly elastoplastic models and for models with linear 

hardening. It is currently implemented the approach taking into account finite strains in the elastic zone; 

the linear formulation of the problem is used in the zone of plastic flux. 

Von Mises yield criterion  

In order to add the Mises plasticity to the Hook material, please select the section for setting material 

properties on the Command Panel (Mode – Blocks and materials, Entity – Material, Action – Create 

material). 

 

Choose the group of material properties from the drop-down list, specify the name of the material and the 

corresponding constants: 
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To create the model with the von Mises plasticity without hardening, set elastic properties of the Hook 

material as well as the yield strength in tension: 

 

 

 

To create the Mises plasticity model with linear hardening, it is also necessary to enter the yield strength in 

tension and the ultimate strain in tension. 
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Drucker-Prager yield criterion  

To set Drucker-Prager plastic model without hardening, it is necessary in addition to the elastic properties 

of the material to determine the yield strength in tension and yield strength in compression.  

 

 

 

In order to create Drucker-Prager plasticity model with hardening, specify also the yield strength and 

ultimate strain in tension and ultimate strain in compression. 

 

 

 

To operate with the Drucker-Prager plasticity model, it is necessary to enable the option of the ultimate 

strain when starting calculation. 
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Element types  

Fidesys Bundle 1.6 supports the solution of elastoplastic problems for the following types of already existing 

finite elements: 

– 1st and 2nd order quadrilateral 2D elements QUAD/QUAD4/QUAD8/QUAD9; 

– 1st and 2nd order triangular 2D elements TRI/TRI3/TRI6; 

– 1st and 2nd order 3D hexahedron HEX/HEX8/HEX27; 

– 1st and 2nd order 3D tetrahedron TETRA/TETRA4/TETRA10; 

– 1st order 3D elements to construct hybrid meshes (pyramid PYRAMID/PYRAMID5 and wedge 

WEDGE/WEDGE6)  
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Starting calculation  

Analysis types  

Fidesys Bundle includes the following types of analysis: 

 Static (1); 

 Dynamic (transient) (2); 

 Modal (3); 

 Buckling (4); 

 Composite materials effective properties calculation (5). 

 

When starting calculation follow these steps: 

1. Select Mode – Calculation settings on Command Panel. 

2. Select the necessary type of analysis: Static, Dynamic, Modal, or Effective properties analysis. 

3. Set the method of numerical analysis: Finite element method (by default) or Spectral element method 

(see the section Spectral Element Method). 

4. Set the parameters of the type of analysis you chose: solver type, coordinate system, fields, scheme, 

time settings (for dynamic analysis), etc. 

5. Click Apply. 

6. Click Start Calculation. 

After starting calculation its process will be displayed in the console. It will also output the messages for 

the user, including the errors in case of unsuccessful or incorrect finishing of the calculation. If the 

calculation is finished successfully, you will see the following message in the console: “Calculation finished 

successfully at <date> <time>”. 

All the calculations are made in Cartesian coordinate system by default. If necessary, you can also convert 

the results into cylindrical and spherical coordinate systems (use the appropriate filters in Fidesys Viewer). 

The dimension of the calculated problem is 2D or 3D. The following types of 2D problem are included: 

 Plane stress; 

 Plane strain. 

Stress, strain and displacement fields are calculated by default. If necessary, you can also calculate principal 

stresses, strains, and Mises stress intensity (use the appropriate filters in Fidesys Viewer). 
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The following types of solvers of linear systems (systems of linear algebraic equations (SLAE)) appearing 

while discretizing the problem, are available: 

 Direct (LU) 

 Iterative. 

The following solvers for problems of modal analysis at systems of linear algebraic equations (SLAE) are 

available: 

 Krylov- Schur; 

 Arnoldi. 

For dynamic load, one of the two calculation schemes can be used: 

 Explicit 

 Implicit. 

Models of problems  

For the calculation, the following models of problems are available: 

 elasticity; 

 plasticity (for static analysis); 

 thermal conductivity; 

 ultimate strains (for static and dynamic analysis); 

 contact. 

To choose a model, the user selects the appropriate checkboxes. Selecting multiple checkboxes 

simultaneously allows setting various combinations of models. For example, the selection of the 

checkboxes Elasticity and Elasticity gives an elastoplastic model and the selection of the checkboxes 

Elasticity and Thermal conductivity gives a model of thermoelasticity.. 

To improve the convergence of nonlinear problems, use the following settings: 

 

For nonlinear problems, convergence of iterations at each loading step can be checked in the file 

Convergence.txt. The file is downloaded into the folder that is created next to the file * .pvd which stores 

the calculation. 

For effective performance of several calculations you can use the Calculations manager (see the section 

Calculations manager). 

For visualization and analysis of the obtained results you can use the program Fidesys Viewer included into 

the package. 
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Calculations manager  

Fidesys Bundle allows performing individual calculations (see the section Starting calculation) as well as a 

cycle of calculations within one project. 

To perform a cycle of calculations, create a new project. You can do this in one of the following ways: 

 Choose File → New Project in the menu 

 Click a button on Calculations manager toolbar 

 Use the combination Ctrl+Shift+N 

In a pop-up window select a name of the project, its location and a type of geometry generation for the 

model a cycle of calculations will be based on: 

 If the model is imported (see the section Geometry generation), select this model in the same pop-up 

window. 

 If the model is created in the program with the use of geometric elements, select Use current model. 

After creating the model, generate a mesh, set boundary conditions and material, set the required 

calculation settings (see the sections Meshing, Setting boundary conditions, Setting the material, Starting 

calculation respectively), and start the calculation. In a pop-up window enter the name of the calculation (or 

leave the suggested by default), comments and settings of start and results visualization of the calculation. 

(Name is the required field. The other settings are optional.) Click Add. The calculation will be automatically 

added into the list of calculations within this project (in spite of its successful or unsuccessful performance). 

To perform another calculation, modify some of the settings of the previous one (e.g. boundary conditions) 

and start the calculation. It will be automatically added into the list of calculations within this project again 

(in spite of its successful or unsuccessful performance). 

To see your list of calculations, select the button Calculations Manager on Command Panel in the mode 

Calculations Manager and click Open Calculation Manager. 

 

 

 

In a pop-up window you will see the list of calculations with their results (successful or unsuccessful 

finishing) and calculation settings (analysis, solver, fields for the output, etc.). 

You can save all the calculations in one of the following ways: 

 Choose File → Save Project in the menu 

 Click a button on Calculations manager toolbar 

 Use the combination Ctrl+Shift+S. 
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To open the saved project, you can also use one of the three ways: 

 Choose File → Open Project in the menu; 

 Click a button on Calculations manager toolbar; 

 Use the combination Ctrl+Shift+O. 

When re-opening the saved project, all of the problem settings will be kept the same as they were in the 

last calculation you made before saving it within this project.  

Only one project can be opened at the same time. 

To close the project, you can also use one of the three ways: 

 Choose File → Close Project in the menu 

 Click a button on Calculations manager toolbar 

 Use the combination Ctrl+Shift+C 

You will be suggested to save the project so as not to lose any data. 
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Spectral element method 

It is a unique feature of Fidesys Bundle that, in addition to the of finite element method (FEM) used by 

default, it enables calculations by spectral element method (SEM).  

SEM brief description and advantages 

Spectral element method (SEM) is a FEM modification where piecewise functions are used as basic functions 

consisting of high degree polynomials.  

The main advantages of SEM in comparison to FEM: 

1) High computational speed as there is no need to solve the system of linear algebraic equations due 

to diagonal form of mass matrix. The latter is obtained by specific quadrature formula for volume 

integration. 

2) High precision of solution approximation at coarse meshing (low number of elements). The solution 

error is estimated as  

‖[𝑢]ℎ − 𝑢ℎ‖ ≤ 𝐶(𝑁), 

where  

𝐶(𝑁) = 𝐶2ℎ𝑁 for FEM 

and  

𝐶(𝑁) = 𝐶1ℎ𝑁𝑒−𝑁 for SEM. 

𝐶1 𝑎𝑛𝑑 𝐶2 are constants,  is a characteristic element size, 𝑁 is an element order, 𝑢ℎ is a numerical solution, 
[𝑢]ℎ is an exact solution in mesh nodes. 

3) Ability of effective paralleling for OpenMP, MPI and CUDA.  

SEM is most effective for the dynamic analysis using an explicit time scheme.  

Here are the results of classical problem of wave propagation in 2D plate (size 1x1). 

To achieve the computational error 2% and less, it is necessary to generate one of the following meshes: 

a) 3-noded triangular mesh of 6 390 197 elements (characteristic element size is 4e-4) 

b) 4-noded quadrilateral mesh of 1 640 961 elements (characteristic element size is 3e-3) 

c) coarse spectral element mesh with 4th element order (only 16 elements are required). 

 

 

Fig.1. Displacements 𝑈 at t1 

 

Fig.2. Displacements 𝑈 at t2 

 

 

 



 CAE Fidesys — User Guide (version 1.6) 

 

Here are the examples of computation results for different spectral element orders: 

 

 

 

2nd spectral element order 

 

4th spectral element order 

 

8th spectral element order 

 

12th spectral element order 
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SEM Usage  

In order to use the method of spectral elements instead of the finite element method to solve the problem, 

select the checkbox Use spectral elements method in the general settings:  
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Parallel calculations on several computers using MPI technology  

If you have a network of several computers with installed САЕ Fidesys software MPI technology allows you 

to combine their computing capacity for parallel solution of the same problem. 

MPI brief description and advantages  

MPI technology currently represents a standard for parallel computing in distributed memory systems, i.e. 

those in which each processor has its own independent address space and communicates with the other 

processors via messages. MPI technology is more effective in solving problems with a large number of 

degrees of freedom because, on the one hand, it allows solving problems that do not fit in the computer 

memory and, on the other hand, large FEM or SEM problems require relatively low intensity of the messages 

exchange between the processors and thus they less load the network connection. This is particularly 

important for systems with distributed memory in which processors are connected by the common network 

with a capacity of 100 Mbit/s as if several computers in the office.  

MPI implementation  in Fidesys 

Fidesys provides the ability to use MPI with the following types of calculations:  

 Statics; 

 Dynamics; 

 Modal; 

 Buckling.  

Here are supported models to calculate via MPI: 

 Elasticity; 

 Elastoplasticity; 

 Thermal conductivity; 

 Thermoelasticity; 

 Finite deformations. 

MPI installation 

Intel MPI installs and runs in conjunction with the installation of the Fidesys Bundle software package. If the 

Intel MPI version has already been installed on your computer and you do not want to replace it, please 

contact Fidesys customer support for instructions on how to install and configure it. 

In order to use when calculating the MPInecessary to put a tick Use MPI in the Toolbar in the General 

settings of the selected calculation type. You will then see a special menu MPI Settings to specify needed 

parameters.  

In the pop-up MPI settings, select parallelization mode: 

a. Local – the calculation will be carried out on the local machine using a specified number of 

processors. The mode gives a gain in comparison to the calculations without MPI only for the 

local configuration with a large number of cores. 

b. Multiple hosts. In this mode, the calculation will be launched on several computers. 
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MPI local usage  

In order to use MPI locally on a single computer, you need to register at first (see below). Then go to the 

MPI Settings Panel, tick Local and select the number of processors in a special window. After this, you can 

start the calculation, no additional settings for MPI local use is not required.  

 

 

 

 

MPI usage on several nodes  

Requirements for the correct operation  

1. Make sure that the firewall settings on all computers allow correct operation of MPI.  

2. It is recommended to disable the firewall on all computers involved in the parallel calculations. 

3. Fidesys should be installed on the same path on all computers. This path cannot be network.  

4. The path to FidesysCalc must be the same on all computers involved in the parallel calculations. 

5. The working directory (the directory where the file .pvd and file folder of the calculation results are 

written) should be available at all nodes on the same path which can be network. The user on whose 

behalf the calculation is carried out must also have write access to the work directory in all nodes. 

To find out which way is the working directory, you can go to the Menu Tools → Settings → Paths, 

the string Working Directory. In other words, the calculation should be stored in a network folder, 

while the network path should be indicated in the save dialog: 

 

 

 
 

 

6. There are no special restrictions on the connection speed between the nodes but you should keep in 

mind that if the connection speed is very slow, the calculation using the MPI can take as much or 

more time than the calculation without MPI as all the time saved will be spent on the data exchange 

between nodes. 

7. This software version has no limit on the number of used nodes. 
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MPI setting on several nodes  

After making sure that all of the above requirements are met, go to the MPI settings panel (Calculation 

Settings – Static – General – Use MPI). Put a checkbox next to the point Multiple hosts and click 

Configure…: 

 

 

 

You will see the following window: 

 

Using Add and Delete, add to the list all the hosts you use, in the field Name write the host name in the 

network, in the field Processors indicate the number of processors used on the host. After completing the 

list, click Ok.  
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After this, the number of hosts indicated in parentheses after the words Multiple hosts on the MPI settings 

panel should change: 

 

 

Now you can specify other calculation settings and run it as usual; it will be carried out using the MPI on 

several nodes. 

Registration before the first usage  

If you try to carry out the calculation using MPI for the first time, you should see the following window: 

 

 

In order to register (without this step, the calculation is impossible), click Yes. You will see Windows 

terminal window which you will need to enter Windows username and password on behalf of which you 

launch the calculation using MPI.  

 

You can also register by running the Windows terminal window from the panel "Start" (to do this, type in the 

search box «cmd») and by typing the command mpiexec –register in the window. Then you need to enter 

login and password in the same way as when registering using a pop-up Fidesys window. 

 

If you have already registered the service, tick Do not show this message again. 

 

For more information, see the Intel MPI documentation. 
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Overview of the calculation results  

After performing the calculation using MPI, in the Fidesys Viewer postprocessor the new field MPI Nodes 

should appear that characterizes a partition on the specified earlier processors: 

 

 
 

Calculation example using MPI  

You can see an example of calculation on two computers in the picture below. Parts that are calculated on 

various computers are presented in different colors. 
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Heterogeneous materials effective property calculation  

 

In Fidesys Bundle there is the possibility of calculating the effective properties of an heterogeneous material, 

for example, composite or porous material. The calculation is carried out only in 3D case. 

 

Geometry of the model for effective property calculation  

A representative volume is a geometric model for calculating the effective properties of the material of 

nonperiodic structures, i.e. the volume by which behavior under deformation you can be judged on the 

behavior of the material in general. This typically means that the size of the representative volume should 

be approximately an order of magnitude greater than the characteristic pore size or the inclusions in the 

material. A periodicity cell may be a geometric model for the calculation of the effective properties of 

periodic structure material. 

It is important that the geometric model for the calculation of the effective properties must always be a 

fragment of material «cut» out of it in the form of a rectangular parallelepiped. When calculating, this 

fragment should be positioned so that the edges of the parallelepiped were strictly parallel to the 

coordinate planes. Automatic checking of the model form and position to calculate the effective properties 

is not provided, this should be controlled by the User – otherwise the calculation can pass and be correctly 

completed but the results will be misleading. 

Examples of valid models for the calculation of the effective properties are shown below. If the tested 

material is solid (left), then the model for calculating its effective properties must be a solid rectangular 

parallelepiped with edges parallel to the coordinate planes. If the material contains pores or cavities, then 

the model for the calculation must contain cavities that may come to the surface (as shown on the right).  

 

 

  

  

Generation of periodicity cell geometry of some composite materials with periodic structure in Fidesys 

Bundle can be performed automatically. In the geometry control mode, there is a button «Create Composite» 

as shown below. 
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You can create periodicity cells of the following composite types  

 Fiber-layered (two-layer) composite; 

 single-layer fiber; 

 single-layer fiber with shells; 

 dispersed fiber reinforced (spherical inclusions); 

 dispersed fiber reinforced with shells. 

The user needs only to set the parameters of materials and click "Create" - the geometry will be generated 

automatically by means of the Fidesys Bundle interface. It stands to reason, the user can also create the 

geometry for the calculation manually by means of the interface or to import; the most important thing is 

that the geometric model for the calculation of the effective properties is «cut» out of the material in form 

of the rectangular parallelepiped with edges parallel to the coordinate system in the Fidesys Bundle 

interface. 

Starting calculation  

After creating the geometry, it is necessary to carry out the same actions as when calculating for static load: 

blocks creation, finite element mesh generation, material properties setting, etc, except for the boundary 

conditions application. To calculate the effective properties, it is unnecessary to apply the boundary 

conditions to the model: when calculating a number of boundary conditions types are automatically applied 

to the model sequentially; of the static load problem is solved for each type; results of all the problems are 

averaged and, as a result of averaging, the effective properties of the material are calculated. The user only 

needs to choose the type of boundary conditions: periodic or nonperiodic. 
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Periodic boundary conditions are preferred if the effective properties of the material of periodic structure 

are calculated and the periodicity cell serves as a model for the calculation. For example, if the material is a 

composite with matrix and inclusions, moreover, the stiffness of the inclusions is much higher than the one 

of the matrix and the inclusions are located on the surface of the model for the calculation – in this case it 

is necessary to use periodic conditions. If the effective properties of the material of irregular structure are 

studied and a representative volume is a model for the calculation, then the nonperiodic boundary 

conditions are preferred. 

In Fidesys Bundle 1.6 it is the SLAE direct solver that is available to calculate the effective properties. 

Element types  

Fidesys Bundle 1.6 supports the effective properties calculation for the following existing finite elements: 

 1st order 3D hexahedron HEX/HEX8; 

 1st order 3D tetrahedron TETRA/TETRA4. 

Effective property calculation and its results  

As mentioned, to calculate effective properties the model undergoes a series of strains. The following types 

of strains are used: 

 tension (along each of the coordinate axes); 

 shears (in each of the coordinate planes). 

The strain magnitude is 0.2% for all types. 

Effective properties are evaluated in the form of the generalized Hook's law: 

 

The result of the calculation is effective elastic modules  displayed to the command line and in the file 

called Cijkl.txt in the working directory. The modules are evaluated in the coordinate system where the 

calculation was carried out (which coordinate planes are parallel to the edges of calculation model). 

Modules  contain 21 independent constants – it is often more than it is necessary to describe effective 

properties of the tested heterogeneous material. That is why there is a possibility of the automatic 

conversion of the obtained effective elastic modules into constants of orthotropic, transversally isotropic or 

isotropic material. After completing the calculation of the effective properties, the window «Process 

effective properties data» opens. In the window, obtained effective elastic modules  are shown at the 

bottom right in the form of a symmetric matrix sized 6x6 (the matrix part below the main diagonal is not 

displayed by the symmetry). 

When the calculation is complete, the window opens automatically. If the user closes it, it can be re-opened 

in the mode Blocks and materials -> Material Management -> Create the material using calculated effective 

properties: 
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The user can assess whether the matrix with obtained  to orthotropic materials with the satisfying 

tolerance. For the exact orthotropic material, the matrix should look as follows (where the letters X denote 

those components that can be nonzero). 

 

However, since the components of the matrix are the result of numerical calculation of effective properties - 

they tend to contain some errors. If, from the user's point of view, the matrix corresponds to orthotropic 

materials with acceptable tolerance, select the «Orthotropic» type of material and click «Process Data» 

resulting in the fact that nine constants of orthotropic material will be counted. 

If orthotropic constants in the X and Y will coincide with acceptable tolerance the user can select the type 

of material «Transversely isotropic» and click «Process data». Five constants of the transversally isotropic 

material will be calculated. 

But if orthotropic constants do not depend on the direction then you can select the type of material 

«isotropic» and again click «Process data». Two constants of an isotropic material – Young’s Modulus and 

Poisson's Ratio – will be calculated. 

The window exterior «Process effective properties data» is shown in the figure below. 
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If the processed material constants satisfy the user, the option to export the material into the file XML is 

available in the same window. You must select a name for the effective material and the name of the XML 

file into which it will be exported. When you click «Export Material…», the material with the specified name 

and obtained effective properties are first created whereupon all other created materials are exported into 

an XML file with the specified name. You can then import these materials from the created file. 

If heterogeneous material which efficient properties are investigated is orthotropic, transversely isotropic or 

isotropic from empirical considerations; and the calculation results do not correspond to that – you should 

try to refine the mesh or to choose a model for the calculation in another way.  
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Results Visualization and Postprocessing 

Fidesys Viewer at a glance 

The program Fidesys Viewer is used for visualization and analysis of the obtained results: 

 Visualization of vector and tensor fields 

 Graph 

 Time dependency analysis 

Fidesys Viewer is included into the package Fidesys Bundle and does not require individual installation. To 

use Fidesys Viewer, the license is not required: the results of calculations obtained by using the Fidesys 

Bundle preprocessor are available for viewing in Fidesys Viewer even after the expiration of the license. 

Main Window 

 

Workbench (1) displays the model and visual effects. 

Main Menu (2) includes standard operations for working with files and projects, managing the visualization 

modes, panel display settings, filters, tools, and help available in the drop-down lists of the menu. 

Toolbar (3) comprises the buttons for calling the most frequently used commands while working with the 

program. 

Pipeline Browser (4) includes the opened models and filters applied to them. 

Properties Page (5) displays the properties of the selected object in the Workbench or in the Pipeline 

Browser. 

Additional panels can be shown or hidden in the menu View. 
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Basics of the program 

Fidesys Viewer allows you to view and analyze the results. Viewing and analysis are performed using 

multiple filters you can select the item View in the menu. Some of them are described below. 

Display on the data field and legend model  

Fields and components of display can be selected in the Toolbar: 

 

You can also see the Color Map by clicking in the Toolbar. 

Selection  

In order to select points or cells, use the following buttons in the Toolbar: 

 

On-screen information display  

Numerical results for the data fields can be viewed in the tab Information. If the entire model is in focus, 

the fields of the tab Information contain a range of data – from minimum to maximum value. 

The values in points can be found using the filter Probe Location (Filters →  Alphabetical →  Probe Location). 

Then you must specify the viewing point coordinates. After applying the filter, data field values are 

displayed only for the specified point in the tab Information. 

To view the numerical results for the selected points is also possible by clicking Point Information 

on the Toolbar.  

The values in the points/nodes/elements can be identified and viewed by using Selection Inspector (View →

Selection Inspector).  

 

Overview of the strained model  

To view the strained model, select Filters →  Alphabetical →  Warp By Vector. In the Properties tab, you can 

select the display scale. 

To quickly access the filter, click Warp By Vector  on the top panel. 

 

Spherical/cylindrical coordinate systems  

To receive data from the spherical or cylindrical coordinate systems, select Filters →   Alphabetical → 

Coordinate systems. Next, select the data field that you want to represent in new coordinates. After 

applying the filter, a new data field will appear in the tab Information, for example, Stress (spher.). 

Graphing along straight line  

To graph along a straight line, select Filters →   Alphabetical → Graph along a straight line.  
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Specify coordinates of the beginning and end of the line. In the tab View, select the appropriate data field to 

display in the graph. 

Graphing along curves  

To graph along a curve, select nodes (see par. Selection) for which graph will be plotted. Next, use Filters →   

Alphabetical → Extract selected and then Filters →   Alphabetical → Show data.  

Graphing in time dependency  

To plot a time dependency graph, you should allocate points of interest through the Allocation Inspector or 

by the button Select points in the standard string and then apply the filter Filters →   Alphabetical → Graph 

selected in time dependency. 

Mises stresses  

To obtain Mises stress intensity select Filters →   Alphabetical →  Invariants. After applying the filter data 

field Stress (Mises) will appear in the tab Information. Quick access button is located in the Fidesys Viewer 

standard string: 

 
 

Estimation of the mesh quality  

To estimate the mesh quality, select View → Filters → Alphabetical → Mesh Quality. Specify the necessary 

settings in the tab Properties. After applying the filter, the new fields which analysis allows  concluding 

about the mesh quality will appear in the tab Information. 

Slice  

To view the model slice, select Filters → Alphabetical → Slice. Specify the normal or the direction in which 

you want to make the slice.  

Cross section  

To view the model cross section, select Filters → Alphabetical → Cross section. Specify the normal or the 

direction in which you want to make the slice.  

Beam and shell 3D-display  

To view beams and shells in 3D in the Fidesys Viewer postprocessor, you can click on the button 3D 

in the standard string. 

Margin of Safety 

To view the model cross section, select Filters → Alphabetical → Margin Of Safety. If the ultimate strength 

and yield strength were not specified when preprocessing, you should set them in the tab Properties. 

Margin of safety is calculated by the first theory of strength, energy theory, Tresca theory, Mohr’s theory of 

failure, Pisarenko-Lebedev theory. Obtained values can be viewed in the tab Information in the new field 
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Margin Of Safety. The first component of the field is the margin of safety by the first theory of strength; the 

second is the margin of safety by the energy theory, etc. 

 

Smoothed results  

To smooth the obtained results, select Filters → Alphabetical → Consistent results. Select the field which 

numerical data are to be converted. After applying the filter a data field, for example, the Stress (smoothed), 

will be displayed in the tab Information. 

Data saving 

To get numerical values of the obtained results, save the data in .csv format. Click Ctrl+S or select File → 

Save to do this. The saved file is an ordinary table of numerical data which can be opened in any text editor.  

For dynamic problems, saving the model variation under deformation is available. Select File → Save 

Animation to do this. 
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Step-by-Step User Guide 

Solving any problem using FIDESYS package includes 6 basic steps: 

 Model generating 

 Meshing 

 Setting boundary conditions 

 Setting the material 

 Starting calculation 

 Results analysis 

 See some examples with step-by-step guide below. 

Static analysis (3D) 

NAFEMS test “Thick Plate Pressure”, Test No LE10, Date/Issue 1990-06-15/2. 

The problem of static load of an ellipsoid plate is being solved.  

The pictures below represent a geometric model of the problem: 

  

Displacements along the normal to the sides are constrained in the side slices of the plate. All of the points 

of the outer curvilinear surface are fixed in the XY plane. The outer curvilinear surface is fixed along the 

middle line of displacements along Z axis. The pressure to the upper side is 1 MPa. The material parameters 

are E = 210 hPa, ν = 0.3. 

Test pass criterion is the following: stress σyy at the point D is -5.38MPa to within 3%. 
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Geometry creation 

1. Create the first elliptic cylinder. 

Select volume geometry generation section on Command Panel 

(Mode — Geometry, Entity — Volume, Action — Create). Select 

Cylinder in the list of geometric elements. Specify the cylinder 

dimensions:  

 Height: 0.6 

 Cross section: Elliptical 

 Major Radius: 2 

 Minor Radius: 1 

Click Apply.  

 

 

 

 

 

 

 

 

2. Create the second elliptic cylinder.  

Select volume geometry generation section on Command Panel 

(Mode — Geometry, Entity — Volume, Action — Create). Select 

Cylinder in the list of geometric elements. Specify the cylinder 

dimensions:  

 Height: 0.6; 

 Cross section: Elliptical; 

 Major Radius: 3.25; 

 Minor Radius: 2.75. 

Click Apply. 

As a result, two generated entities are displayed in the Model Tree 

(Volume 1 and Volume 2): 
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3. Subtract the first cylinder from the second one . 

Select volume geometry generation section on Command Panel 

(Mode — Geometry, Entity — Volume, Action — Boolean). Select 

Subtract in the list of operations. Set the following parameters: 

 Volume ID(s): 1 (the volumes to be subtracted); 

 From Volume ID(s): 2 (volumes from which other volumes will 

be subtracted); 

 Imprint. 

 Click Apply. 

As a result, only one volume is displayed in the Model Tree 

(Volume 2). 

 

 

 

 

4. Leave a quarter of a volume (symmetry of the problem). 

 

 

 

 

 

Select volume geometry generation section on Command Panel 

(Mode — Geometry, Entity — Volume, Action — Webcut). Select 

Coordinate Plane  in the list of possible webcut types. Set the 

following parameters:  

 Volume ID(s): 2 (the volume to be webcut); 

 Webcut with: YZ Plane; 

 Offset value: 0; 

 Imprint. 

Click Apply. 

 

Do the same for the ZX Plane: 

 Volume ID(s): 2 (the volume to be webcut); 

 Webcut with: ZX Plane; 

 Offset value: 0; 

 Imprint. 

Click Apply. 
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As a result, the original volume in the Model Tree is split into three (Volume 2, Volume 3 and Volume 4). 

 

  

Delete the volumes 2 and 3. To do this, select these volumes in the Model Tree holding down Ctrl and click 

Delete in contextual menu. As a result, a quarter of the original volume is left (Volume 4): 
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5. Split the outer curvilinear surface into two (it is necessary for restraining this surface from 

displacements along the middle line). 

Select surface geometry modification section on Command Panel (Mode — Geometry, Entity — Surface, 

Action — Modify). Select Split in the list of possible operations. Set the following parameters: 

 Surface ID(s): 28 (the surface to be split along the middle line); 

 Split Method: Direction Curve; 

 Direction Curve ID: 44. 

Click Apply. 

As a result, the outer curvilinear surface is split into two, and two new surfaces (Surface 32 and Surface 33) 

are displayed in the Model Tree instead of Surface 28: 

 

Meshing  

It is necessary to calculate the value at the point D, that is why the generated mesh should be refined in the 

vicinity of the point. 

1. Select meshing on curves section on Command Panel (Mode — Mesh, Entity — Curve, Action — Mesh). 

Specify the parameters of mesh refinement: 

 Select Curves: 46 44 45 43 (using space after each curve); 

 Select the way of meshing: Equal; 

 Select the checkbox Interval; 

 Specify the number of intervals: 6 

Click Apply. 

Click Mesh. 
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Select meshing on curves section on Command Panel (Mode — Mesh, Entity — Curve, Action — Mesh). 

 Select Curves: 14 41 39 12 (using space after each curve); 

 Select the way of meshing: Equal; 

 Select the checkbox Interval; 

 Specify the number of intervals: 3; 

Click Apply. 

Click Apply Scheme 

 

2. Select volume mesh generation section on Command Panel (Mode — Mesh, Entity — Volume, Action — 

Mesh). 

 Select Entities to Mesh (specify their ID): 4 (or by the command all); 

 Select Meshing Scheme: Polyhedron. 

Click Apply Scheme.  

Click Mesh. 
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The resulting number of elements can be viewed in the Property Page by clicking on the inscription Volume 

4 in the Model Tree on the left.  

To view the mesh properties, you can follow these steps: 

 Select the entire model  

 Right-click on the model 

 In the pop-up menu, select List Information – List Mesh Info  

 Information on the mesh will be displayed in Command Line  
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Setting boundary conditions 

1. Fix one side (slice) along X axis. 

Select Mode — Boundary Conditions, Entity — Displacement, Action — Create on Command Panel. Set the 

following parameters: 

 System Assigned ID 

 Entity List: Surface 

 Entity ID(s): 11 

 Degrees of Freedom: x-Translation 

 DOF Value: 0 

 Click Apply. 

 

2. Fix one side (slice) along Y axis. 

Select Mode — Boundary Conditions, Entity — Displacement, Action — Create on Command Panel. Set the 

following parameters: 
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 System Assigned ID 

 Entity List: Surface 

 Entity ID(s):  27 

 Degrees of Freedom: y-Translation 

 DOF Value: 0 

 Click Apply.  

3. Fix the outer curvilinear surface along X and Y axes. 

Select Mode — Boundary Conditions, Entity — Displacement, Action — Create on Command Panel. Set the 

following parameters: 

 System Assigned ID 

 Entity List: Surface 

 Entity ID(s):  32 33 

 Degrees of Freedom: x-Translation and y-Translation 

 DOF Value: 0 

 Click Apply. 

 

4. Fix the middle line of the outer curvilinear side along Z axis. 

Select Mode — Boundary Conditions, Entity — Displacement, Action — Create on Command Panel. Set the 

following parameters: 

 System Assigned ID 

 Entity List: Curve 

 Entity ID(s):  47 

 Degrees of Freedom: z-Translation 

 DOF Value: 0 

 Click Apply. 



 CAE Fidesys — User Guide (version 1.6) 

 

 

5. Apply pressure to the upper side. 

Select Mode – Boundary Conditions, Entity – Pressure, Action – Create. Set the following parameters: 

 System Assigned ID 

 Entity List: Surface 

 Entity ID(s): 31 

 Magnitude Value: 1e6 (an exponential number format using the Latin letter“e” is supported ) 

 Click Apply. 
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All applied boundary conditions must be displayed in the Model Tree on the left. In addition, the boundary 

conditions are available for editing from the Model Tree. 

To view all the applied boundary conditions also click Show BC on the top panel.  
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Setting material and element type 

1. Create the material.  

Select setting the material properties section on Command Panel (Mode — Blocks and Materials, Entity — 

Block, Action — Create Material). Set the following parameters:  

 Name: Material1; 

 Description: Hook material  

 Properties group: Hook material; 

 Young’s Modulus: 210e9; 

 Poisson’s Ratio: 0.3. 

Click Apply. 
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2. Create a block of one type of the material.  

Select setting the material properties section on Command Panel (Mode — Blocks and Materials, Entity — 

Block, Action — Manage). Select Add in the list of possible operations. Set the following parameters: 

 Block ID: 1; 

 Select the entities to be united into block: Volume; 

 ID(s): 4 (or by the command all). 

Click Apply. 
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3. Assign the material to the block.  

Select setting the material properties section on Command Panel (Mode — Blocks and Materials, Entity — 

Block, Action — Manage). Select Assign Material to Block in the list of possible operations. Set the following 

parameters: 

 Block ID(s): 1 

 Select the previously created material in the list: FEA Material 1 

Click Apply. 
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4. Assign the element type.  

Select material properties setting section on Command 

Panel (Mode — Blocks and Materials, Entity — Block, 

Action — Manage). Select Element type in the list of 

possible operations. Set the following parameters:  

 Block ID(s): 1; 

 Select: Volumes; 

 Volumes: HEX27. 

Click Apply. 

 

 

 

 

 

 

Starting calculation  

1. Set the type of the problem to be solved.  

Select calculation settings section on Command Panel (Mode — Calculation settings, Calculation settings — 

Static, Static — General). Select: 

 Dimension: 3D; 

 Model: Elasticity.  

Click Apply. 

2. Set the solver settings. 

Select calculation setting section on Command Panel (Mode — Calculation settings, Calculation settings — 

Static, Static — Solver). Select the solver method (direct or iterative) and set Convergence Parameters in 

case of choosing an iterative one. You can also leave all the settings by default.  

Click Apply.  

Click Start Calculation.  

3. In a pop-up window select a folder to save the result and enter the file name. 

4. If the calculation is finished successfully, you will see a message in the Console: “Calculation finished 

successfully at <date> <time>”.  
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Results analysis 

1. Open the file with the results. You can do this in one of the three ways. 

 Press Ctrl+E. 

 Select Calculation → Open Results in the Main Menu. Click Open last result. 

 Select Calculations Manager on Command Panel (Mode – Calculations Manager, Calculations 

Manager – Results). Click Open Results.  

 

To apply all of the filters changes automatically, click Apply changes to parameters automatically on 

Command Panel. 

 

2. Display the component yy of the stress field and the mesh on the model. 

In Fidesys Viewer window set the following parameters on Toolbar: 

 Representation Mode: Surface; 

 Representation Field: Stress; 

 Representation Component: 22. 

 Surface with edges. 

 

3. Select a point where you need to view the stress. 

In the Main Menu, choose View – Allocation Inspector. 

Select a point on the model by using Select Points Through.  

 

Select a point D on the upper side. The node number (243) should be displayed in Selection Inspector on 

the right.  

In Allocation Inspector, go to the tab Point Tag and select the following settings: 

 Enable Visibility; 

 Tag Mode: Stress; 

As a result, Stress components at the point D is displayed at the picture. 
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4. View a numerical value σyy at the selected point D. 

The difference between the obtained value -5.294807e+06 and the required one -5.380e+06 is 1.61%. 

5. Download numerical data. 

Select File → Save Data in the Main Menu or click Ctrl+S. Enter the file name (*.csv format), leave it by 

default. Click ОК. The saved file is an ordinary table of numerical data which can be opened in any text 

editor. 

6. You can see the way the body is deformed under the applied pressure. 

Select the filter Warp By Vector to do this. Set the following parameters in the tab Properties: 

 Vectors: Displacements; 

 Scale Factor: 5000. 
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As a result, the deformed body is displayed at the picture. To see the original model, click near it in the 

Model Tree. The picture below shows the deformed (solid grey filling) and the original model (with the field 

of displacements distribution along Y axis). 

 

Using Console Interface 

For geometry generation, meshing, setting boundary conditions and materials you can use Console 

Interface. The following program code allows performing the steps of the above-described guide you only 

need to manually specify the full path and name of the file to be saved. 

Here is an example of the working script (the file is saved in D:/FidesysBundle/calc/example.pvd) 
 

reset 
set node constraint on 
create Cylinder height 0.6 major radius 2 minor radius 1  
create Cylinder height 0.6 major radius 3.25 minor radius 2.75  
subtract body 1 from body 2 imprint  
webcut body 2 with plane xplane offset 0 imprint  
webcut body 2 with plane yplane offset 0 imprint  
delete Body 3 
delete Body 2 
split surface 28 direction curve 44 
curve 46 44 45 43 interval 6 
curve 46 44 45 43 scheme equal 
curve 46 44 45 43 interval 6 
curve 46 44 45 43 scheme equal 
mesh curve 46 44 45 43  
curve 14 41 39 12 interval 3 
curve 14 41 39 12 scheme equal 
curve 14 41 39 12 interval 3 
curve 14 41 39 12 scheme equal 
mesh curve 14 41 39 12 
volume 4 scheme Polyhedron 
volume 4 scheme Polyhedron 
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mesh volume 4  
create displacement on surface 11 dof 1 fix 0  
create displacement on surface 27 dof 2 fix 0  
create displacement on surface 32 33 dof 1 dof 2 fix 0  
create displacement on curve 47 dof 3 fix 0  
create pressure on surface 31 magnitude 1e6  
undo group begin 
create material "material 1" property_group "CUBIT-FEA" description "Hook material"  
modify material "material 1" scalar_properties "MODULUS" 2.1e+11 "POISSON" 0.3  
undo group end 
set duplicate block elements off 
block 1 volume 4  
block 1 material 'material 1' 
block 1 element type hex27 
analysis type static elasticity dim3 
spectralelement off 
usempi off 
solver method auto try_other off 
solver method auto try_other off 
calculation start path "D:/FidesysBundle/calc/example.pvd" 
 

 It is also possible to run the file Example_1_Static_3D.jou by selecting Journal Editor on Toolbar. In 

a pop-up window of the main menu select File → Open and open the necessary journal file. 
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Static load (gravity force) 

R.J. Roark, Formulas for Stress and Strain, 4th Edition? McGraw-Hill Book Co., Inc., New York, NY, 1965, pg 112, no. 

33  

The problem of the tube bending of under gravity force is to be solved. The pictures below represent a 

geometric model of the problem: 

 

  

 

The side edges are rigidly fixed on all displacements and rotations. Material parameters are E = 30e6 psi, ν = 

0.0, =0.00073 lb-sec2/in4. The gravity force is defined via the acceleration g=386 in/sec2. The geometrical 

dimensions of the model: L=200 in, d0=2 in, di=1 in. 

Due to the symmetry of the problem, half tube will now be considered (L/2). 

 

 

 

 

 

 

 

 

Test pass criterion is the following: displacement in the center of the tube uyy at the point D (0, d0/2, 0) is -

0.12529 within 3%.  

  



 CAE Fidesys — User Guide (version 1.6) 

 

Geometry creation 

1. Create the first circular cylinder. 

Select volume geometry generation section on Command Panel (Mode — Geometry, Entity — Volume, 

Action — Create). Select Cylinder in the list of geometric elements. Specify the cylinder dimensions:  

 Height: 100; 

 Cross section: Circular; 

 Radius: 1; 

Click Apply. 

 

 

 

 

 

2. Create the second cylinder.  

Select volume geometry generation section on Command Panel 

(Mode — Geometry, Entity — Volume, Action — Create). Select 

Cylinder in the list of geometric elements. Specify the cylinder 

dimensions:  

 Height: 100; 

 Cross section: Circular; 

 Major Radius: 0.5; 

Click Apply. 

As a result, two generated entities are displayed in the Model 

Tree (Volume 1 and Volume 2). 
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3. Subtract the first cylinder from the second one.  

Select volume geometry generation section on Command Panel 

(Mode — Geometry, Entity — Volume, Action — Boolean). Select 

Subtract in the list of operations. Set the following parameters: 

 Volume ID(s): 1 (the volumes to be subtracted); 

 From Volume ID(s): 2 (volumes from which other volumes will 

be subtracted); 

 Imprint. 

 Click Apply. 

As a result, only one volume is displayed in the Model Tree (Volume 

1). 

 

 

 

 

 

 

 

 

 

 

4. Place the volume to the coordinate origin.  

Select volume geometry generation section on Command Panel 

(Mode — Geometry, Entity — Volume, Action — Modify). Select Move 

from the list of possible types of slices. Set the following 

parameters:  

 Volumes ID: 1 (the volume to be cut); 

 Checkbox Distance; 

 Distance along the Z axis: 50; 

Click Apply. 

 

Thus, the center of the left end of the tube is placed in the origin of 

coordinates.  
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Meshing  

1. Set the approximate size of the elements. 

Select volume mesh generation section on Command Panel (Mode — Mesh, Entity — Volume, Action — 

Intervals). Specify the approximate size of the elements: 

 Select volumes: 1; 

 Select Approximate size from the drop-down list; 

 Approximate size: 0.25; 

Click Apply. 

 

2. Select the way of mesh generation. 

Select volume mesh generation section on Command Panel (Mode — Mesh, Entity — Volume, Action —

Mesh). 

 Select volumes: 1; 

 Select meshing scheme: Polyhedron; 

Click Apply. 

Click Mesh. 

 

The resulting number of elements can be found on the property page by clicking on Volume 1 in the Model 

Tree on the left.  

To view the mesh properties, you can follow these steps: 

 Select the entire model  

 Right-click on the model 

 In the pop-up menu, select List Information – List Mesh Info  

 Information on the mesh will be displayed in Command Line  
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Setting boundary conditions  

1. Fix the right lateral edge at all directions. 

Select Mode — Boundary Conditions, Entity — 

Displacement, Action — Create on Command Panel. Set the 

following parameters: 

 System Assigned ID; 

 Entity List: Surface; 

 Entity ID(s):  8; 

 Degrees of Freedom: All; 

 DOF Value: 0. 

 Click Apply. 

 

2. Fix the left lateral edge along X and Z axes by 

analogy. 

Select Mode — Boundary Conditions, Entity — 

Displacement, Action — Create on Command Panel. Set the 

following parameters: 

 System Assigned ID; 

 Entity List: Surface; 

 Entity ID(s):  9; 

 Degrees of Freedom: X-Component, Z-Component; 

 DOF Value: 0. 

 Click Apply. 
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3. Set the gravity force using the acceleration. 

Select  Mode — Boundary Conditions, Entity — Acceleration, 

Action — Create on Command Panel. Set the following 

parameters: 

 System Assigned ID; 

 Entity List: Volume; 

 Entity ID(s):  1; 

 Degrees of Freedom: Acceleration Y; 

 DOF Value: -386. 

 Click Apply. 

Note: The acceleration is set for mass forces taking into account 

the sign. In this case, the acceleration g acts in the negative 

direction of the Y axis. 

 

 

 

 

 

 

 

 

 

 

 

Setting material and element type  

1. Create the material.  

Select setting the material properties section on Command Panel (Mode — Blocks and Materials, Entity —

Material, Action — Create Material). Set the following parameters:  

 Name: Material 1; 

 Description: Hook material 

 Property group: Hook material; 

 Young’s Modulus: 30e6; 

 Poisson’s Ratio: 0; 

 Density: 0.00073.  

Click Apply. 
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2. Create the block of one material type.  

Select setting the material properties section on Command Panel (Mode — Blocks and Materials, Entity — 

Block, Action — Manage). Select Add in the list of possible operations. Set the following parameters: 

 Block ID: 1;  

 Select entities to be united into the block: Volume; 

 ID: 1 (or by the command all). 

Click Apply. 
  



 CAE Fidesys — User Guide (version 1.6) 

 

 
 

3. Assign the material to the block.  

Select setting the material properties section on Command Panel (Mode — Blocks and Materials, Entity — 

Block, Action — Manage). Select Assign Material to Block in the list of possible operations. Set the following 

parameters: 

 Block(s) ID: 1; 

 Select the previously created material in the list: Material 1. 

Click Apply. 
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4. Assign the element type.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity — Block, Action 

— Manage). Select Element Type in the list of possible 

operations. Set the following parameters:  

 Block(s) ID: 1; 

 Select: Volumes; 

 Volumes: HEX8. 

Click Apply. 

 

 

 

Starting calculation 

1. Set the type of the problem to be solved.  

Select calculation setting section on Command Panel (Mode 

— Calculation settings, Calculation settings — Static, Static 

— General). Select: 

 Dimension: 3D; 

 Model: Elasticity.  

Click Apply. 

2. Set the solver settings. 

Select calculation setting section on Command Panel (Mode — Calculation settings, Calculation settings — 

Static, Static — Solver). Select the solver method (direct or iterative) and set Convergence Parameters in 

case of choosing an iterative one. You can also leave all the settings by default.  

Click Apply.  

Click Start Calculation. 

3. In a pop-up window select a folder to save the result and enter the file name. 

4. If the calculation is finished successfully, you will see a message in the Console: “Calculation finished 

successfully at <date> <time>”.  

 

Results analysis  

1. Open the file with the results. You can do this in one of 

the three ways. 

 Click Ctrl+E. 

 Select Calculation → Open Results in the Main Menu. 

Click  Open last result. 
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 Select Calculations Manager on Command Panel (Mode — Calculations Manager, Calculations 

Manager — Results). Click  Open Results.  

To apply all of the filters changes automatically, click Apply changes to parameters automatically on 

Command Panel. 

2. Display the Uyy component of the displacement field on the model. 

In Fidesys Viewer window set the following parameters on Toolbar: 

 Representation Mode: Surface; 

 Representation Field: Displacement; 

 Representation Component: 2. 

 Surface. 

 

3. Display the maximum Displacement Uyy. 

Display the legend.  

Next, go to the color scale settings by clicking the corresponding button near. 

 

Specify the following settings in the pop-up form: 
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After applying the settings, you will see the following picture: 
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4. Check the maximum value Uyy at the selected point D.  

In the picture, it is the maximum in modulus Displacement (blue). It corresponds to -0.127222 in the 

color legend. 

The difference between the resulting value -0.127222 and the required -0.12524 is 1.56%. 

  

5. Download numerical data. 

Select File → Save Data in the Main Menu or click Ctrl+S. Enter the file name (*.csv format), leave it by 

default. Click  ОК. The saved file is an ordinary table of numerical data which can be opened in any text 

editor. 

6. You can see the way the body is deformed under the applied pressure. 

To do this, select Filters → Alpabatical → Warp By Vector. Set the following parameters in the tab 

Properties::  

 Vectors: Displacement; 

 Scale Factor: 100. 

As a result, the deformed body is displayed at the picture. To see the original model, click the button 

near the model in the Model Tree. The picture below shows the deformed (solid grey filling) and the original 

model (with the field of displacements distribution along Y axis).  
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Using Console Interface 

For geometry generation, meshing, setting boundary conditions and materials you can use Console 

Interface. The following program code allows performing the steps of the above-described guide, you only 

need to manually specify the full path and name of the file to be saved. 

Here is an example of the working script (the file is saved in D:/FidesysBundle/calc/example.pvd) 
 

reset 
create Cylinder height 100 radius 1  
create Cylinder height 100 radius 0.5  
subtract body 2 from body 1  
move Volume 1 preview z 50 include_merged  
move Volume 1 z 50 include_merged  
volume 1 size 0.25 
volume 1 scheme Polyhedron 
volume 1 scheme Polyhedron 
mesh volume 1 
create displacement on surface 8 dof all fix 0  
create displacement on surface 9 dof 1 dof 3 fix 0  
create acceleration on volume 1 dof 2 fix -386 
undo group begin 
create material "material 1" property_group "CUBIT-FEA" description "Hook material"  
modify material "material 1" scalar_properties "MODULUS" 3e+07 "POISSON" 0 "DENSITY" 
0.00073  
undo group end 
set duplicate block elements off 
block 1 volume 1  
block 1 material 'material 1' 
block 1 element type hex8 
analysis type static elasticity dim3 
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spectralelement off 
usempi off 
solver method auto try_other off 
solver method auto try_other off 
calculation start path " D:/FidesysBundle/calc/example.pvd"  
 

It is also possible to run the file Example_2_Static_3D.jou by selecting Journal Editor on Toolbar. In a 

pop-up window of the main menu select File → Open and open the necessary journal file. 

 

Static load (beam model, reaction forces)  

S.H. Crandall, N.C. Dahl, An Introduction to the Mechanics of Solids, McGraw-Hill Book Co., Inc., New York, NY, 

1959, pg. 389, ex. 8.9 

 

The problem of static load of a square section beam is being solved. The picture represents a geometric 

model of the problem: a = 50 In, beam section 1 x 1 in. The boundary conditions are presented in the 

picture; the force applied at the point B is Fy = -1000 lb. The material parameters are E = 30e6 psi , ν = 0.3. 

Test pass criterion is the following: reaction force RA at the point A (0,0,0) is 148.15 lb, reaction moment at 

the point C is 27778 in-lb within 1.5%. 

Geometry creation 

1. Create a straight line 100 in length (segment AB).  

Select volume geometry generation section on Command 

Panel (Mode — Geometry, Entity — Curve, Action — 

Create). Select Line in the list of geometric elements. 

Create it using Location and Direction. Set the following 

parameters:  

 Location: 0 0 0 (line origin); 

 Direction: 1 0 0 (along Х axis); 

 Length: 100; 

Click Apply. 
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2. Create a straight line 50 in length (segment ВС).  

Select volume geometry generation section on Command Panel (Mode — Geometry, Entity — Curve, Action 

— Create). Select Line in the list of geometric elements. Create it using Location and Direction. Set the 

following parameters:  

 Location: 100 0 0 (line origin); 

 Direction: 1 0 0 (along Х axis); 

 Length: 50; 

Click Apply. 

As a result, in left side of the Model Tree there are two free 

curves having no common vertices.  

 

 

 

 

 

3. Unite two vertices.  

Select volume geometry generation section on Command Panel 

(Mode — Geometry, Entity — Vertex, Action — Merge). Set the 

following parameters:  

 Vertex ID: 2 3 (using space after each of them); 

Click Apply. 

 

 

 

Meshing 

4. Select meshing on curves section on Command Panel 

(Mode — Mesh, Entity — Curve, Action — Meshing). Specify the 

parameters of mesh refinement: 

 Select Curves: all; 

 Select the way of meshing: Equal; 

 Select the meshing parameters: Interval; 

 Interval: 1. 

Click Apply.  

Click Mesh. 
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Setting boundary conditions 

1. Fix the point C at all directions.  

Select Mode — Boundary Conditions, Entity — Displacement, 

Action — Create on Command Panel. Set the following 

parameters: 

 System Assigned ID; 

 Entity List: Vertex; 

 Entity ID(s):  4; 

 Degrees of Freedom: All;  

 DOF Value: 0. 

 Click Apply.  

 

2. Fix the point C at the Y and Z displacement.  

Select Mode — Boundary Conditions, Entity — Displacement, 

Action — Create on Command Panel. Set the following 

parameters: 

 System Assigned ID; 

 Entity List: Vertex; 

 Entity ID(s):  1; 

 Degrees of Freedom: Displacement Y, Displacement Z; 

 DOF Value: 0.  

 Click Apply.  

 

 

3. Apply force at the point B. 

Select Mode — Boundary Conditions, Entity — Point Force, 

Action — Create on Command Panel. Set the following 

parameters: 

 System Assigned ID; 

 Entity List: Vertex; 

 Entity ID(s):  2; 

 Force: 1000; 

 Click  Direction…; 

 In the pop-up window select: Negative Y. 

 Click Apply. 
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 Setting material and element type 

1. Create the material.  

Select setting the material properties section on Command Panel 

(Mode — Blocks and Materials, Entity —Material, Action — Create 

Material). Set the following parameters:  

 Name: Material 1; 

 Description: Hook material 

 Property group: Hook material; 

 Young’s Modulus: 30e6; 

 Poisson’s Ratio: 0.3 

 

Click Apply. 
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2. Create the block of one type of the material.  

Select setting the material properties section on 

Command Panel (Mode — Blocks and Materials, Entity — 

Block, Action — Manage). Select Add in the list of possible 

operations. Set the following parameters: 

 Block ID: 1; 

 Entity type to be united into the block: Curve; 

 ID: 1 2 (or by the command all). 

Click Apply. 
  

  
 

3. Assign the material to the block.  

Select setting the material properties section on 

Command Panel (Mode — Blocks and Materials, Entity — 

Block, Action — Manage). Select Assign Material to Block 

in the list of possible operations. Set the following 

parameters: 

 Block(s) ID: 1; 

 Select the previously created material in the list: 

Material 1. 

Click Apply. 

 

 
 

4. Assign the element type.  

Select setting the material properties section on Command Panel (Mode — Blocks and Materials, Entity — 

Block, Action — Manage). Select Element Type in the list of possible operations. Set the following 

parameters:  

 Block(s) ID: 1; 

 Select: Curves; 

 Element type: Beam2. 

Click Apply. 
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Setting beam cross section profile  

5. Set beam parameters.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity — Beam 

Properties). Set the checkbox Select profile. Select Rectangle 

in the list of geometric elements. Specify the following 

parameters:  

 Block ID: 1; 

 Height (H): 1; 

 Width (B): 1; 

Click Apply. 
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Starting calculation 

1. Set the type of the problem to be solved.  

Select calculation setting section on Command Panel (Mode — Calculation settings, Calculation settings — 

Static, Static — General). Select: 

 Dimension: 3D; 

 Model: Elasticity.  

Click Apply. 

2. Set the solver settings. 

Select calculation setting section on Command Panel (Mode — Calculation settings, Calculation settings — 

Static, Static — Solver). Select the solver method (direct or iterative) and set Convergence Parameters in 

case of choosing an iterative one. You can also leave all the settings by default.  

Click Apply.  

3. Set the reaction force calculation  

Go to the tab Static – Output fields and set the checkbox Calculate nodal and reaction forces.  

Click Apply.  

Click  Start Calculation. 

Note: Without setting the checkbox Calculate nodal and reaction forces, the field is not calculated. 

4. In a pop-up window select a folder to save the result and enter the file name. 

5. If the calculation is finished successfully, you will see a message in the Console: “Calculation finished 

successfully at <date> <time>”.  

Results analysis 

1. Open the file with the results. You can do this in one of the 

three ways. 

 Click  Ctrl+E. 

 Select Calculation → Open Results in the Main Menu. 

Click  Open last result. 

 Select Calculations Manager on Command Panel (Mode 

— Calculations Manager, Calculations Manager — 

Results). Click  Open Results.  

 

2. Display the uy component of the displacements field. 

In Fidesys Viewer window set the following parameters on Toolbar: 

 Representation Mode: Surface; 

 Representation Field: Displacement; 

 Representation Component: 2.  
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The field of displacements distribution along the Y axis wil be displayed on the model  

3. Check the numerical value of the reaction force at the point A.  

 Display Component 2 of the Reaction Forces field. 

 

On the Fidesys Viewer Main Panel, click Select Points On surface. 

 

Select the limiting left point (point A) on the geometric model. 

To quickly view the information at the fixed point, click pointsInfo on the Main Panel.  

 

 

 

In the pop-up window, components of the reaction force at the selected point will be displayed.  

 

The difference between the resulting value 148.148 and the required 148.15 is less than 0.01%. 

Please, do not close the window Points information. 

4. Check the numerical value of reaction moments at the point C. 

Display Component 3 of  the Reaction_moment field. 
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On the Fidesys Viewer Main Panel, click Select Points On surface. 

 

Select the limiting right point C on the geometric model. 

In the window Points information components of the reaction moment at the selected point will be 

displayed. 

 

The difference between the resulting value -27777.8 and the required -27778 is less than 0.01%. 

5. Open 3D-image of the beam. 

To display 3D-view of the beam cross section, set the focus on the calculation title and click the button 

 in the Fidesys Viewer standard line. 

 

 

 

To apply all of the filters changes automatically, click Apply changes to parameters automatically on 

Command Panel. 
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6. Download numerical data. 

Select File → Save Data in the Main Menu or click Ctrl+S. Enter the file name (*.csv format), leave it by 

default. Click ОК. The saved file is an ordinary table of numerical data which can be opened in any text 

editor. 

Using Console Interface 

For geometry generation, meshing, setting boundary conditions and materials you can use Console 

Interface. The following program code allows performing the steps of the above-described guide, you only 

need to manually specify the full path and name of the file to be saved. 

Here is an example of the working script (the file is saved in D:/FidesysBundle/calc/example3.pvd): 
reset 
set node constraint on 
create curve location 0 0 0 direction 1 0 0 length 100 
create curve location 100 0 0 direction 1 0 0 length 50 
merge vertex 2 3  
curve all interval 1 
curve all scheme equal 
curve all interval 1 
curve all scheme equal 
mesh curve all 
create displacement on vertex 4 dof all fix 0  
create displacement on vertex 1 dof 2 dof 3 fix 0  
create force on vertex 2 force value 1000 direction ny  
set duplicate block elements off 
block 1 curve all  
undo group begin 
create material "Material 1" property_group "CUBIT-FEA" description "Hook material"  
modify material "Material 1" scalar_properties "MODULUS" 3e+06 "POISSON" 0.3  
undo group end 
block 1 material 'Material 1' 
block 1 element type beam2 
block 1 attribute count 14 
block 1 attribute index 1 value 1 name 'A' 
block 1 attribute index 2 value 0.140833 name 'It' 
block 1 attribute index 3 value 0.166667 name 'Ix' 
block 1 attribute index 4 value 0.0833333 name 'Iy' 
block 1 attribute index 5 value 0 name 'Iyz' 
block 1 attribute index 6 value 0.0833333 name 'Iz' 
block 1 attribute index 7 value 0 name 'angle' 
block 1 attribute index 8 value 0 name 'ey' 
block 1 attribute index 9 value 0 name 'ez' 
block 1 attribute index 10 value 0.5 name 'max_y' 
block 1 attribute index 11 value 0.5 name 'max_z' 
block 1 attribute index 12 value 0 name 'section_type' 
block 1 attribute index 13 value 1 name 'geom_H' 
block 1 attribute index 14 value 1 name 'geom_B' 
analysis type static elasticity dim3 
spectralelement off 
usempi off 
solver method auto try_other off 
output nodalforce on midresults on 
output nodalforce on midresults on 
calculation start path 'D:/FidesysBundle/calc/example3.pvd' 
 

It is also possible to run the file Example_3_Static_Beam.jou by selecting Journal Editor on Toolbar. 

In a pop-up window of the main menu select File → Open and open the necessary journal file.  
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Static load (shell)  

Тимошенко С.П. Войновский-Кригер С. Пластинки и оболочки – М.: Наука, 1966 г. – 636стр.  

[Timoshenko S.P. Voynovskiy-Kriger S. Plates and shells, Nauka, Moscow, 1966, 636 pages [in Russian]] 

 

The problem of static load of square shell which two sides are 

clamped and the other two are freely supported, is being solved.. 

The picture represents a geometric model of the problem: a = 1 m, 

shell thickness is 0.1 m. The boundary conditions are presented in 

the picture. The plate is loaded by uniform pressure of 10 kPa. 

Test pass criterion is the following: the maximum deflection is 

1.19e-6, moments Мx=252 N·m and Мy=332 N·m.  

 

 

Geometry creation 

1. Create the square 1 m on side.  

Select volume geometry generation section on Command Panel 

(Mode — Geometry, Entity — Surface, Action — Create). Select 

Rectangle in the list of geometric elements. Set the parameters:  

 Width: 1; 

 Height: Optional. 

Click Apply.  

 

 

 

 

 

 

 

Meshing 

1. Select surface mesh generation section on Command Panel 

(Mode — Mesh, Entity — Surface, Action — Meshing). Specify the 

following parameters: 

 Select surfaces: 1; 

 Select meshing scheme: Polyhedron; 

Click Apply Scheme. 

Click Mesh. 
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Setting boundary conditions 

1. Fix the two edges rigidly.  

Select Mode — Boundary Conditions, Entity — Displacement, 

Action — Create on Command Panel. Set the following 

parameters: 

 System Assigned ID; 

 Entity List: Curve; 

 Entity ID(s):  1 3 (or sequentially click on the top and 

bottom edges); 

 Degrees of Freedom: All; 

 DOF Value: 0. 

 Click Apply. 
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2. Fix the two other edges at displacements.  

Select Mode — Boundary Conditions, Entity — Displacement, Action — Create on Command Panel. Set the 

following parameters: 

 System Assigned ID; 

 Entity List: Curve; 

 Entity ID(s):  2 4 (or sequentially click on the right and left 

edges); 

 Degrees of Freedom: X-Translation, Y-Translation, Z-

Translation; 

 DOF Value: 0. 

Click Apply.  

3. Apply the uniform pressure on the surface. 

Select Mode — Boundary Conditions, Entity — Pressure, Action — 

Create on Command Panel. Set the following parameters: 

 System Assigned ID; 

 Entity List: Surface; 

 Entity ID(s):  1; 

 Value: 1e4; 

Click Apply. 

 

 

 

 

 

 

Setting material and element type 

1. Create the material.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity —Material, Action — 

Create Material). Set the following parameters:  

 Name: Material 1; 

 Description: Hook material 

 Property group: Hook material; 

 Young’s Modulus: 200е9; 

 Poisson’s Ratio: 0.3. 

Click Apply.   
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2. Create the block of one type of the material.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity — Block, Action — 

Manage). Select Add in the list of possible operations. Set the 

following parameters: 

 Block ID: 1; 

 Entity type to be united into the block: Surface; 

 ID: 1 (or by the command all). 

Click Apply. 
  

 
 
 
 
 
 
 
 
 
 
 
 

3. Assign the material to the block.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity — Block, Action — 

Manage). Select Assign Material to Block in the list of possible 

operations. Set the following parameters: 

 Block(s) ID: 1; 

 Select the previously created material in the list: 

Material 1. 

Click Apply. 

 

4. Assign the element type.  

Select setting the material properties section on Command Panel 

(Mode — Blocks and Materials, Entity — Block, Action — 

Manage). Select Element Type in the list of possible operations. 

Set the following parameters:  

 Block(s) ID: 1; 

 Select: Surfaces; 

 Element type: Shell4. 

Click Apply. 
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 Setting shell thickness 

1. Set the shell thickness.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity — Block, 

Action – Manage). Select in the list of possible operations 

Shell thickness. Set the following parameters:  

 Block ID: 1; 

 Thickness: 0.1; 

 Loft Factor: 0.5; 

Click Apply. 

 

Starting calculation 

2. Set the type of the problem to be solved.  

Select calculation setting section on Command Panel (Mode — Calculation settings, Calculation settings — 

Static, Static — General). Select: 

 Dimension: 3D; 

 Model: Elasticity.  

Click Apply. 

3. Set the solver settings. 

Select calculation setting section on Command Panel (Mode — Calculation settings, Calculation settings — 

Static, Static — Solver). Select the solver method (direct or iterative) and set Convergence Parameters in 

case of choosing an iterative one. You can also leave all the settings by default. Click Apply.  

4. Set the reaction force calculation  

Go to the tab Static – Output fields and set the checkbox 

Calculate nodal and reaction forces.  

Click Apply.  

Click Start Calculation. 

Note: Without setting the checkbox Calculate nodal and 

reaction forces, the field is not calculated. 

5. In a pop-up window select a folder to save the result and 

enter the file name. 

6. If the calculation is finished successfully, you will see a 

message in the Console: “Calculation finished successfully 

at <date> <time>”.  
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Results analysis 

1. Open the file with the results. You can do this in one of the three ways. 

 Click  Ctrl+E. 

 Select Calculation → Open Results in the Main Menu. Click  Open last result. 

 Select Calculations Manager on Command Panel (Mode — Calculations Manager, Calculations 

Manager — Results). Click  Open Results.  

2. Display the uz component of the displacement field. 

In Fidesys Viewer window set the following parameters on Toolbar: 

 Representation Mode: Surface; 

 Representation Field: Displacement; 

 Representation Component: 3. 

 

The field of displacements distribution along the Z axis will be displayed on the model  

3. Check the numerical value of the maximum displacement.  

 Display maximum Component 3 of the Displacement field. 

 

 

The difference between the resulting value -1.21е-6 and the required -1.19e-6 is 1.7% 
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4. Check numeric values of moments in the center of the plate. 

Display component 11 of the MomentsShell field. 

 

 

Select the filter Probe Location (Filters – Alphabetical – 

Probe Location) in the Fidesys Viewer Main Menu. In the tab 

Properties set the following values:  

 Point: (0,0,0); 

 Number of Points: 1; 

 Radius: 0. 

 

 

 

 

 

 

 

 

 

Go to the Information tab and look at the MomentsShell field. 

 

The difference between the resulting values (Мx=258.58 and Мy=336.129) and the required (Мx=252 and 

Мy=332) is 2.6% and 1.2%, relatively. 

5. Open 3D-image of the shell. 

To display 3D-view of the beam cross section, set the focus on the calculation title and click the button 

 in the Fidesys Viewer standard line. 
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A new file example 4_3D.pvd will be opened and you will be able to apply various filters to it and to view its 

deformed view. 

Choose the new file example_3D.pvd in the Model Tree and display Filters – Alphabetical – Warp by Vector 

for it with the following fields values  

 Vectors: Displacement  

 Scale Factor: 2е5 

On the Toolbar, set once again the following parameters for the deformed type: 

 

The first buckling mode will be displayed on the screen but the shell will be enveloped with thickness. 

 

 

 

To apply all of the filters changes automatically, click Apply changes to parameters automatically on 

Command Panel. 
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6. Download numerical data. 

Select File → Save Data in the Main Menu or click Ctrl+S. Enter the file name (*.csv format), leave it by 

default. Click ОК. The saved file is an ordinary table of numerical data which can be opened in any text 

editor. 

Using Console Interface 

For geometry generation, meshing, setting boundary conditions and materials you can use Console 

Interface. The following program code allows performing the steps of the above-described guide, you only 

need to manually specify the full path and name of the file to be saved. 

Here is an example of the working script (the file is saved in D:/FidesysBundle/calc/example.pvd): 
 

reset 
set node constraint on 
create surface rectangle width 1 zplane  
surface 1 scheme Polyhedron 
surface 1 scheme Polyhedron 
mesh surface 1 
create displacement on curve 1 3 dof all fix 0  
create displacement on curve 2 4 dof 1 dof 2 dof 3 fix 0  
create pressure on surface 1 magnitude 1e4  
undo group begin 
create material "Material 1" property_group "CUBIT-FEA" description "Hook material"  
modify material "Material 1" scalar_properties "MODULUS" 2e+11 "POISSON" 0.3  
undo group end 
set duplicate block elements off 
block 1 surface 1  
block 1 material 'Material 1' 
undo group begin 
block 1 attribute count 2 
block 1 attribute index 1 value 0.1 
block 1 attribute index 2 value 0.5 
undo group end 
analysis type static elasticity dim3 
spectralelement off 
usempi off 
solver method auto try_other off 
output nodalforce on midresults on 
calculation start path "D:/FidesysBundle/calc/example.pvd" 
 

It is also possible to run the file Example_4_Static_Shell.jou by selecting Journal Editor on Toolbar. 

In a pop-up window of the main menu select File → Open and open the necessary journal file.  
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Hydrostatic pressure on cylinder (setting boundary conditions according to 

coordinates) 

Societe Francaise des Mecaniciens, Guide de validation des progiciels de calcul de 

structures, (Paris, Afnor Technique,1990.) Test No. SSLS08/89. I-Deas Model 

Solution Verification Manual 

The problem of hydrostatic load of the cylindrical shell is being solved. The 

picture represents a geometric model of the problem: radius 1 m, shell 

thickness 0.02 m. The shell is fixed on the condition of the symmetry. The 

plate is loaded by the pressure p = 20000·z/L Pa. 

 

Test pass criterion is the following: displacement 𝑢𝑧 at the point (0, R, L) is 

2.8610-6 m. 

 

 

Geometry creation 

1.  Create the cylinder of 1 m radius  and 4 m high.  

 Select volume geometry generation section on Command Panel 

(Mode — Geometry, Entity — Volume, Action — Create). Select 

Cylinder in the list of geometric elements. Specify the cylinder 

dimensions:  

 Height: 4;  

 Cross section: Circular; 

 Radius: 1. 

Click Apply. 

 

 

 

 

 

 

 

 

2. Get the cylindrical shell out of the volumeric cylinder. 

Select the volume removing section on Command Panel (Mode — Geometry, Entity — Volume, Action — 

Delete). Enter the number of the created volume – 1 into the field Volume ID(s). Put a tick against Keep 

lower geometry. 

Click Apply. 

As a result, three plane bodies (Body 1, Body 2, Body 3) are obtained.  
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This will be displayed in the Model Tree. 

 

 

 

 

 

3. Delete side surfaces Surface 2 and Surface 3.  

Select the surface removing section on Command Panel (Mode 

— Geometry, Entity — Surface, Action — Delete). Enter 

numbers – 2 3 in the window Surface ID(s).  

 

Click Apply. 
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As a result, only the lateral cylindrical shell of 1 m radius and 4 m high will remain of the initial volume. 

 

 

4. Leave a quarter of a shell (symmetry of the problem).  

Select volume geometry generation section on Command Panel (Mode — Geometry, Entity — Volume, 

Action — Webcut). Select Plane in the list of possible webcut types. Set the following parameters:  

 Body ID: 2 (the body to be webcut);  

 Webcut with: YZ Plane;  

 Offset value: 0.  

Click Apply. 

Do the same for the ZX Plane.  

 Body ID: 2 (the body to be webcut);  

 Webcut with: ZX Plane;  

 Offset value: 0. 

Click Apply. 
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As a result, the original Body 2 in the Model Tree is split into three (Body 2, Body 5 and Body 6).  

 

5. Delete surfaces Surface 5 and Surface 6.  

Select the surface removing section on Command Panel (Mode — Geometry, Entity — Surface, Action — 

Delete). Enter numbers – 5 6 into the window Surface ID(s).  

Click Apply.  
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As a result, only a quarter of the original shell Body 6 (Surface 7) is left. 

 

6. Move the surface to the coordinate origin.  

Select surface geometry modification section on Command 

Panel  (Mode — Geometry, Entity — Surface, Action — Modify). 

Select Move in the list of possible webcut types. Set the 

following parameters:  

 Surface: 7 (the surface to be moved);  

 Checkbox Distance;  

 Z Distance: 2. 

Click Apply.  
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Meshing  

1. Specify the parameters of mesh refinement. 

Select meshing on curves section on Command Panel (Mode — Mesh, Entity — Curve, Action — Meshing).  

Split the cross-cut curves Surface 17 and Surface 18 into 10 elements.  

 Select Curves: 17 18 (or click the mouse while holding down the Ctrl key on contour of the cross-cut 

curves);  

 Select the way of meshing: Equal;  

 Select splitting settings: Interval;  

 Specify interval number: 10.  

Click Apply.  

Split longitudinal curves Curve 5 and Curve 16 into 20 elements.  

 Select Curves: 5 16 (or click the mouse while holding down the Ctrl key on contour of the longitudinal 

curves);  

 Select the way of meshing: Equal;  

 Select splitting settings: Interval;  

 Specify interval number: 20.  

Click Apply.  

2. Create the mesh.  

Select the surface mesh generation section on Command Panel (Mode — Mesh, Entity — Surface, Action — 

Intervals).  

 Select Surfaces to Mesh (specify their ID)): 7 (or by the command all);  

 Select meshing scheme: Automatically Calculate. 

Click Apply.  

Click Mesh. 

The resulting number of elements can be viewed in the Property Page by clicking on the inscription Surface 

7 in the Model Tree on the left.  

To view the mesh properties, you can follow these steps: 

 Select the entire model  

 Right-click on the model 

 In the pop-up menu, select List Information – List Mesh Info  

 Information on the mesh will be displayed in Command Line  
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Setting material and element type  

1. Create the material.  

Select setting the material properties section on Command Panel (Mode 

— Blocks and Materials, Entity — Material, Action — Create Material). Set 

the following parameters:  

 Name: Material1;  

 Property group: Hook material;  

 Young’s Modulus: 2.1e11;  

 Poisson’s Ratio: 0.3.  

Click Apply. 

 

2. Create the block of one type of the material.  

Select setting the material properties section on Command Panel (Mode 

— Blocks and Materials, Entity — Block, Action — Manage). Select Add 

in the list of possible operations. Set the following parameters:  

 Block ID: 1;  

 Select the entities to be united into block: Surface;  

 ID: 7 (or by the command all).  

Click Apply. 
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3. Assign the material to the block.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity — Block, Action — 

Manage). Select Assign Material to Block in the list of possible 

operations. Set the following parameters:  

 Block(s) ID: 1;  

 Select the previously created material in the list: 

Material 1.  

Click Apply. 

4. Assign the shell thickness.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity — Block, Action – 

Manage). Select Shell thickness in the list of possible 

operations. Set the following parameters:  

 Block ID: 1;  

 Screen: normal; 

 Thickness: 0.02;  

 Loft Factor: 0.5. 

Click Apply. 
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5. Assign the element type to the block.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity — Block, Action — 

Manage). Select Element type in the list of possible operations. 

Set the following parameters:  

 Block(s) ID: 1;  

 Select: Surfaces;  

 Surfaces: Shell8.  

Click Apply. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Setting boundary conditions  

1. Fix the cross-cut curve Surface 17 by the symmetry condition.  

Select Mode — Boundary Conditions, Entity — Displacement, Action — Create on Command Panel. Set the 

following parameters: 

 System Assigned ID; 

 Entity List: Curve; 

 Entity ID(s):  17 (or click on the cross-cut curve); 

 Degrees of Freedom: Z-Translation; X-Rotation; Y-Rotation. 

Click Apply. 

 

2. Fix the longitudinal curve Curve 5 on the symmetry condition.  

Select Mode — Boundary Conditions, Entity — Displacement, Action — Create on Command Panel. Set the 

following parameters: 

 System Assigned ID; 

 Entity List: Curve; 

 Entity ID(s):  5 (or click on the longitudinal curve); 

 Degrees of Freedom: X-Translation; Y-Rotation; Z-Rotation. 

Click Apply. 
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3. Fix the longitudinal curve Curve 16 by the symmetry condition.   

Select Mode — Boundary Conditions, Entity — Displacement, Action — 

Create on Command Panel. Set the following parameters: 

 System Assigned ID; 

 Entity List: Curve; 

 Entity ID(s):  16 (or click on the longitudinal curve);  

 Degrees of Freedom: Y-Translation; X-Rotation; Z-Rotation. 

Click Apply. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

4. Apply pressure to the cylinder inner surface with value 

of 1. 

Select Mode — Boundary Conditions, Entity — Pressure, Action — 

Create on Command Panel. Set the following parameters: 

 System Assigned ID; 

 Entity List: Surface; 

 Entity ID(s):  7 (or click on the cylinder surface); 

 Value: 1. 

 

Click Apply. 
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5. Set pressure dependency of the z-coordinate. 

Select Mode — Boundary Conditions, Entity — Set time/coordinates dependency of BC on Command Panel.   

In the pop-up window BC Dependency, set the following parameters:  

 BC name: Pressure 1;  

 Select checkbox Formula, Manually;  

 In the field below, enter -20000*z/4. 

Click Apply. 

 

 

 

 

 

 

 

 

To view the plotted graph, please, use the appropriate tab. 
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Starting calculation 

1. Set the type of the problem to be solved.  

Select calculation setting section on Command Panel (Mode — 

Calculation settings, Calculation settings — Static, Static — 

General). Select: 

 Dimension: 3D; 

 Model: Elasticity.  

Click Apply. 

Click  Start Calculation. 

In a pop-up window select a folder to save the result and enter 

the file name. 

If the calculation is finished successfully, you will see a message 

in the Console: “Calculation finished successfully at <date> <time>”.  

 

 

Results analysis 

1. Open the file with the results. You can do this in one of 

the three ways. 

 Click  Ctrl+E. 

 Select Calculation → Open Results in the Main Menu. Click  

Open last result. 

 Select Calculations Manager on Command Panel (Mode — Calculations Manager, Calculations 

Manager — Results). Click Open Results.  

2. Display the Uz component of the displacement field on the model.  

In Fidesys Viewer window set the following parameters on Toolbar: 

 Representation Mode: Surface; 

 Representation Field: Displacement; 

 Representation Component: 3. 

3. Compare the numerical value of the target displacement at the point (0,1,4) with the initial one of 

the source -2.86e-6. 

Select Filters → Alphabetical → Probe Location. In the tab Properties, set the following parameters for the 

filter:  

 Point (0, 1, 4); 

 Number of Points: 1; 

 Radius: 0. 
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Go to the tab Information. We are interested in the field Displacement – the third component: 

The difference between the resulting value -2.85709е-6 and the required -2.86e-6 is 0.1%. 

 

 

You can see the way the body is deformed under the applied pressure. 
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Select the filter Warp By Vector to do this. Set the following parameters in the tab Properties:  

 Vectors: Displacement;  

 Scale Factor: 1e5.  

As a result, the deformed body is displayed at the picture. 

 

Select the following display settings for the deformed view: 

 

 

To see the original model, click the icon near the model in the Model Tree.  

 

Consider the direction of the coordinate axes in the picture. 

 

4. Download numerical data. 

Select File → Save Data in the Main Menu or click Ctrl+S. Enter the file name (*.csv format), leave it by 

default. Click  ОК. The saved file is an ordinary table of numerical data which can be opened in any text 

editor. 
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5. Get the original cylinder using reflection. 

In the Model Tree, click on test.pvd. Then, in the Main Menu, select Filters → Alphabetical → Reflect. Set 

the following parameters in the tab Properties:  

 Plane: Х 

 Center: 0. 

In the Model Tree, select now Reflect1 and then again Filters → Alphabetical → Reflect. Set the following 

parameters in the tab Properties:  

 Plane: Y 

 Center: 0. 

You received completely original cylinder by reflecting ¼ part.  

 

 
 

 

Using Console Interface 

For geometry generation, meshing, setting boundary conditions and materials you can use Console 

Interface. The following program code allows performing the steps of the above-described guide, you only 

need to manually specify the full path and name of the file to be saved. 

Here is an example of the working script (the file is saved in D:/FidesysBundle/calc/example.pvd): 

 
reset 
set node constraint on 
create Cylinder height 4 radius 1  
delete volume 1 keep_lower_geometry  
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delete Surface 2 3  
webcut body 2 with plane xplane offset 0 preview  
webcut body 2 with plane xplane offset 0  
webcut body 2 with plane yplane offset 0 preview  
webcut body 2 with plane yplane offset 0  
delete Surface 5 6  
move Surface 7 preview z 2 include_merged  
move Surface 7 z 2 include_merged  
curve 17 18 interval 10 
curve 17 18 scheme equal 
curve 5 16 interval 20 
curve 5 16 scheme equal 
surface all size auto factor 5 
mesh surface all 
list Surface 7 mesh 
undo group begin 
create material "material 1" property_group "CUBIT-FEA" description "Hook material"  
modify material "material 1" scalar_properties "MODULUS" 2.1e+11 "POISSON" 0.3  
undo group end 
set duplicate block elements off 
block 1 surface 7  
block 1 material 'material 1' 
block 1 element type shell8 
undo group begin 
block 1 attribute count 2 
block 1 attribute index 1 value 0.02 
block 1 attribute index 2 value 0.5 
undo group end 
block 1 element type shell8 
create displacement on curve 17 dof 3 dof 4 dof 5 fix  
create displacement on curve 5 dof 1 dof 5 dof 6 fix  
create displacement on curve 16 dof 2 dof 4 dof 6 fix  
create pressure on surface 7 magnitude 1  
bcdep pressure 1 value '-20000*z/4' 
analysis type static elasticity dim3 
spectralelement off 
usempi off 
calculation start path "D:/FidesysBundle/calc/example.pvd" 
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Static loading (2D, Kirsch problem)  

Седов Л.И. “Механика сплошной среды, том 2”. М.: Наука, 1970г., 568 стр. 

[Sedov L.I., Continuum Mechanics, Volume 2, Nauka, Moscow, 1970, 568 pages [in Russian]]   

 

2D problem of one-sided tension of a plate with a circular hole is 

regarded. The picture represents a geometric model of the problem: side 

length is 10 m, hole diameter is 0.5 m. The load P0 = 1 MPa is applied on 

the edges.  

In view of the symmetry of the problem, ¼ of the plate is considered. 

Test pass criterion is the following: Stress σ𝜃 at the point Е (0.25;0;0) is 

3 MPa within 3%. 

Geometry creation 

1. Create the square 10 on side.  

Select volume geometry generation section on Command Panel (Mode — Geometry, Entity —Surface, Action 

— Create). Select Rectangle in the list of geometric elements. Set the parameters:  

 Width: 10; 

 Height: Optional. 

 Z-plane 

Click Apply. 

Note: 2D problems for Quad/Quad4/Quad8/Quad8 and Tri/Tri3/Tri6 elements are to be solved if only the 

model is in the Z-plane. 
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2.  Create the circle with a radius 0.25.  

Select volume geometry generation section on Command 

Panel (Mode — Geometry, Entity —Surface, Action — Create). 

Select Circle in the list of geometric elements. Set parameters:  

 Radius: 0.25; 

 Z-plane. 

Click Apply. 

 

 

 

 

 

 

 

 

3. Subtract the circle from the square.  

Select volume geometry generation section on Command 

Panel (Mode — Geometry, Entity — Volume, Action — 

Boolean). Select Subtract in the list of operations. Set 

parameters:  

 Body ID: 1 (or click on the square) 

 Subtract bodies (ID): 2 (or click on the circle) 

Click Apply.  
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4. Leave a quarter of the plate.  

Select volume geometry generation section on Command 

Panel (Mode — Geometry, Entity — Volume, Action — 

Webcut). Select Coordinate Plane in the list of possible 

webcut types. Set the following parameters:  

 Body ID: 1 (or click on the plate); 

 Webcut with: YZ Plane; 

 Offset value: 0. 

Click Apply. 

 

Do the same for the ZX Plane. Set the following parameters: 

 Body ID: 1 (or click on the right plate); 

 Put the checkbox for ZX; 

 Offset value: 0. 

Click Apply. 

 

 

As a result, the original surface in the Model Tree is split into three (Body 1, Body 3 and Body 4). 
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Delete surfaces 1 and 3. To do this, holding down the Ctrl key, select the volumes in the Model Tree and 

click Delete in the context menu. As a result, a quarter of the original plate is left (Body 4): 

 

 

Meshing 

1. Select meshing on curves section on Command Panel 

(Mode — Mesh, Entity — Curve, Action — Meshing). Specify 

the following parameters: 

 Select Curves: 22 20 7 (or clicking on the bottom and 

left edges of the plate and on the circle outline while 

pressing the key Ctrl); 

 Select meshing scheme: Bias; 

 In the drop-down list below, select: First Size & Bias; 

 The first size: 0.01; 

 Bias Factor: 1.15; 

 Start Vertex ID: 18 8. 

Click Apply size. 

Click Mesh. 

 

2. Select surfave mesh generation section on Command 

Panel (Mode — Mesh, Entity — Surface, Action — Meshing). 

Specify the following parameters: 

 Choosing surfaces: 7 (or all); 

 Select meshing scheme: Polyhedron; 

Click Apply. 

Click Mesh. 
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3. In the Model Tree, select Plane bodies – Body 4 – Surface 7. Below, on the Property Page you can 

see the number of elements for the generated mesh. 
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Setting boundary conditions 

 

1. Fix the bottom edge by the symmetry condition.  

Select Mode — Boundary Conditions, Entity — 

Displacement, Action — Create on Command Panel. Set the 

following parameters: 

 System Assigned ID; 

 Entity List: Curve; 

 Entity ID(s):  20 (or click on the bottom edge); 

 Degrees of Freedom: Y-Translation; 

 DOF Value: 0. 

 Click Apply. 

 

 

 

 

 

2. Fix the left edge on the symmetry condition.  

Select Mode — Boundary Conditions, Entity — 

Displacement, Action — Create on Command Panel. Set the 

following parameters: 

 System Assigned ID; 

 Entity List: Curve; 

 Entity ID(s):  7 (or click on the left edge); 

 Degrees of Freedom: X-Translation; 

 DOF Value: 0. 

 Click Apply. 
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3. Apply uniform pressure to the surface.  

Select Mode — Boundary Conditions, Entity — Pressure, Action — 

Create on Command Panel. Set the following parameters:  

 System Assigned ID;  

 Entity List: Curve;  

 Entity ID(s):  11; 

 Value: -1e6; 

Click Apply. 

 

 

 

 

 

 

 

 

 

 

Setting material and element type 

1. Create the material.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity —Material, Action — 

Create Material). Set the following parameters:  

 Name: Material 1; 

 Description: Hook material 

 Property group: Hook material; 

 Young’s Modulus: 200е9; 

 Poisson’s Ratio: 0.3. 

 

Click Apply.  
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2. Create the block of one type of the material.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity — Block, Action 

— Manage). Select Add in the list of possible operations. Set 

the following parameters: 

 Block ID: 1; 

 Entity type to be united into the block: Surface; 

 ID: 1 (or by the command all). 

Click Apply. 
  

 
 
 

 
 

 
 
 

 

3. Assign the material to the block.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity — Block, Action 

— Manage). Select Assign Material to Block in the list of 

possible operations. Set the following parameters: 

 Block(s) ID: 1; 

 Select the previously created material in the list: 

Material 1. 

Click Apply. 

 

4. Assign the element type.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity — Block, Action — 

Manage). Select Element Type in the list of possible operations. 

Set the following parameters:  

 Block(s) ID: 1; 

 Select: Surfaces; 

 Element type: Quad8. 

Click Apply. 
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Starting calculation 

 

1. Set the type of the problem to be solved.  

Select calculation setting section on Command Panel (Mode — Calculation settings, Calculation settings — 

Static, Static — General). Select: 

 Dimension: 2D; 

 Type of plane problem: Plane deformed state; 

 Model: Elasticity.  

Click Apply. 

 

 

2. Set the solver settings. 

Select calculation setting section on Command Panel (Mode — Calculation settings, Calculation settings — 

Static, Static — Solver). Select the solver method (direct or iterative) and set Convergence Parameters in 

case of choosing an iterative one. You can also leave all the settings by default. Click Apply.  

3. Set the reaction force calculation  

Go to the tab Static – Output fields and set the checkbox Calculate nodal and reaction forces.  

Click Apply.  

Click  Start Calculation. 

Note: Without setting the checkbox Calculate nodal and reaction forces, the field is not calculated. 

4. In a pop-up window select a folder to save the result and enter the file name. 

5. If the calculation is finished successfully, you will see a message in the Console: “Calculation finished 

successfully at <date> <time>”.  

 

 

 

Results analysis 

1. Open the file with the results. You can do this in one 

of the three ways. 

 Click  Ctrl+E. 

 Select Calculation → Open Results in the Main 

Menu. Click  Open last result. 

 Select Calculations Manager on Command Panel 

(Mode — Calculations Manager, Calculations 

Manager — Results). Click  Open Results.  
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2. Display the σ𝜃 component of the stress field. 

Select Filter → Alphabatical → Coordinate systems conversions. 

Select in the tab Properties:  

 Scalar Array: Stress. 

 Cylinder axis: Z 

 

 

 

 

 

 

 

In Fidesys Viewer window set the following parameters on Toolbar: 

 Representation Mode: Surface; 

 Representation Field: Stress cylindrical; 

 Representation Component: FF. 

 

On the model stress distribution field σ𝜃 will be displayed in cylindrical coordinates. 
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3. Check the numerical value of the target stress. 

Click with the mouse on the name of the filter Coordinate systems in the Model Tree. Next, select Filter → 

Alphabetical → Probe Location. In the Properties tab for the filter, set the following parameters:  

 Point (0.25, 0, 0); 

 Number of Points: 1; 

 Radius: 0. 
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Please, go to the Information tab. We are interested in the Stress field (cyl.) – the second component: 

 

The difference between the resulting value 3.05077e+06 and the required 3e6 is 1.6%. 

 

To apply all of the filters changes automatically, click Apply changes to parameters automatically on 

Command Panel. 

4. Download numerical data. 

Select File → Save Data in the Main Menu or click Ctrl+S. Enter the file name (*.csv format), leave it by 

default. Click ОК. The saved file is an ordinary table of numerical data which can be opened in any text 

editor. 

Using Console Interface 

For geometry generation, meshing, setting boundary conditions and materials you can use Console 

Interface. The following program code allows performing the steps of the above-described guide, you only 

need to manually specify the full path and name of the file to be saved. 

Here is an example of the working script (the file is saved in D:/FidesysBundle/calc/example.pvd): 
 

reset 
set node constraint on 
create surface rectangle width 10 zplane  
create surface circle radius 0.25 zplane  
subtract body 2 from body 1  
webcut body 1 with plane xplane offset 0  
webcut body 1 with plane yplane offset 0  
delete Body 1 3 
curve 20 22 7 scheme bias fine size 0.01 factor 1.15 start vertex 18 8  
mesh curve 20 22 7 
surface 7 scheme Polyhedron 
mesh surface 7 
create displacement on curve 20 dof 2 fix 0  
create displacement on curve 7 dof 1 fix 0  
create pressure on curve 11 magnitude -1e+06 
undo group begin 
create material "Material 1" property_group "CUBIT-FEA" description "Hook material"  
modify material "Material 1" scalar_properties "MODULUS" 2e+11 "POISSON" 0.3  
undo group end 
set duplicate block elements off 
block 1 surface all  
block 1 material 'Material 1' 
block 1 element type quad8 
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analysis type static elasticity dim2 planestrain 
spectralelement off 
usempi off 
solver method auto try_other off 
output nodalforce on midresults on 
calculation start path "D:/FidesysBundle/calc/example.pvd" 
 

It is also possible to run the file Example_5_Static_2D.jou by selecting Journal Editor on Toolbar. In a 

pop-up window of the main menu select File → Open and open the necessary journal file.  

 

  



 CAE Fidesys — User Guide (version 1.6) 

 

Dynamic load (3D) 

A dynamic problem of the wave propagation in a long rod is being solved. The problem has an analytic 

solution which sets the dependency between the velocity of wave distribution in the rod and the material 

parameters of the rod: 

𝛼 = √
𝜆 + 2𝜇

𝜌
 

where α is the wave velocity, 𝜌 is the density, 

𝜆 =
𝜐𝐸

(1+𝜐)(1−2𝜐)
, 

𝜇 =
𝐸

2(1 + 𝜐)
 

Е — Elastic Modulus(Young’s Modulus), 

𝜐 — Poisson’s Ratio. 

At the values Е = 200 hPa, 𝜌 = 7900 kg/m3 and 𝜐 = 0.3 the wave velocity according to analytic solution is 

5717.41 m/s. 

The picture below represents a geometric model of the problem: 

 

The length of the rod is 100 m. Displacement along the normal to the rod’s sides (parallel to the axis Х) is 

constrained. The left butt is fixed along Х axis. The pressure 100 MPa is suddenly applied to the right butt.  

Test pass criterion is the following: stress σyy at the point D is -5.38МPа to within 1.5%. 
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Geometry creation 

1. Create a sliver parallelepiped. 

Select volume geometry generation section on Command Panel (Mode 

— Geometry, Entity — Volume, Action — Create). Select Brick in the list 

of geometric elements. Set the brick dimensions: 

 Width: 100; 

 Height: 1; 

 Depth: 1. 

Click Apply. 

 

 

 

Meshing 

1. Set the elements size. 

Select volume mesh generation section on Command Panel (Mode — Mesh, Entity — Volume, Action — 

Intervals):  

 Select Volumes (specify their ID): 1 (or by the command all); 

 The way of meshing: Approximate Size; 

 Approximate Size: 0.5 

Click  Apply Scheme. 

Click Mesh.    



 CAE Fidesys — User Guide (version 1.6) 

 

Setting material and element type 

1. Create the material.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity — Material, Action 

— Create Material). Set the following parameters:  

 Name: Material1; 

 Description: Hook material 

 Property group: Hook material; 

 Young’s Modulus: 200e9; 

 Poisson’s Ratio: 0.3. 

 Density: 7900 

Click Apply. 
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On the left panel a new material Material1 is displayed. Click on it to display the following constants of 

materials on the Properties page below. 

 

The parameters of materials on the properties page are available 

for editing. Left-click on the editing window opposite the 

inscription Density. Remove the 7900 value and enter the new 

value 7800. Click  ENTER. After this a message about changing of 

constants of the material will be displayed in Command Line: 
modify material 1 density 7800 
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2. Create the block of one type of the material.  

Select setting the material properties section on 

Command Panel (Mode — Blocks and Materials, Entity — 

Block, Action — Manage). Select Add in the list of possible 

operations. Set the following parameters: 

 Block ID: 1; 

 Entity type to be united into the block: Volume; 

 ID: 1 (or by the command all). 

Click Apply. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

3. Assign the material to the block.  

Select setting the material properties section on Command Panel (Mode — Blocks and Materials, Entity — 

Block, Action — Manage). Select Assign Material to Block in the list of possible operations. Set the following 

parameters: 

 Block(s) ID: 1; 

 Select the previously created material in the list: Material 1. 

Click Apply. 
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4. Assign the element type.  

Select setting the material properties section on 

Command Panel (Mode — Blocks and Materials, Entity — 

Block, Action — Manage). Select Element Type in the list 

of possible operations. Set the following parameters:  

 Block(s) ID: 1; 

 Select: Volumes; 

 Volumes: HEX8. 

Click Apply. 

 

 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

Setting boundary conditions 

1. Fix one side along X-axis.  

Set Mode — Boundary Conditions, Entity — Displacement, 

Action — Create. Set the following parameters: 

 System Assigned ID; 

 Entity List: Surface; 

 Entities ID: 4 (or click on the left butt of the beam); 

 Degrees of Freedom: X-Component; 

 DOF Value: 0. 

 Click Apply. 
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2. Fix two sides along Y axis. 

The procedure is similar to the previous step. Select Mode — Boundary Conditions, Entity — Displacement, 

Action — Create. Set the following parameters: 

 System Assigned ID; 

 Entity List: Surface; 

 Entities ID: 3 5 (or sequentially click on the top and bottom edges); 

 Degrees of Freedom: Y-Component; 

 DOF Value: 0. 

 Click Apply. 

3. Fix another two sides along Z-axis. 

Select Mode — Boundary Conditions, Entity — Displacement, Action — Create. Set the following parameters: 

 System Assigned ID; 

 Entity List: Surface; 

 Entities ID: 1 2 (or sequentially click on two side 

edges); 

 Degrees of Freedom: Z-Component; 

 DOF Value: 0. 

 Click Apply. 

4. Apply pressure to the right butt of the rod. 

Select Mode — Boundary Conditions, Entity — Pressure, 

Action — Create on Command Panel. Set the following 

parameters: 

 System Assigned ID; 

 Entity List: Surface; 

 Entities ID: 6; 

Value: 1. 

Note: For the dynamic problems it is necessary to 

create the boundary condition (unit vector) 

before setting the time dependency. 

 Click Apply. 

 
 
 

Setting time dependency 

1. Creat time dependency.  

Select Mode — Boundary Conditions, Entity — Creat time dependency on Command Panel. In a pop-up 

window. Specify the following parameters: 
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 BC name: Pressure 1; 

 Inlay Formula; 

 From the drop-down list select: Manually; 

 DOF Value: 100*exp(-10*t). 

 Click Apply. 
 

 
 

This dependency can be entered using pre-installed functions. In the drop-down list below, select: Exponent 

and enter Amplitude 100, Damping ratio 10. 
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Note: After clicking Apply the following command should be entered in Command Line:  

bcdep pressure 1 value "100*exp(-10*t)". The time dependency is not saved in general.cub-file, thus, it is 

advisable to keep this command separately for the following running of the saved calculation. 

 

Starting calculation 

1. Set the type of the problem to be solved. 

Select calculation settings section on Command Panel (Mode — Calculation settings, Calculation settings 

— Dynamic, Dynamic — General). Set the following calculation parameters: 

 Dimension: 3D; 

 Scheme: Explicit; 

 Max time: 0.02; 

 Max steps count: 600; 

 Courant number: 0.8; 

 Model: Elasticity 

Click Apply.   

 

 

 

 

 

 

 

 

 

 

 

 

 

2. Set the parameters output field.  

Select calculation setting section on Command Panel 

(Mode — Calculation settings, Calculation settings — 

Dynamic, Dynamic — Output Fields). Set the following 

calculation parameters: 

 Output results: Every 1 step 

Click Apply.  

Click  Start Calculation. 
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3. In a pop-up window select a folder to save the result and enter the file name. 

4. In the process of calculation the number of time step, current time for step and the time step for the 

step will be displayed in Command Line. 

 

 

 

5. If the calculation is finished successfully, you will see a message in the Console: “Calculation finished 

successfully at <date> <time>”.  

 

 

 

In this case, 506 steps  were made to reach the predetermined maximum time of 0.02 seconds. 

 

Results analysis  

1. Open the file with the results. You can do this 

in one of the three ways. 

 Click  Ctrl+E. 

 Select Calculation → Open Results in the 

Main Menu. Click  Open last result.  
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Select Calculations Manager on Command Panel (Mode — Calculations Manager, Calculations Manager 

— Results). Click Open Results. 

 

 

 

 

 

 

 

 

 

 

2. Display ХХ component of the stress field. 

In a pop-up Fidesys Viewer window set the following parameters on Toolbar: 

 Representation Mode: Surface; 

 Representation Field: Stress; 

 Representation Component: 11. 

 

3. There is a menu on Toolbar which allows viewing animation. It consists of a cycle of solutions 

calculated for every moment of time. Click “Play” to start animation. 

 

You will clearly see the way the deformation wave is distributing along the rod (see the picture below, 

screenshot is made for the time step with the number 200). 
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4. Fix the moment when the wave reaches the second end of the rod by clicking “Pause”.   

 

 

 

Pay attention to the file number:  

 

 

Define the total number of files by clicking “Last Frame”  

 

 

 

 

 

You can find the wave distribution velocity in the rod accounting for the modeling time indicated when 

setting calculation (0.02 s) accounting distance of the wave to the opposite beam side and the time 

which the wave needs to reach the beam side: 

𝑐 =
𝐿

𝑡
=

100

0.02
506

∙ 432
≈ 5856.48 

The difference between this value and the one obtained analytically is 2.43%. 
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Using Console Interface 

For geometry generation, meshing, setting boundary conditions and materials you can use Console 

Interface. The following program code allows performing the steps of the above-described guide, you only 

need to manually specify the full path and name of the file to be saved. 

Here is an example of the working script (the file is saved in D:/FidesysBundle/calc/example.pvd) 
 

reset 
set node constraint on 
brick x 100 y 1 z 1 
volume 1 size 0.5 
volume 1 size 0.5 
mesh volume 1 
undo group begin 
create material "Material 1" property_group "CUBIT-FEA" description "Hook material"  
modify material "Material 1" scalar_properties "MODULUS" 2e+11 "POISSON" 0.3 "DENSITY" 
7900  
undo group end 
set duplicate block elements off 
block 1 volume 1  
block 1 material 'Material 1' 
block 1 element type hex8 
create displacement on surface 4 dof 1 fix 0  
create displacement on surface 3 5 dof 2 fix 0  
create displacement on surface 1 2 dof 3 fix 0  
create pressure on surface 6 magnitude 1  
bcdep pressure 1 value '100*exp(-10*t)' 
analysis type dynamic elasticity dim3 
dynamic scheme explicit maxtime 0.02 maxsteps 600 courant 0.8 
spectralelement off 
usempi off 
output nodalforce off midresults on results everystep 1 
output nodalforce off midresults on results everystep 1  
calculation start path "D:/FidesysBundle/calc/example.pvd" 
 

 It is also possible to run the Example_6_Dynamic_3D.jou, by selecting Journal Editor on Toolbar. In 

a pop-up window of the main menu select File → Open and open the necessary journal file. 
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Buckling (shell model) 

S.P. Timoshenko, J.M Manages “Theory of elastic stability” second 

edition. Dunod, 1966, 500 pages  

The problem of cylindrical shell buckling under the pressure 

uniformly distributed over the entire surface is being solved. 

The picture represents a geometric model of the problem: R = 2 m, L 

= 2 m, thickness h = 0.002 m. Due to the symmetry of the problem, 

the ¼ part of the cylinder is regarded. Constraints on the lines AB 

and CD are due to the conditions of symmetry; a uniformly 

distributed load on the surface is ABSD q = 1 kPa. The material 

parameters are E = 200 GPa, ν = 0.3.  

It is necessary to compare the first three critical values. 

 

 

 

 

Geometry creation 

1. Create a cylinder with radius of 2 m and length of 2 m.  

Select volume geometry generation section on Command Panel 

(Mode — Geometry, Entity — Volume, Action — Create). Select 

Cylinder in the list of geometric elements. Creat leaving Circular 

at the base. Set radius of 2 and height of 2 

Click Apply. 

 

 

 

 

 

 

 

2. Get the cylindrical shell out of the volumeric cylinder. 

 

Select the volume removing section on Command Panel (Mode — 

Geometry, Entity — Volume, Action — Delete). Enter the number 

of the created volume – 1 into the field Volume ID(s). Put a tick 

against Keep lower geometry. 

Click Apply. 
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As a result, three plane bodies (Body 1, Body 2, Body 3) are obtained. This will be displayed in the Model 

Tree. 

 

 

 

 

 

 

Delete side surfaces Body 3 and Body 4. 

Select the surface removing section on Command Panel (Mode — Geometry, Entity — Surface, Action — 

Delete). Enter numbers 2 3 in the window Surface ID(s).  

Click Apply. 

As a result, only the lateral cylindrical shell of 2 m radius and 2 m high will remain of the initial volume. 
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3.  Leave a quarter of a shell (symmetry of the problem).  

Select volume geometry generation section on Command 

Panel (Mode — Geometry, Entity — Volume, Action — Webcut). 

Select Coordinate Plane in the list of possible webcut types. 

Set the following parameters:  

 Body ID: 2 (the body to be webcut);  

 Webcut with: YZ Plane;  

 Offset value: 0; 

 Imprint. 

Click Apply. 

 

 

Do the same for the ZX Plane: 

 Volume ID(s): 2 (the volume to be webcut); 

 Webcut with: ZX Plane; 

 Offset value: 0; 

 Imprint. 

Click Apply. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

As a result, the original volume in the Model Tree is split into three (Body 2, Body 5 and Body 6). 
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Delete the bodies 2 and 5. To do this, select these bodies in the Model Tree holding down the Ctrl key and 

click Delete in contextual menu. As a result, a quarter of the original shell is left (Body 6): 

 

 

 

 

 

 

 

 

Meshing 

1. Create a quadrangular mesh.  

Select meshing on plane section on Command Panel (Mode 

— Mesh, Entity — Surface, Action — Intervals). Specify the 

parameters of mesh refinement: 

 Select surfaces: 7; 

 The way of meshing: Approximate Size; 

 Approximate Size: 0.125. 

Click Apply.  

 

 

 

 

 

 

 

 Select meshing on plane section on Command Panel 

(Mode — Mesh, Entity — Surface, Action —Meshing). Select meshing scheme: 
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 Select surfaces: 7; 

 Select meshing scheme: Polyhedron; 

 

Click Apply. 

Click  Mesh. 
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Setting boundary conditions 

1. Fix the line AB on the conditions of symmetry. 

Select Mode — Boundary Conditions, Entity — Displacement, Action — Create on Command Panel. Set the 

following parameters: 

 System Assigned ID; 

 Entity List: Curve; 

 Entities ID: 5 (or click on the top line on a quarter of the shell); 

 Degrees of Freedom: Х-Translation, Y-Rotation, Z-Rotation; 

 DOF Value: 0. 

 Click Apply. 
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2.  Fix the line CD of the conditions of symmetry. 

Select Mode — Boundary Conditions, Entity — Displacement, Action 

— Create on Command Panel. Set the following parameters: 

 System Assigned ID; 

 Entity List: Curve; 

 Entities ID: 16 (or click on the lower line on a quarter of the 

shell); 

 Degrees of Freedom: Y-Translation, X-Rotation, Z-Rotation; 

 DOF Value: 0.  

 Click Apply. 

 

 

 

 

 

 

 

 

 

 

 

 

Apply pressure to the entire surface of the shell. 

Select Mode — Boundary Conditions, Entity — Pressure, Action 

— Create on Command Panel. Set the following parameters: 

 System Assigned ID; 

 Entity List: Surface; 

 Entities ID: 7 (or click on the surface of the shell); 

 Value: 1000. 

 Click Apply. 
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Setting material and element type 

1. Create the material.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity — Material, Action 

— Create Material). Set the following parameters:  

 Name: Material 1; 

 Property group: Hook material; 

 Young’s Modulus: 200e9; 

 Poisson’s Ratio: 0.3.  

Click Apply. 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 

2.  Create a block of one type of the material.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity — Block, Action — 

Manage). Select Add in the list of possible operations. Set the 

following parameters: 

 Block ID: 1; 

 Entity type to be united into the block: Surface; 

 ID: 7 (or by the command all). 

Click Apply. 
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3. Assign the material to the block.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity — Block, Action — 

Manage). Select Assign Material to Block in the list of possible 

operations. Set the following parameters: 

 Block(s) ID: 1; 

 Select the previously created material in the list: 

Material 1. 

Click Apply. 

 

 

 

 

 

 

4. Assign the element type.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity — Block, Action — 

Manage). Select Element Type in the list of possible 

operations. Set the following parameters:  

 Block(s) ID: 1; 

 Select: Surfaces; 

 Elements: Shell4. 

Click Apply. 
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Setting shell thickness 

1. Set the shell thickness.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity — Block, Action – 

Manage). Select Shell thickness in the list of possible 

operations. Set the following parameters:  

 Block ID: 1; 

 Thickness: 0.02; 

 Loft Factor: 0.5; 

Click Apply. 

 

 

 

 

 

 

 

 

 

Starting calculation 

1. Set the type of the problem to be solved.  

Select calculation setting section on Command Panel (Mode — 

Calculation settings, Calculation settings — Stability, Stability 

— General). Select 3 in the field Number of buckling modes. 

Leave other parameters by  default. Click Apply. Click Start 

calculation. 

In a pop-up window select a folder to save the result and enter 

the file name. 

If the calculation is finished successfully, you will see a 

message in the Console: “Calculation finished successfully at 

<date> <time>”.  
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Results analysis 

1. Compare the obtained results. 

The first three critical values are displayed in Command Line.  

 

Compare the obtained results with those in the table: 

 

№ Theor. value FIDESYS 

1 72.260 72.5865 0.45% 

2 164.835 159.28 3.37% 

3 293.040 292.571 0.16% 

 

 

 

2. Open the file with the results. You can do this in one of 

the three ways.  

 Click  Ctrl+E. 

 Select Calculation → Open Results in the Main Menu. 

Click  Open last result. 

 Select Calculations Manager on Command Panel (Mode 

— Calculations Manager, Calculations Manager — 

Results). Click  Open Results.  

 

3. In a pop-up Fidesys Viewer window select a filter Warp 

By Vector. 

 

 

 

4. In a pop-up filter Warp By Vector in the tab Properties, set the following parameters: 

 Vectors: Displacement Mode 1 

 Scale Factor: 10 
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5. Display Displacements Mode 1. 

In Fidesys Viewer window set the following parameters on Toolbar: 

 

Make sure that the first required critical value is displayed in the window Critical value. 

6. View results 

As a result, the deformed body is displayed at the picture. To see the original model, click near the 

model in the Model Tree. The picture below shows the deformed (solid grey filling) and the original 

model (with the distribution field Displacements for Mode 1). 

 

7. Select the filter Warp By Vector to do this. Set the following field value Displacements Mode 2 in 

the tab Properties  

 Vectors: Displacements Mode 2 

 Scale Factor: 10 

8. Display Displacements Mode 2. 

In Fidesys Viewer window set the following parameters on Toolbar: 

 

Make sure that the second required critical value is displayed in the window Critical value. 

9. View results  
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10.  Display Displacements Mode 3 in the same way, make sure that the third required critical value is 

displayed in the window Critical value. 

 

11. Display the 3D-view of the model (shell with thickness). 

To do this, click on the name of the source file in the Model Tree. After this click 3D-view button in the 

default string. 
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The file* _3D.pvd with a 3D-image of the shell must be opened and you will be able to apply various filters 

to it and to view its deformed view. 

Choose the new file example_3D.pvd in the Model Tree and display Filters Warp by Vector for it with the 

following fields values: 

 Vectors: Displacements for mode 1 

 Scale Factor: 10 

On the Toolbar, set once again the following parameters for the deformed type: 

 

The first buckling mode will be displayed on the screen but the shell will be enveloped with thickness. 
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To apply all of the filters changes automatically, click Apply changes to parameters automatically on 

Command Panel. 

12. Download numerical data. 

Select File → Save Data in the Main Menu or click 

Ctrl+S. Enter the file name (*.csv format), leave it by 

default. Click  OK. In the pop-up window select:  

 Field Association: Field Data  

  

The saved file is an ordinary table of numerical data 

which can be opened in any text editor. 

 

 

Using Console Interface 

For geometry generation, meshing, setting boundary conditions and materials you can use Console 

Interface. The following program code allows performing the steps of the above-described guide, you only 

need to manually specify the full path and name of the file to be saved. 

Here is an example of the working script (the file is saved in D:/FidesysBundle/calc/example.pvd) 
  

reset 
set node constraint on 
create Cylinder height 2 radius 2  
delete volume 1 keep_lower_geometry  
delete Surface 3 2  
webcut body 2 with plane xplane offset 0 imprint preview  
webcut body 2 with plane xplane offset 0 imprint  
webcut body 2 with plane yplane offset 0 imprint preview  
webcut body 2 with plane yplane offset 0 imprint  
delete Surface 5 6  
surface 7 size 0.125 
surface 7 scheme Polyhedron 
mesh surface 7 
create displacement on curve 16 dof 2 dof 4 dof 6 fix 0  
create displacement on curve 5 dof 1 dof 5 dof 6 fix 0  
create pressure on surface 7 magnitude 1000  
undo group begin 
create material "Material 1" property_group "CUBIT-FEA" description "Hook material"  
modify material "Material 1" scalar_properties "MODULUS" 2e+11 "POISSON" 0.3  
undo group end 
set duplicate block elements off 
block 1 surface 7  
block 1 material 'Material 1' 
block 1 element type shell4 
undo group begin 
block 1 attribute count 2 
block 1 attribute index 1 value 0.02 
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block 1 attribute index 2 value 0.5 
undo group end 
analysis type stability elasticity dim3 
eigenvalue find 3 smallest 
spectralelement off 
usempi off 
calculation start path "D:/FidesysBundle/calc/example.pvd" 
 

It is also possible to run the file Example_7_Stability_Shell.jou, by selecting Journal Editor on 

Toolbar. In a pop-up window of the main menu select File → Open and open the necessary journal 

file.  
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Modal analysis (3D) 

NAFEMS Selected Benchmarks for Natural Frequency Analysis “Simply Supported "Solid" Square Plate”, Test No 

FV52. 

The problem of modal analysis of a square plate is being solved. 

The picture represents a geometric model of the problem and a mesh: 

The size of the plate is 10 m х 10 m х 1 m. 

Displacements along z-axis are constrained for 

the edges of the plate bottom side. The 

material parameters are E = 200 hPa, ν = 0.3, ρ 

= 8000 kg/m3. 

Eigenmodes from 4 to 10 are to be compared. 

 

 

Geometry creation 

1. Create the plate. 

Select volume geometry generation section on Command Panel (Mode — Geometry, Entity — Volume, 

Action — Create). Select Brick in the list of geometric elements. Set the brick dimensions:  

 X (width): 10 

 Y (height): 10 

 Z (depth): 1 

Click Apply. 
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Meshing 

A mesh of 8*8*3 linear hexahedral elements is to be generated 

(as shown at the picture with the problem setting). 

1. Select meshing on curves section on Command Panel 

(Mode — Mesh, Entity — Curve, Action — Meshing). Specify the 

parameters of mesh refinement: 

 Select Curves: 1 2 3 4 5 6 7 8 (using space after each of 

them); 

 Select the way of meshing: Equal; 

 Select splitting settings: Interval; 

 Interval: 8 (see the figure) 

Click Apply. 

 

2. Select meshing on curves section on Command Panel (Mode 

— Mesh, Entity — Curve, Action — Meshing). Specify the 

parameters of mesh refinement: 

 Select Curves: 9 10 11 12 (using space after each of them); 

 Select the way of meshing: Equal; 

 Select splitting settings: Interval; 

 Interval: 3. 

Click Apply.  

 

 

 

 

3. Select volume mesh generation section on Command Panel 

(Mode — Mesh, Entity — Volume, Action — Mesh).  

 Select Entities to Mesh (specify their ID): 1 (or by the 

command all) 

 Select Meshing Scheme: Automatically Calculate 

Click Apply Scheme.  

Click Mesh. 
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Setting boundary conditions 

1. Fix the bottom side edges along Z.  

Select Mode — Boundary Conditions, Entity — Displacement, Action 

— Create on Command Panel. Set the following parameters: 

 System Assigned ID 

 Entity List: Curve 

 Entity ID(s):  5 6 7 8 (using space after each of them) 

 Degrees of Freedom: Z-Translation 

 DOF Value: 0 

 Click Apply. 

 

 

 

 

 

 

 

 

 

 

 

Setting material and element type 

1. Create the material. 

Select setting the material properties section on Command Panel 

(Mode — Blocks and Materials, Entity — Material, Action — Create 

Material). Set the following parameters:  

 Name: Material 1; 

 Property group: Hook material; 

 Young’s Modulus: 200e9; 

 Poisson’s Ratio: 0.3; 

 Density: 8000. 

Click Apply. 
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2. Create a block of one type of the material.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity — Block, Action — 

Manage). Select Add in the list of possible operations. Set the 

following parameters: 

 Block ID: 1; 

 Entity type to be united into the block: Volume; 

 ID: 1 (or by the command all). 

Click Apply. 

. 
  

 
 
 
 
 
 
 
 
 
 
 
 

 

3. Assign the material to the block.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity — Block, Action — 

Manage). Select Assign Material to Block in the list of possible 

operations. Set the following parameters: 

 Block(s) ID: 1; 

 Select the previously created material in the list: 

Material 1. 

Click Apply. 

 

 

 

 

 

 

 

  



 CAE Fidesys — User Guide (version 1.6) 

 

4. Assign the element type.  

Select setting the material properties section on Command Panel 

(Mode — Blocks and Materials, Entity — Block, Action — Manage). 

Select Element Type in the list of possible operations. Set the 

following parameters:  

 Block(s) ID: 1; 

 Select: Volumes; 

 Volumes: Hex8. 

Click Apply. 

 

 

 

 

 

 

 

 

 

Starting calculation 

1. Set the type of the problem to be solved.  

Select calculation setting section on Command Panel (Mode — 

Calculation settings, Calculation settings — Eigen Frequencies, 

Eigen Frequencies — General). Specify the following settings: 

 Interval: 20 – 250.  

Click Apply.  

Click  Start Calculation.  
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2. In a pop-up window select a folder to save the result and enter the file name. 

3. If the calculation is finished successfully, you will see a message in the Console: “Calculation finished 

successfully at <date> <time>” as well as the required eigen values and frequencies. 

 

Results analysis 

1. Compare the obtained results to those in the given table. 

 

№ NAFEMS FIDESYS 

  Value, Hz Error 

4 51.65 51.68 0.1% 

5 132.73 132.75 0.0% 

6 132.73 132.75 0.0% 

7 194.37 194.38 0.0% 

8 197.18 197.19 0.0% 

9 210.55 210.55 0.0% 

10 210.55 210.55 0.0% 

 

2. Open the file with the results. You can do this in one of the three ways. 

 Click  Ctrl+E. 

 Select Calculation → Open Results in the Main 

Menu. Click  Open last result. 

 Select Calculations Manager on Command 

Panel (Mode — Calculations Manager, Calculations Manager — Results). Click  Open Results.  

 

 

 

 

 

 

 

 

 

 

3. You can see the way the body is deformed. 

Select a filter Warp By Vector to do this. Set the following parameters in the tab Properties: 

 Vectors: Eigenvalue_# (# stands for the number of the eigenvalue) 

 Scale Factor: 700 

 As a result, the deformed body is displayed at the picture. To see the original model, click  near it in 

the Model Tree. The picture below shows the deformed model at different eigenvalues. 
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Mode 4  

 

Mode 5  

 

Mode 6  

 

Mode 7  

 

Mode 8  

 

Mode 9  

 

Mode 10  

 

 

 

Using Console Interface 

For geometry generation, meshing, setting boundary conditions and materials you can use Console 

Interface. The following program code allows performing the steps of the above-described guide, you only 

need to manually specify the full path and name of the file to be saved. 

Here is an example of the working script (the file is saved in D:/FidesysBundle/calc/example.pvd): 
 

reset 
set node constraint on 
brick x 10 y 10 z 1 
curve 1 2 3 4 5 6 7 8 interval 8 
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curve 1 2 3 4 5 6 7 8 scheme equal 
curve 9 10 11 12 interval 3 
curve 9 10 11 12 scheme equal 
volume 1 scheme Auto 
volume 1 scheme Auto 
mesh volume 1  
create displacement on curve 5 6 7 8 dof 3 fix 0  
undo group begin 
create material "material 1 " property_group "CUBIT-FEA" description "Hook material"  
modify material "material 1 " scalar_properties "MODULUS" 2e+11 "POISSON" 0.3 "DENSITY" 
8000  
undo group end 
set duplicate block elements off 
block 1 volume 1  
block 1 material 'material 1' 
block element type hex8 
block 1 element type hex8 
analysis type eigenfrequencies elasticity dim3 
eigenvalue find 10 from 20 to 250 preload off 
spectralelement off 
usempi off 
analysis type eigenfrequencies elasticity dim3 
calculation start path "D:/FidesysBundle/calc/example.pvd" 
 
 

It is also possible to run the file Example_8_EigenValue_3D.jou, by selecting Journal Editor on 

Toolbar. In a pop-up window of the main menu select File → Open and open the necessary journal 

file . 
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Modal analysis (shell model)  

NAFEMS-Glasgow, BENCHMARK newsletter, Report No. E1261/R002, “Free 

Vibrations of a Simply-supported Thin Square Plate” , February 1989, 

p.21. 

The problem of modal analysis of a square plate is being solved. 

The size of the plate is 10 m х 10 m, the thickness is 0.05 m. X- and Y-

Translation and Z-Rotation are constrained for all nodes of the plate. 

All the edges are constrained in Z-direction. The X-rotation is 

constrained for edges AB and CD. The Y-rotation is constrained for 

edges BC and AD. The material parameters are E = 200 hPa, ν = 0.3, ρ 

= 8000 kg/m3. 

Eigenmodes from 1 to 8 are to be compared. 

 

Geometry creation 

1. Create the plate.  

Select volume geometry generation section on Command Panel (Mode 

— Geometry, Entity — Surface, Action — Create). Select Rectangle in 

the list of geometric elements. Set the brick dimensions:  

 Width: 10; 

 Location: ZPlane. 

Click Apply. 

 

 

 

 

Meshing 

A mesh of 32*32 linear quadrilateral elements is to be generated (as 

shown at the picture with the problem setting. 

1. Select meshing on curves section on Command Panel (Mode 

— Mesh, Entity — Curve, Action — Meshing). Specify the parameters 

of mesh refinement: 

 Select Curves: all; 

 Select the way of meshing: Equal; 

 Select splitting settings: Interval; 

 Interval: 32 (see the figure).  

Click Apply. 

Click Mesh.  
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2.  Select surface mesh generation section on Command 

Panel (Mode — Mesh, Entity — Surface, Action — Meshing). 

 Select Entities to Mesh (specify their ID): 1 (or by the 

command all) 

 Select Meshing Scheme: Automatically Calculate 

Click Apply Scheme.  

Click Mesh. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Setting boundary conditions 

1. Fix the plate: X- and Y-Translations and Z-Rotations.  

Select Mode — Boundary Conditions, Entity — Displacement, 

Action — Create on Command Panel. Set the following 

parameters: 

 System Assigned ID; 

 Entity List: Node; 

 Entity ID(s):  all; 

 Degrees of Freedom: X-Translation, Y-Translation and 

Z-Rotation; 

 DOF Value: 0. 

 Click Apply.  

2. Fix all the edges at the Z-direction.  

Select Mode — Boundary Conditions, Entity — Displacement, 

Action — Create. Set the following parameters: 

 System Assigned ID; 

 Entity List: Curves; 
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 Entity ID(s):  all; 

 Degrees of Freedom: Z-Translation; 

 DOF Value: 0. 

 Click Apply.  

 

3. Fix the edges AB and CD on X-Rotation.  

Select Mode — Boundary Conditions, Entity — Displacement, Action — Create on Command Panel. Set the 

following parameters: 

 System Assigned ID; 

 Entity List: Curves; 

 Entity ID(s):  2 4 (using space after each of them); 

 Degrees of Freedom: X-Rotation; 

 DOF Value: 0. 

 Click Apply.  

4. Fix the edges BC and AD in Y-rotation.  

Select Mode — Boundary Conditions, Entity — Displacement, Action — Create on Command Panel. Set the 

following parameters: 

 System Assigned ID; 

 Entity List: Curves; 

 Entity ID(s):  1 3 (using space after each of them); 

 Degrees of Freedom: Y-Rotation; 

 DOF Value: 0. 

 Click Apply. 

 

 

Setting material and element type 

1. Create the material. 

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity — Material, Action 

— Create Material). Set the following parameters:  

 Name: Material 1; 

 Property group: Hook material; 

 Young’s Modulus: 200e9; 

 Poisson’s Ratio: 0.3; 

 Density: 8000. 

Click Apply. 
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2. Create the block of one type of the material 

 

Select setting the material properties section on Command Panel (Mode — Blocks and Materials, Entity — 

Block, Action — Manage). Set the following parameters: 

 Block ID: 1; 

 Entity type to be united into the block: Surface; 

 ID: 1 (or by the command all). 

Click Apply. 
 

3. Assign the material to the block.  

Select setting the material properties section on Command Panel 

(Mode — Blocks and Materials, Entity — Block, Action — 

Manage). Select Assign Material to Block in the list of possible 

operations. Set the following parameters: 

 Block(s) ID: 1; 

 Select the previously created material in the list: Material 

1. 

Click Apply. 

 

 

 

 

 

 

 

 

 

 

 

4. Assign the element type.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity — Block, Action — 

Manage). Select Element Type in the list of possible 

operations. Set the following parameters:  

 Block(s) ID: 1; 

 Select: Surfaces; 

 Surfaces: Shell4. 

Click Apply. 
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Setting shell thickness 

 

1. Set the shell thickness.  

Select setting the material properties section on Command Panel (Mode — Blocks and Materials, Entity — 

Block, Action – Manage). Select Shell thickness in the list of possible operations. Set the following 

parameters:  

 Block ID: 1; 

 Thickness: 0.05; 

 Loft Factor: 0.5; 

Click Apply. 
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Starting calculation 

1. Set the type of the problem to be solved.  

Select calculation setting section on Command Panel (Mode — 

Calculation settings, Calculation settings — Eigen Frequencies, 

Eigen Frequencies — General). Set the default settings.  

Click Apply.  

Click  Start Calculation. 

2. In a pop-up window select a folder to save the result and 

enter the file name. 

3. If the calculation is finished successfully, you will see a 

message in the Console: “Calculation finished successfully at 

<date> <time>” as well as the required eigenvalues and 

frequencies. 

 

 

 

 

Results analysis 

1. Compare the obtained results to those given in the picture. 
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2. Open the file with the results. You can do this in one of the three ways. 

 Click  Ctrl+E. 

 Select Calculation → Open Results in the Main 

Menu. Click  Open last result. 

 Select Calculations Manager on Command 

Panel (Mode — Calculations Manager, 

Calculations Manager — Results). Click  Open Results.  

 

 

3.  You can see the way the body is deformed under the applied pressure. 

Select a filter Warp By Vector to do this. Set the following parameters in the 

tab Properties: 

 Vectors: Eigenvalue_# (# stands for the number of the eigenvalue); 

 Scale Factor: 200. 

 As a result, the deformed body is displayed at the picture. To see the 

original model, click  near it in the Model Tree. The picture below shows 

the deformed model at different eigenvalues. 

 

 

4. Display the 3D-view of the model (shell with 

thickness). 

To do this, click on the name of the source file in the 

Model Tree. After this click 3D-view button in the 

default string. 

 

The file *_3D.pvd with a 3D-image of the shell must 

be opened and you will be able to apply various filters 

to it and to view its deformed view. 

 

Using Console Interface 

For geometry generation, meshing, setting boundary conditions and materials you can use Console 

Interface. The following program code allows performing the steps of the above-described guide, you only 

need to manually specify the full path and name of the file to be saved. 

Here is an example of the working script (the file is saved in D:/FidesysBundle/calc/example.pvd): 
 

reset 
set node constraint on 
create surface rectangle width 10 zplane  
curve all interval 32 
curve all scheme equal 
surface 1 scheme Auto 
surface 1 scheme Auto 
mesh surface 1 
create displacement on node all dof 1 dof 2 dof 6 fix 0  
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create displacement on curve all dof 3 fix 0  
create displacement on curve 2 4 dof 4 fix 0  
create displacement on curve 1 3 dof 5 fix 0  
undo group begin 
create material "material 1" property_group "CUBIT-FEA" description "Hook material"  
modify material "material 1" scalar_properties "MODULUS" 2e+11 "POISSON" 0.3 "DENSITY" 
8000  
undo group end 
set duplicate block elements off 
block 1 surface 1  
block 1 material 'material 1' 
block 1 element type shell4 
undo group begin 
block 1 attribute count 2 
block 1 attribute index 1 value 0.05 
block 1 attribute index 2 value 0.5 
undo group end 
analysis type eigenfrequencies elasticity dim3 
eigenvalue find 10 smallest preload off 
spectralelement off 
usempi off 
analysis type eigenfrequencies elasticity dim3 
eigenvalue find 10 smallest preload off 
spectralelement off 
usempi off 
calculation start path 'D:/FidesysBundle/calc/example.pvd' 
 

It is also possible to run the file Example_9_Eigenvalue_Shell.jou, by selecting Journal Editor on 

Toolbar. In a pop-up window of the main menu select File → Open and open the necessary journal 

file. 
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Setting heat transfer (3D, working with two blocks) 

 

The 3D problem of a hollow two-material cylinder which inner and outer 

surfaces undergo the convection is being solved.  

The pictures represent a geometric model of the problem: 

The inner radius of the cylinder Ri = 0.30 m, the middle radius of the cylinder 

(at the place of material changing) Rm = 0.35 m, the external radius of the 

cylinder Re = 0.37 m.  

Сonvective heat exchange with internal temperature Ti = 70 ° C and coefficient 

hi = 150 W/ m2/°C occurs on the inner surface of the cylinder. Сonvective heat 

exchange with exterior temperature Te = -15 °C and coefficient he = 200 W/ 

m2/°C occurs on the outer surface of the cylinder. 

Materials are isotropic. The material heat transfer 1 is Ѵ1 = 40 W/(m·°C). The 

material heat transfer 2 is Ѵ2 = 20 W/(m·°C). 

Test pass criterion is the following:  

at the point (0.3, 0, 0) heat flux φ = 6687 W/ m2 is within 1%. 

 

 

 

Geometry creation 

1. Create the first cylinder. 

Select volume geometry generation section on Command Panel 

(Mode – Geometry, Object – Volume, Action – Create). Select 

Cylinder in the list of geometric elements. Specify the cylinder 

dimensions:  

 Height: 0.01; 

 Circular; 

 Radius: 0.3. 

Click Apply. 
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2. Create the second cylinder.  

Select volume geometry generation section on Command Panel (Mode — Geometry, Entity — Volume, 

Action — Create). Select Cylinder in the list of geometric elements. Specify the cylinder dimensions:  

 Height: 0.01; 

 Circular; 

 Radius: 0.35. 

Click Apply. 

 

 

3. Create the third cylinder.  

Select volume geometry generation section on Command Panel 

(Mode — Geometry, Entity — Volume, Action — Create). Select 

Cylinder in the list of geometric elements. Specify the cylinder 

dimensions:  

 Height: 0.01; 

 Circular; 

 Radius: 0.37. 

Click Apply. 

 

As a result, three generated entities are displayed in the Model 

Tree (Volume 1, Volume 2 and Volume 3). 

 

 

4. Subtract the first cylinder from the second one. 

Select volume geometry generation section on Command Panel 

(Mode — Geometry, Entity — Volume, Action — Boolean). Select 

Subtract in the list of operations. Set the following parameters: 

 Body ID: 2 (volumes from which other volumes will be 

subtracted); 

 Substract bodies (ID): 1 (the volumes to be subtracted);  

 Keep Originals. 

Click Apply. 
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5. Subtract the second cylinder from the third one. 

Select volume geometry generation section on Command Panel (Mode — Geometry, Entity — Volume, 

Action — Boolean). Select Subtract in the list of operations.  Set the following parameters: 

 Body ID: 3 (volumes from which other volumes will be subtracted); 

 Substract bodies (ID): 2 (the volumes to be subtracted);  

 Keep Originals. 

Click Apply. 

 

 

 

As a result, five generated entities are displayed in the Model 

Tree: Volume 1, Volume 2, Volume 3, Volume 4 and Volume 5. 

Delete the thirst three bodies by right-clicking and selecting 

Delete.  

Two entities: Volume 4 and Volume 5 are left in the Model 

Tree. 

 

 

 

 

 

 

6. Unite obtained objects. 

Select volume geometry generation section on Command 

Panel (Mode — Geometry, Entity — Volume, Action — Impirint 

And Merge). Select Merge in the list of operations. Set the 

following parameters: 

 Body ID: 4 5 (the volumes to be united).  

Click Apply. 
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Meshing 

1. Select meshing on curves section on Command Panel 

(Mode — Mesh, Entity — Curve, Action — Meshing). Specify the 

parameters of mesh refinement: 

 Select Curves: all (mesh will be creat on all the curves); 

 Select the way of meshing: Equal; 

 Select the meshing parameters: Interval; 

 Interval: 200. 

Click Apply. 

 

 

 

 

 

 

 

 

 

 

2. Select volume mesh generation section on Command Panel 

(Mode — Mesh, Entity — Volume, Action — Mesh). 

 Select volumes: all (mesh will be creat on all the volumes); 

 Select meshing scheme: Polyhedron. 

Click  Apply Scheme. 

Click Mesh. 
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Setting material and element type  

1. Create Material 1.  

Select setting the material properties section on Command Panel (Mode — Blocks and Materials, Entity — 

Material, Action — Create Material). Enter the name for the material. Set the following parameters:  

 Coeff. of Thermal Expansion: 40. 

Click Apply. 

 

2. Create Material 2.  

Select setting the material properties section on Command Panel (Mode — Blocks and Materials, Entity — 

Material, Action — Create Material). Enter the name for the material. Set the following parameters:  

 Coeff. of Thermal Expansion: 20. 

Click Apply. 
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3. Create Block 1.  

Select setting the material properties section on 

Command Panel (Mode — Blocks and Materials, Entity — 

Block, Action — Manage). Select Add in the list of possible 

operations. Set the following parameters: 

 Block ID: 1; 

 Entity type to be united into the block: Volume;  

 ID: 4. 

Click Apply. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

4. Assign the material to block 1.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity — Block, Action — 

Manage). Select Assign Material to Block in the list of possible 

operations. Set the following parameters: 

 Block(s) ID: 1; 

 Select the previously created material in the list: 

Material 1. 

Click Apply. 
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5.  Create Block 2.  

Select setting the material properties section on 

Command Panel (Mode — Blocks and Materials, Entity — 

Block, Action — Manage). Select Add in the list of possible 

operations. Set the following parameters: 

 Block ID: 2; 

 Entity type to be united into the block: Volume; 

 ID: 5. 

Click Apply. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

6. Assign the material to block №2.  

Select setting the material properties section on 

Command Panel (Mode — Blocks and Materials, Entity — 

Block, Action — Manage). Select Assign Material to Block 

in the list of possible operations. Set the following 

parameters: 

 Block(s) ID: 2; 

 Select the previously created material in the list: 

Material 2. 

Click Apply. 
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7. Assign the element type to the both of blocks.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity — Block, Action 

— Manage). Select Element Type in the list of possible 

operations. Set the following parameters:  

 Block(s) ID: all; 

 Select: Volumes; 

 Volumes: Hex27. 

Click Apply. 
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Setting boundary conditions 

1. Set the process of convective heat exchange on the inner 

surface of the cylinder.  

Select Mode — Boundary Conditions, Entity — Convection, Action 

— Create on Command Panel. Set the following parameters: 

 System Assigned ID; 

 Entity List: Surface; 

 Entity ID(s):  10; 

 Select the way of parameters setting: Surrounding; 

 Value: 70; 

 Coefficient: 150. 

 Click Apply. 
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2. Set the process of convective heat exchange on the outer 

surface of the cylinder.  

Select Mode — Boundary Conditions, Entity — Convection, Action — 

Create on Command Panel. Set the following parameters: 

 System Assigned ID; 

 Entity List: Surface; 

 Entities ID: 15; 

 Select the way of parameters setting: Surrounding; 

 Value: -15; 

 Coefficient: 200. 

 Click Apply. 
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3.  Fix the base of the cylinder. 

Select Mode — Boundary Conditions, Entity — Displacement, 

Action — Create on Command Panel. Set the following 

parameters: 

 System Assigned ID; 

 Entity List: Surface; 

 Entities ID: 12 13 16 17 (using space after each of them); 

 Degrees of Freedom: Z-Translation; 

 DOF Value: 0. 

 Click Apply. 
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Starting calculation 

1. Set the type of the problem to be solved.  

Select calculation setting section on Command Panel (Mode — 

Calculation settings, Calculation settings — Static, Static — 

General). Select Dimension – 3D. Untick next to the item 

Elasticity. Tick next to the item Heat transfer. 

Click Apply.  

  

2. Set the solver settings. 

Select calculation setting section on Command Panel (Mode — 

Calculation settings, Calculation settings — Static, Static — 

Solver). Select the solver method (direct or iterative) and set 

Convergence Parameters in case of choosing an iterative one. 

You can also leave all the settings by default.  

Click Apply.  

Click  Start Calculation. 

 

3. In a pop-up window select a folder to save the result and 

enter the file name. 

 

4. If the calculation is finished successfully, you will see a message in the Console: “Calculation finished 

successfully at <date> <time>”.  

 

 

Results analysis 

1. Open the file with the results. You can do this in 

one of the three ways. 

 Click  Ctrl+E. 

 Select Calculation → Open Results in the Main Menu. Click  Open last result. 

 Select Calculations Manager on Command Panel (Mode — Calculations Manager, Calculations 

Manager — Results). Click Open Results.  
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2. Display the component of the heat flux. 

In Fidesys Viewer window set the following parameters on Toolbar: 

 Representation Mode: Surface; 

 Representation Field: HeatFlux. 

 

 To display the color legend scale, click the button Switch the color legend visibility on Command 

Panel. 

3. Select a point where you need to view the heat flux. 

In the Main Menu, select the filter Probe Location. In the tab Properties set the coordinates of the point A 

where you need to view the stress: 

 Show Point; 

 Point (coordinates): 0.3 0 0; 

 Number of Points: 1; 

 Radius: 0. 

Click Apply. 

To apply all of the filters changes automatically, click Apply changes to parameters automatically on 

Command Panel. 

As a result, point A is displayed at the picture. 
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4. View a numerical value of the heat flux  φ at the selected point A. 

See the heat flux values in the line HeatFlux in the tab Information in the field Data Arrays. 

 

The heat flux value is calculated using the following formula:  

√φ𝑥
2 + φ𝑦

2 + φ𝑧
2 = √ 6686.412 + (−0.00302395)2 + (8.02105e − 05)2 = 6686.41 

The difference between the obtained value 6686.41 and the required one 6 687 is 0.01%. 

 

5. Download numerical data. 

Select File → Save Data in the Main Menu or click Ctrl+S. Enter the file name (*.csv format), leave it by 

default. Click ОК. The saved file is an ordinary table of numerical data which can be opened in any text 

editor. 

 

 

Using Console Interface 

For geometry generation, meshing, setting boundary conditions and materials you can use Console 

Interface. The following program code allows performing the steps of the above-described guide, you only 

need to manually specify the full path and name of the file to be saved. 

Here is an example of the working script (the file is saved in D:/FidesysBundle/calc/example.pvd): 
reset 
create Cylinder height 0.01 radius 0.3  
create Cylinder height 0.01 radius 0.35  
create Cylinder height 0.01 radius 0.37  
subtract body 1 from body 2 keep 
subtract body 2 from body 3 keep  
delete body 1 2 3 
merge volume 4 5 
curve all interval 200 
curve all scheme equal 
volume all scheme Polyhedron 
mesh volume all  
create material "Material 1" property_group "CUBIT-FEA"  
modify material "Material 1" scalar_properties "CONDUCTIVITY" 40  
create material "Material 2" property_group "CUBIT-FEA"  
modify material "Material 2" scalar_properties "CONDUCTIVITY" 20 
block 1 volume 4 
block 1 material 'Material 1' 
block 2 volume 5 
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block 2 material 'Material 2' 
block all element type HEX27 
create convection on surface 10 surrounding 70 coefficient 150 
create convection on surface 15 surrounding -15 coefficient 200 
create displacement on surface 12 13 16 17 dof 3 fix 0 
analysis type static heattrans dim3  
calculation start path " D:/FidesysBundle/calc/example.pvd" 
 
 

It is also possible to run the file Example_10_Static_3D_Conduction.jou, by selecting Journal Editor 

on Toolbar. In a pop-up window of the main menu select File → Open and open the necessary 

journal file. 

 

  



 CAE Fidesys — User Guide (version 1.6) 

 

Setting heat transfer (2D) 

2D problem of a hollow cylinder under the convection is being solved. 

The picture below represents a geometric model of the problem: 

The inner radius of the cylinder is Ri = 0,30 m, the external radius is Re = 0,391 

m. 

Сonvective heat exchange with internal temperature Ti = 500 °C and 

coefficient hi = 150 W/ m2/°C occurs on the inner surface of the cylinder. 

Сonvective heat exchange with exterior temperature Te = 20 °C and 

coefficient he = 142 W/ m2/°C occurs on the outer surface of the cylinder. 

The material is isotropic. The material parameters are E=210 GPa, ν=0.3, V=40 W/(m · °C). 

 

Test pass criterion: at the point (0,3;0;0) temperature T = 272.3 °C, heat flux φ = 3.416E4 W/m2 are within 

1 %. 

 

Geometry creation 

1. Create the first circle. 

Select 2D geometry generation section on Command Panel (Mode 

— Geometry, Entity — Surface, Action — Create). Select Circle in the 

list of geometric elements. Specify the circle dimensions:  

 Radius: 0.3. 

Click Apply. 

 

 

 

 

 

 

2. Create the second circle.  

Select 2D geometry generation section on Command Panel (Mode — 

Geometry, Entity — Surface, Action — Create). Select Circle in the list of 

geometric elements. Specify the circle dimensions:  

 Radius: 0.391. 

Click Apply. 

As a result, two generated entities are displayed in the Model Tree (Body 

1 and Body 2). 
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3. Subtract the first circle from the second one. 

Select volume geometry generation section on Command Panel 

(Mode — Geometry, Entity — Volume, Action — Boolean). Select 

Subtract in the list of operations. Set the following parameters: 

 Body ID: 2 (volumes from which other volumes will be 

subtracted); 

 Substract bodies (ID): 1 (the volumes to be subtracted);  

 Imprint. 

 Click Apply. 

 

 

 

 

 

As a result, only one entity 

is displayed in the Model 

Tree (Body 2). 

 

 

 

 

 

 

 

 

Meshing 

1. Select meshing on curves section on Command Panel 

(Mode — Mesh, Entity — Curve, Action — Meshing). Specify the 

parameters of mesh refinement: 

 Select Curves: 3 2 (using space after each of them); 

 Select the way of meshing: Equal; 

 Select the meshing parameters: Interval; 

 Interval: 200. 

Click Apply. 
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2.  Select surface mesh generation section on Command Panel 

(Mode — Mesh, Entity — Surface, Action — Meshing). 

 Select surfaces (specify their ID): 3 (or by the command 

all); 

 Select meshing scheme: TriMesh. 

Click  Apply Scheme. 

Click Mesh. 

 

 

 

 

 

 

 

 

 

 

 

Setting material and element type 

1. Create the material.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity — Material, Action 

— Create Material). Enter the name for the material. Set the 

following parameters:  

 Conductivity: 40. 

Click Apply. 
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2. Create a block of one type of the material.  

Select setting the material properties section on 

Command Panel (Mode — Blocks and Materials, Entity — 

Block, Action — Manage). Select Add in the list of possible 

operations. Set the following parameters: 

 Block ID: 1; 

 Entity type to be united into the block: Surface; 

 ID: 3 (or by the command all). 

Click Apply. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

3. Assign the material to the block.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity — Block, Action 

— Manage). Select Assign Material to Block in the list of 

possible operations. Set the following parameters: 

 Block(s) ID: 1; 

 Select the previously created material in the list: 

Material 1. 

Click Apply. 
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4. Assign the element type.  

Select setting the material properties section on 

Command Panel (Mode — Blocks and Materials, Entity — 

Block, Action — Manage). Select Element Type in the list of 

possible operations. Set the following parameters:  

 Block(s) ID: 1; 

 Select: Surfaces; 

 Surfaces: Tri3. 

Click Apply. 
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Setting boundary conditions 

1. Set the process of convective heat exchange on the inner 

surface of the cylinder.  

Select Mode — Boundary Conditions, Entity — Convection, 

Action — Create on Command Panel. Set the following 

parameters: 

 System Assigned ID; 

 Entity List: Surface; 

 Entity ID: 10; 

 Select the way of parameters setting: Surrounding; 

 Value: 500; 

 Coefficient: 150. 

 Click Apply. 
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2. Set the process of convective heat exchange on the outer 

surface of the cylinder. 

Select Mode — Boundary Conditions, Entity — Convection, 

Action — Create on Command Panel. Set the following 

parameters: 

 System Assigned ID; 

 Entity List: Curve; 

 Entity ID: 2; 

 Select the way of parameters setting: Surrounding; 

 Value: 20; 

 Coefficient: 142. 

 Click Apply. 
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Starting calculation 

1. Set the type of the problem to be solved.  

Select calculation setting section on Command Panel (Mode — 

Calculation settings, Calculation settings — Static, Static — 

General). Select Dimension – 2D, Type of plane problem: Plane 

deformed state. Untick next to the item Elasticity. Tick next to 

the item Heat transfer. 

Click Apply. 

 

2. Set the solver settings. 

Select calculation setting section on Command Panel (Mode — 

Calculation settings, Calculation settings — Static, Static — 

Solver). Select the solver method (direct or iterative) and set 

Convergence Parameters in case of choosing an iterative one. 

You can also leave all the settings by default.  

Click Apply.  

Click  Start Calculation. 

3. In a pop-up window select a folder to save the result and 

enter the file name. 

4. If the calculation is finished successfully, you will see a 

message in the Console: “Calculation finished successfully at 

<date> <time>”.  

 

 

 

 

Results analysis 

1. Open the file with the results. You can do this in 

one of the three ways. 

 Click  Ctrl+E. 

 Select Calculation → Open Results in the Main Menu. 

Click  Open last result. 

 Select Calculations Manager on Command Panel (Mode 

— Calculations Manager, Calculations Manager — 

Results). Click  Open Results.  
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2. Display the component of temperatures. 

In Fidesys Viewer window set the following parameters on Toolbar: 

 Representation Mode: Surface; 

 Representation Field: Temperature. 

 

 To display the color legend scale, click the button Switch the color legend visibility on Command 

Panel. 

 

3. Select a point where you need to check the temperature. 

In the Main Menu, select the filter Probe Location. In the tab Properties set the coordinates of the point A 

where you need to view the stress: 

 Show Point; 

 Point (coordinates):  0.3 0 0; 

 Number of Points: 1; 

 Radius: 0. 

Click Apply. 

To apply all of the filters changes automatically, click Apply changes to parameters automatically on 

Command Panel. 

As a result, point A is displayed at the picture. 
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4. Check a numerical temperature value T at the selected point A. 

See the Temperature value in the line Heat flux in the tab Information in the field Data Arrays.  

 

The difference between the obtained value 272.347 and the required one 272.3 is 0.02%. 

 

5. Display the component of the heat flux. 

In Fidesys Viewer window set the following parameters on Toolbar: 

 Representation Mode: Surface; 

 Representation Field: HeatFlux. 
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6. View a numerical value of the heat flux  φ at the selected point A. 

You can see the heat flux values in the line HeatFlux in the tab Information in the field Data Arrays.. 

 

 

The heat flux value is calculated using the following formula: 

√φ
𝑥
2 + φ

𝑦
2 = √ 33512.72 +  526.0732 = 33516.82882 

The difference between the obtained 33516.82882 and the required one 3.416E4 is 1.88%. 

7. Download numerical data. 

Select File → Save Data in the Main Menu or click Ctrl+S. Enter the file name (*.csv format), leave it by 

default. Click ОК. The saved file is an ordinary table of numerical data which can be opened in any text 

editor. 

Using Console Interface 

For geometry generation, meshing, setting boundary conditions and materials you can use Console 

Interface. The following program code allows performing the steps of the above-described guide, you only 

need to manually specify the full path and name of the file to be saved. 

Here is an example of the working script (the file is saved in D:/FidesysBundle/calc/example.pvd): 
 

reset 
set node constraint on 
create surface circle radius 0.3 zplane  
create surface circle radius 0.391 zplane  
subtract body 1 from body 2 imprint  
curve 3 2 interval 200 
curve 3 2 scheme equal 
surface 3 scheme TriMesh 
mesh surface 3 
undo group begin 
create material "Material 1" property_group "CUBIT-FEA"  
modify material "Material 1" scalar_properties "MODULUS" 2.1e+11 "POISSON" 0.3 
"CONDUCTIVITY" 40  
undo group end 
set duplicate block elements off 
block 1 surface 3  
block 1 material 'Material 1' 
block 1 element type tri3 
create convection on curve 3 surrounding 500 coefficient 150 
create convection on curve 2 surrounding 20 coefficient 142 
analysis type static heattrans dim2 planestrain 
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spectralelement off 
usempi off 
solver method auto try_other off 
solver method auto try_other offcalculation start path "D:/FidesysBundle/calc/example.pvd" 
 
 

It is also possible to run the file Example_11_Static_2D_Conduction.jou, by selecting Journal Editor 

on Toolbar. In a pop-up window of the main menu select File → Open and open the necessary 

journal file. 
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Setting thermoelasticity (2D)  

Боли Б.,Уэйнер Дж. Теория температурных напряжений. М.: Мир, 1964, p. 259. 

[Boley B, Weiner J., Theory of thermal stresses (translated from English), Mir publ, Moscow, 1964, p.259 [in 

Russian]]   

The problem of static temperature load of the hollow cylindrical body of external radius R1 = 4 m and inner 

radius R2 = 3 m is being solved. Temperature effect applied to 

the inner edge of the cylinder AC is constant and equal to T1 = 

30°C. Temperature effect applied to the inner edge of the 

cylinder BD is constant and equal to T2 = 100°C. 

 Edges AB and CD are fixed on the symmetry condition:  

 Zero X-Translation on the line AB; 

 Zero Y-Translation on the line DC. 

The material parameters are Young’s Modulus E = 200 GPa, 

Poisson’s Ratio = 0.3, thermal expansion μ = 0.0001 1/ °C. 

Test pass criterion is the following: Displacement 𝑢𝑥  at the 

point (3, 0, 0) is 0.0205014 m within 1%. 

 

 

 

 

Geometry creation 

1. Create Circle 1. 

Select volume geometry generation section on Command Panel 

(Mode — Geometry, Entity — Surface, Action — Create). Select 

Circle in the list of geometric elements. Specify the circle 

dimensions:  

 Radius: 4; 

 Location: ZPlane. 

 

Click Apply. 
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2. Create Circle 2 

Select volume geometry generation section on Command Panel 

(Mode — Geometry, Entity — Surface, Action — Create). Select 

Circle in the list of geometric elements. Specify the circle 

dimensions:  

 Radius: 3;  

 Location: ZPlane. 

Click Apply. 

As a result, two generated entities are displayed in the Model 

Tree (Body 1 and Body 2). 

 

 

 

 

 

 

 

3.  Subtract the first circle from the second one.  

Select volume geometry generation section on Command 

Panel (Mode — Geometry, Entity — Volume, Action — 

Boolean). Select Subtract in the list of operations. Set the 

following parameters: 

 Body ID: 2 (volumes from which other volumes will be 

subtracted); 

 Substract bodies (ID): 1 (the volumes to be subtracted);  

 Imprint. 

 Click Apply 

As a result, only one volume is displayed in the Model Tree 

(Body 1). 
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4. Leave a quarter of a surface (symmetry of the 

problem).  

Select volume geometry generation section on Command 

Panel (Mode — Geometry, Entity — Volume, Action — 

Webcut). Select  Coordinate plane in the list of possible 

webcut types. Set the following parameters:  

 Body ID: 1 (the surface to be webcut);  

 Webcut with: YZ Plane; 

 Offset value: 0; 

 Imprint. 

Click Apply. 

Do the same for the ZX Plane: 

 Body ID: 1 (the surfaces to be webcut); 

 Webcut with: ZX Plane; 

 Offset value: 0; 

 Imprint. 

Click Apply. 

 

 

As a result, the original plane in the Model Tree is split into three (Body 1, Body 3, Body 4 ). 
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Delete the bodies 1, 3 and 5. To do this, right-click on 

these planes in the Model Tree and click Delete in 

contextual menu. As a result, a quarter of the original 

plane is left (Body 4): 

 

 

 

 

 

 

 

 

 

Meshing 

1. Select meshing on planes section on Command Panel (Mode — Mesh, Entity — Surface, Action — 

Meshing). Select meshing scheme: 

 Select surfaces (specify their ID): 7 (or by the command all); 

 Select meshing scheme: TriMesh; 

Click  Apply Scheme. 
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2. Select meshing on planes section on Command Panel (Mode — Mesh, Entity — Surface, Action — 

Intervals). Select the meshing interval: 

 Select surfaces (specify their ID): 7 (or by the command all); 

 Select meshing: Automatically; 

 Move the cursor of the automatical multiplier to the third position from the left side. 

Click Apply.  

Click Mesh.  

 

Setting boundary conditions 

1. Fix one side line in the X direction. 

Select Mode — Boundary Conditions, Entity — Displacement, Action — Create on Command Panel. Set the 

following parameters: 

 System Assigned ID; 

 Entity List: Curve; 

 Entities ID: 4; 

 Degrees of Freedom: X-Translation; 

 DOF Value: 0. 

Click Apply.  
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2. Fix one side line in the Y direction. 

Select  Mode — Boundary Conditions, Entity — Displacement, Action — Create on Command Panel. Set the 

following parameters: 

 System Assigned ID; 

 Entity List: Curve; 

 Entities ID: 15; 

 Degrees of Freedom: Y-Translation; 

 DOF Value: 0. 

Click Apply. 

3. Set the the thermal stress on the inner curve of the cylinder. 

Select Mode — Boundary Conditions, Entity — Temperature, Action — Create on Command Panel. Set the 

following parameters: 

 System Assigned ID; 

 Entity List: Curve; 

 Entities ID: 17; 

 Temperature value: 30. 

Click Apply. 
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4. Set the thermal stress on the outer curve of the cylinder. 

Select Mode — Boundary Conditions, Entity — Temperature, Action — Create on Command Panel. Set the 

following parameters: 

 System Assigned ID; 

 Entity List: Curve; 

 Entity ID: 16; 

 Temperature value: 100. 

Click Apply. 
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Setting material and element type 

1. Create the material.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity — Material, 

Action — Create Material). Enter the name for the material. 

Set the following parameters:  

 Young’s Modulus: 2е11; 

 Poisson’s Ratio: 0.3; 

 Heat transfer: 1; 

 Coeff. of Thermal Expansion: 1е-4. 

Click Apply. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

2. Create a block of one type of the material. 

Select setting the material properties section on 

Command Panel (Mode — Blocks and Materials, Entity — 

Block, Action — Manage). Select Add in the list of possible 

operations. Set the following parameters: 

 Block ID: 1 

 Entity type to be united into the block: Surface;  

 ID: 7 (or by the command all). 

 

Click Apply.  
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3. Assign the material to the block.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity —Block, Action — 

Manage). Select Assign Material to Block in the list of possible 

operations.  

Set the following parameters:  

 Block(s) ID: 1;. 

 Select the previously created material in the list: 

Material 1. 

Click Apply.  

 

 

 

 

 

 

 

4. Assign the element type.  

Select setting the material properties section on Command Panel 

(Mode — Blocks and Materials, Entity — Block, Action — 

Manage). Select Element Type in the list of possible operations. 

Set the following parameters:  

 Block(s) ID: 1; 

 Select: Surfaces; 

 Surfaces: Tri3. 

Click Apply. 
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Starting calculation 

1. Set the type of the problem to be solved.  

Select calculation setting section on Command Panel (Mode — 

Calculation settings, Calculation settings — Static, Static — 

General). Select Dimension – 2D, Type of plane problem – Plane 

stress. Tick next to the item Heat transfer. 

 

Click Apply. 

 

2. Set the solver settings. 

Select calculation setting section on Command Panel (Mode — 

Calculation settings, Calculation settings — Static, Static — Solver). 

Select the solver method (direct or iterative) and set Convergence 

Parameters in case of choosing an iterative one. You can also leave 

all the settings by default.  

 

Click Apply.  

Click  Start Calculation. 

3. In a pop-up window select a folder to save the result and enter 

the file name. 

4. If the calculation is finished successfully, you will see a message in the Console: “Calculation finished 

successfully at <date> <time>”.  

 

 

 

Results analysis 

1. Open the file with the results. You can do this in 

one of the three ways. 

 Click  Ctrl+E. 

 Select Calculation → Open Results in the Main Menu. 

Click  Open last result. 

 Select Calculations Manager on Command Panel 

(Mode — Calculations Manager, Calculations Manager 

— Results). Click  Open Results.  
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2. Display the 𝑢𝑅  component of the displacements field. 

Set the following parameters on Fidesys Viewer Toolbar: 

 Representation Mode: Surface With Edges; 

 Representation Field: Displacement; 

 Representation Component: 1. 

 

 

 

As a result, the displacement field  𝑢𝑥 is displayed. 

3. Select a point where you need to view the Displacement. 

In the Main Menu, select the filter Probe Location in the tab Filters → Alphabetical. In the tab Properties set 

the coordinates of the point E where you need to view the Displacement: 

 Show Point; 

 Point (coordinates):  3 0 0; 

 Number of Points: 1; 

 Radius: 0. 

Click Apply. 

To apply all of the filters changes automatically, click Apply changes to parameters automatically on 

Command Panel. 

 As a result, point C is displayed at the picture. 
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4. View a numerical valueof Ux at the selected point С. 

You can see the required value in the tab Information in the field Data Arrays (the first value in the line 

Displacement corresponds to the component 𝑢𝑥).  

 

The difference between the obtained 0.0204953 and the required one 0.0205014 is 0.03%. 

5. Download numerical data. 

Select File → Save Data in the Main Menu or click Ctrl+C. Enter the file name (*.csv format), leave it by 

default. Click  ОК. The saved file is an ordinary table of numerical data which can be opened in any text 

editor. 

 

 

 

Using Console Interface 

For geometry generation, meshing, setting boundary conditions and materials you can use Console 

Interface. The following program code allows performing the steps of the above-described guide, you only 

need to manually specify the full path and name of the file to be saved. 

Here is an example of the working script (the file is saved in D:/FidesysBundle/calc/example.pvd): 
 
reset 
set node constraint on 
create surface circle radius 4 zplane  
create surface circle radius 3 zplane  
subtract body 2 from body 1 imprint  
webcut body 1 with plane xplane offset 0 imprint preview  
webcut body 1 with plane xplane offset 0 imprint  
webcut body 1 with plane yplane offset 0 imprint preview  
webcut body 1 with plane yplane offset 0 imprint  
delete Body 1 
delete Body 3 
surface 7 size auto factor 3 
surface 7 size auto factor 3 
mesh surface 7  
create displacement on curve 4 dof 1 fix 0  
create displacement on curve 15 dof 2 fix 0  
create temperature on curve 17 value 30 
create temperature on curve 16 value 100 
undo group begin 
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create material "Material 1" property_group "CUBIT-FEA"  
modify material "Material 1" scalar_properties "MODULUS" 2e+11 "POISSON" 0.3 
"CONDUCTIVITY" 1 "THERMAL_EXPANSION" 0.0001  
undo group end 
set duplicate block elements off 
block 1 surface 7  
block 1 material 'Material 1' 
block 1 element type tri3 
analysis type static elasticity heattrans dim2 planestress 
spectralelement off 
usempi off 
solver method auto try_other off 
solver method auto try_other off 
calculation start path "D:/FidesysBundle/calc/example.pvd" 
 

It is also possible to run the file Example_12_Static_2D_Termoelasticity.jou by selecting Journal 

Editor on Toolbar. In a pop-up window of the main menu select File → Open and open the 

necessary journal file. 
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Temperature load stability (beam model)  

S.P. Timoshenko, J.M Manages “Theory of elastic stability” second edition. Dunod, 1966, 500 pages  

The problem of stability of a body clamped at butts and subjected to the uniform temperature heat is being 

solved. 

The picture represents a geometric model of the problem. 

A beam length is L = 200 mm. Rectangular cross section: width – 10 mm, thickness – 1 mm. Both ends of 

the beam are rigidly fixed at all displacements and rotations. 

The material is isotropic. Elastic modulus is E = 200 000 N/mm2, Poisson’s Ratio is 𝜈 = 0.33, the coefficient 

of thermal expansion is  𝛼=11.7∙10-6 С-1. 

 

Test pass criterion is the following:  

critical temperature is 𝑇𝑐𝑟𝑖𝑡 = 7.028o C within 1% . 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Geometry creation 

1.  Create the line.  

Select volume geometry generation section on Command Panel 

(Mode — Geometry, Entity — Curve, Action — Create). Select Circle 

in the list of geometric elements. Create using Location and 

Direction. Set Parameters:  

 Location: 0 0 0; 

 Direction: 1 0 0; 

 Length: 200. 

 

Click Apply. 
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Meshing 

1. Select meshing on curves section on Command Panel (Mode — Mesh, Entity — Curve, Action — 

Meshing). Specify the parameters of mesh refinement: 

 Select Curves: 1; 

 Select the way of meshing: Equal; 

 Select the meshing parameters: Interval; 

 Interval: 20. 

 

Click Apply. 

Click Mesh. 
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Setting boundary conditions 

1. Fix beam ends. 

Select Mode — Boundary Conditions, Entity — Displacement, 

Action — Create on Command Panel. Set the following 

parameters: 

 System Assigned ID; 

 Entity List: Vertex; 

 Entity ID(s):  1 2 (using space after each of them); 

 Degrees of Freedom: All; 

 DOF Value: 0. 

 Click Apply. 

 

 

 

 

 

 

 

 

 

 

 

 

 

2. Set the temperature load. 

Select Mode — Boundary Conditions, Entity — Temperature, 

Action — Create on Command Panel. Set the following 

parameters: 

 System Assigned ID; 

 Entity List: Curve; 

 Entity ID(s):  1; 

 Temperature value: 1. 

 Click Apply. 
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Setting material and element type 

1. Create the material.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity — Material, Action — 

Create Material). Enter the name for the material. Set the 

following parameters:  

 Young’s Modulus: 2e5; 

 Poisson’s Ratio: 0.33; 

 Coeff. of Thermal Expansion: 11.7e-6. 

Click Apply. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 

2. Create the block of one type of the material.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity — Block, Action — 

Manage). Select Add in the list of possible operations. Set the 

following parameters: 

 Block ID: 1; 

 Entity type to be united into the block: Curve; 

 ID: 1 (or by the command all). 

Click Apply. 
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3. Assign the material to the block.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity — Block, Action 

— Manage). Select Assign Material to Block in the list of 

possible operations. Set the following parameters: 

 Block(s) ID: 1; 

 Select the previously created material in the list: 

Material 1. 

Click Apply. 

 

 

 

 

 

 

4. Assign the element type.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity — Block, Action — 

Manage). Select Element Type in the list of possible 

operations. Set the following parameters:  

 Block(s) ID: 1; 

 Select: Curves; 

 Curves: Beam2. 

Click Apply. 
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Setting  beam cross section profile  

1. Set the parameters of the beam.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity — Beam 

parameters). Select the checkbox at Cross section profile. 

Select Rectangle from the list of possible profiles. Set the 

following parameters:  

 Block ID: 1; 

 Height (H): 10; 

 Width (B): 1.  

Click Apply. 
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Starting calculation 

1. Set the type of the problem to be solved.  

Select calculation setting section on Command Panel (Mode — 

Calculation settings, Calculation settings — Stability, Stability — 

General). Leave all the settings by default.  

Click Apply. 

 

 

2. Set the solver settings. 

Select calculation setting section on Command Panel (Mode — 

Calculation settings, Calculation settings — Stability, Stability 

ость — Solver). Select the solver method (direct or iterative) and 

set Convergence Parameters in case of choosing an iterative 

one. You can also leave all the settings by default.  

Click Apply.  

Click  Start Calculation. 

 

 

3. In a pop-up window select a folder to save the result 

and enter the file name. 

 

 

 

4. If the calculation is finished successfully, you will see a message in the Console: “Calculation finished 

successfully at <date> <time>” as well as the required values of the critical value. 
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Results analysis 

1. Compare the obtained results to those given in the table. 

 
№ Analitical 

solution 
FIDESYS 

  Value, o C Error 

1 7.028 7.02982 0.03% 

 

2. Open the file with the results. You can do this 

in one of the three ways. 

 Click  Ctrl+E.  

 Select Calculation → Open Results in the 

Main Menu. Click  Open last result. 

 Select Calculations Manager on Command Panel 

(Mode — Calculations Manager, Calculations 

Manager — Results). Click  Open Results.  

 

 

 

 

 

3. Display the 3D-view of the model (beam with thickness). 

To do this, click on the name of the source file in the Model Tree in the pop-up Fidesys Viewer 

window. After this click 3D-view button in the default string . 

 

The file *_3D.pvd with a 3D-image of the beam must be opened and you will be able to apply various filters 

to it and to view its deformed view. 

 

4. Select a filter Warp By Vector. 

 Choose the new file example Beam_Stability_3D.pvd in the 

Model Tree and display Filters Warp by Vector for it with the 

following field values : 

 Vectors: displacements Mode 1 

 Scale Factor: 10 
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5. Display displacements Mode 1. 

In Fidesys Viewer window set the following parameters on Toolbar: 

 

Make sure that the first required critic temperature value is displayed in the window Critical value. 

To apply all of the filters changes automatically, click Apply changes to parameters automatically on 

Command Panel. 

6. View results. 

 As a result, the deformed body is displayed at the picture. To see the original model, click near the 

model in the Model Tree. The picture below shows the deformed (solid grey filling) and the original 

model (with the field of displacements distribution for Mode 11). 

 

7.  Download numerical data. 

Select File → Save Data in the Main Menu or click Ctrl+S. Enter the file name (*.csv format), leave it by 

default. Click  ОК. The saved file is an ordinary table of numerical data which can be opened in any text 

editor. 

 

Using Console Interface 

For geometry generation, meshing, setting boundary conditions and materials you can use Console 

Interface. The following program code allows performing the steps of the above-described guide, you only 

need to manually specify the full path and name of the file to be saved. 

Here is an example of the working script (the file is saved in D:/FidesysBundle/calc/example.pvd): 
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reset 
set node constraint on 
create curve location 0 0 0 direction 1 0 0 length 200 
curve 1 interval 20 
curve 1 scheme equal 
curve 1 interval 20 
curve 1 scheme equal 
mesh curve 1 
create displacement on vertex 1 2 dof all fix 0  
create temperature on curve 1 value 1 
undo group begin 
create material "Material 1" property_group "CUBIT-FEA"  
modify material "Material 1" scalar_properties "MODULUS" 2e+05 "POISSON" 0.33 
"THERMAL_EXPANSION" 1.17e-05  
undo group end 
set duplicate block elements off 
block 1 curve 1  
block 1 material 'Material 1' 
block 1 element type beam2 
block 1 attribute count 14 
block 1 attribute index 1 value 10 name 'A' 
block 1 attribute index 2 value 3.12334 name 'It' 
block 1 attribute index 3 value 84.1667 name 'Ix' 
block 1 attribute index 4 value 83.3333 name 'Iy' 
block 1 attribute index 5 value 0 name 'Iyz' 
block 1 attribute index 6 value 0.833333 name 'Iz' 
block 1 attribute index 7 value 0 name 'angle' 
block 1 attribute index 8 value 0 name 'ey' 
block 1 attribute index 9 value 0 name 'ez' 
block 1 attribute index 10 value 0.5 name 'max_y' 
block 1 attribute index 11 value 5 name 'max_z' 
block 1 attribute index 12 value 0 name 'section_type' 
block 1 attribute index 13 value 10 name 'geom_H' 
block 1 attribute index 14 value 1 name 'geom_B' 
analysis type stability elasticity dim3 
eigenvalue find 10 smallest 
spectralelement off 
usempi off 
solver method auto try_other off 
solver method auto try_other offcalculation start path "D:/FidesysBundle/calc/example.pvd" 
 
 
 

It is also possible to run the file Example_13_Stability_Temperature_Beam.jou, by selecting Journal 

Editor on Toolbar. In a pop-up window of the main menu select File → Open and open the 

necessary journal file. 
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Dynamic load: nonsteady heat transfer (3D, implicit scheme)  

The 3D problem of 1D nonsteady heat transfer inside a beam is being solved.  

The picture below represents a geometric model of the problem: 

 

 

 

 

 

 

 

 

 

The beam length is 0.1 m, square cross section is 0.01x0.01 m. The temperature at the point A is TA = 0 °C, 

the temperature at the point B varies harmonically: TB = 100 sin 
𝜋𝑡

40
 °C. The material parameters are 

isotropic, V = 35 W/(m·°C), C = 440.5 J/(kg ·°C), 𝜌 = 7 200 kg/m3. 

 

Test pass criterion is the following: temperature T at the point C (0.8;0;0) at time t = 32c is 36.60°C within 

2%. 

 

Geometry creation 

1. Create the sliver parallelepiped. 

Select volume geometry generation section on Command 

Panel (Mode — Geometry, Entity — Volume, Action — Create). 

Select Brick in the list of geometric elements. Set the brick 

dimensions:  

 Width: 0.1; 

 Height: 0.01; 

 Depth: 0.01. 

Click Apply. 
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2. Combine left edge of the beam with the origin of 

coordinates. 

Set the following parameters: Select volume geometry 

modification section on Command Panel  (Mode — Geometry, 

Entity — Surface, Action — Transform). Select Move in the list of 

possible webcut types. Set the following parameters:  

 

 Volume: 1; 

 Select method: Distance; 

 X Distance: 0.05. 

Click Apply. 

 

 

 

 

 

  

 

 

Meshing 

1. Creat the mesh of hexahedrons. 

Select volume mesh generation section on Command Panel 

(Mode — Mesh, Entity — Volume, Action — Mesh): 

 Select Volumes (specify their ID): 1 (or by the command 

all); 

 The way of meshing: Polyhedron. 

Click  Apply Scheme. 

Click Mesh. 

 

  



 CAE Fidesys — User Guide (version 1.6) 

 

Setting material and element type 

1. Create the material. 

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity — Material, Action — 

Create Material). Enter the name for the material. Set the 

following parameters:  

 Density: 7200; 

 Specific Heat: 440.5; 

 Conductivity: 35. 

Click Apply. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

2. Create a block of one type of the material.  

Select setting the material properties section on Command Panel 

(Mode — Blocks and Materials, Entity — Block, Action — Manage). 

Select Add in the list of possible operations. Set the following 

parameters: 

 Block ID: 1; 

 Entity type to be united into the block: Volume; 

 ID: 1 (or by the command all). 

Click Apply. 
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3. Assign the material to the block.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity — Block, Action — 

Manage). Select Assign Material to Block in the list of 

possible operations. Set the following parameters: 

 Block(s) ID: 1; 

 Select the previously created material in the list: 

Material 1. 

Click Apply. 

 

 

 

 

 

 

4. Assign the element type.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity — Block, Action — 

Manage). Select Element Type in the list of possible operations. 

Set the following parameters:  

 Block(s) ID: 1; 

 Select: Volumes; 

 Volumes: Hex8. 

Click Apply. 
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Setting boundary conditions 

1. Set the value of temperature applied to the left side of 

the beam.  

Select Mode — Boundary Conditions, Entity — Temperature, 

Action — Create on Command Panel. Set the following 

parameters: 

 System Assigned ID; 

 Entity List: Surface; 

 Entity ID(s):  4; 

 Temperature Value: 0. 

 Click Apply. 

 

 

 

 

 

 

 

 

 

2. Set the value of temperature applied to the right side 

of the beam.  

Select Mode — Boundary Conditions, Entity — 

Temperature, Action — Create on Command Panel. Set the 

following parameters: 

 System Assigned ID; 

 Entity List: Surface; 

 Entity ID(s):  6; 

 Temperature Value: 1. 

 Click Apply. 
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Setting time dependency of boundary conditions  

3. Set time dependency of the temperature applied to 

the right edge of the beam. 

Select Mode — Boundary Conditions. Click on the button 

Time dependency on Command Panel. The pop-up menu 

with the settings will be opened. On the left panel, select 

BC for which the time dependency will be set: 

Temperature 2. Put a checkbox next to the item Formula. 

Set the following parameters: 

 Time dependency type: Manually; 

 Enter formula: 100*sin(0.0785*t). 

 Click Ok. 
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Starting calculation 

4. Set the type of the problem to be solved.  

Select calculation setting section on Command Panel 

(Mode — Calculation settings, Calculation settings — 

Dynamic, Dynamic — General). Set the following 

calculation parameters: 

 Dimension: 3D; 

 Spectral element method; 

 Spectral element order: 2; 

 Elasticity: untick; 

 Heat transfer: tick; 

 Scheme: Implicit; 

 Max time: 32; 

 Steps count: 100. 

Click Apply.  

Click  Start Calculation. 

 

 

 

 

 

 

 

 

 

5. In a pop-up window select a folder to save the result and enter the file name. 

6. If the calculation is finished successfully, you will see a message in the Console: “Calculation finished 

successfully at <date> <time>”.  
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Results analysis 

1. Open the file with the results.  

You can do this in one of the three ways: 

 Click  Ctrl+E. 

 Select Calculation → Open Results in the Main 

Menu. Click  Open last result.  

 Select Calculations Manager on Command Panel (Mode — 

Calculations Manager, Calculations Manager — Results). 

Click  Open Results. 

 

 

 

 

 

You can see the calculation results in the pop-up Fidesys Viewer window. 

 

2. There is a menu on Toolbar which allows viewing animation. It consists of a cycle of solutions 

calculated for every moment of time. Click “Last Frame” to see the model in time moment t = 32°C. 

 

 

3. Display the component of the temperature. 

In Fidesys Viewer window set the following parameters on Toolbar: 

 Representation Field: Temperature;  

 Representation Mode: Surface With Edges. 

 

The model displays the mesh resulting from application of the spectral element method and the field of 

temperature distribution. 

 

 To display the color legend scale, click the button Switch the color legend visibility on Command 

Panel. 
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4. To graph along one of the beam edges. 

Select the filter Plot Over Line in the Main Menu. Set the 

coordinates of the points defining the line In the tab 

Properties: 

 Source: High Resolution Line; 

 Show Line; 

 Point 1 (coordinates): 0 -0.005 0.005; 

 Point 2 (coordinates): 0.1 -0.005 0.005; 

 Resolution: 100; 

 PassPartialArrays 

Click Apply. 

To apply all of the filters changes automatically, click 

Apply changes to parameters automatically on 

Command Panel. 

Click on the graph window appeared on the right side of the 

screen. 
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5. Display temperature change on the graph. 

Click on the graph window, go to the tab "Display" in the filter control panel. 

Set the Attribute Mode – Point Data  

Next, in the field “Line Series”, set up labels against the parameters that you want to display on the graph.  

Untick all the options except Temperature. 

The temperature dependency at points belonging to the beam edge and the coordinates of these point 

coordinates are displayed on the graph. 

 

 

 

6. Check the numerical temperature value T at the point (0.08;0;0). 

Move the cursor to the required point on the graph. You can see a tool tip with the temperature value. 
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The difference between the obtained value 36.1947 and the required one 36.60 is 1.11%. 

7. Download numerical data. 

Select File → Save Data in the Main Menu or click Ctrl+S. Enter the file name (*.csv format), leave it by 

default. Click OK. The saved file is an ordinary table of numerical data which can be opened in any text 

editor.  
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Using Console Interface 

For geometry generation, meshing, setting boundary conditions and materials you can use Console 

Interface. The following program code allows performing the steps of the above-described guide, you only 

need to manually specify the full path and name of the file to be saved. 

Here is an example of the working script (the file is saved in D:/FidesysBundle/calc/example.pvd): 
 

reset 
brick x 0.1 y 0.01 z 0.01 
move volume 1 x 0.05 
volume all size auto factor 5 
mesh volume all 
undo group begin 
create material "Material 1" property_group "CUBIT-FEA"  
modify material "Material 1" scalar_properties "DENSITY" 7200 "SPECIFIC_HEAT" 440.5 
"CONDUCTIVITY" 35  
undo group end 
set duplicate block elements off 
block 1 volume 1   
block 1  material 'Material 1' 
block 1 element type HEX8 
create temperature  on surface 4  value 0 
create temperature  on surface 6  value 1 
bcdep temperature 2 value '100*sin(0.0785*t)' 
analysis type dynamic heattrans dim3 
dynamic scheme implicit maxtime 32 maxsteps 100 
spectralelements on order 2 
calculation start path "D:/FidesysBundle/calc/example.pvd" 

 
 

 

 It is also possible to run the file Example_14_Dynamic_3D_Conduction_Spectr.jou, by selecting 

Journal Editor on Toolbar. In a pop-up window of the main menu select File → Open and open the 

necessary journal file. 
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Static load considering plasticity (3D) 

NAFEMS Understanding Non-linear Finite Element Analysis Through Illustrative Benchmarks, Pressured cylinder 

plasticity benchmark p.51. 

The problem of static load of a cylinder with perfect plasticity is being solved.  

The pictures below represent a geometric model of the problem: 

  

 

Due to the symmetry, 1/8 part of the cylinder is considered. The model is also fixed on the symmetry 

condition. The pressure of 140 Pa is applied to the inner edge. The material parameters are Young’s 

Modulus E = 207000 Pa, Poisson’s Ratio ν = 0.3, yield strength y=208. In the process of solving, the load is 

split into 14 steps of loading. 

Test pass criterion is the following: stress graphs σMises for P=140 coincide with the shown in the picture:  
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Geometry creation 

1. Create the first cylinder. 

Select volume geometry generation section on Command 

Panel (Mode — Geometry, Entity — Volume, Action — Create). 

Select Cylinder in the list of geometric elements. Specify the 

cylinder dimensions: 

 Height: 100; 

 Cross section: Circular; 

 Radius: 100; 

Click Apply. 

 

 

 

 

 

 

 

 

2. Create the second cylinder.  

Select volume geometry generation section on Command Panel (Mode — 

Geometry, Entity — Volume, Action — Create). Select Cylinder in the list of 

geometric elements. Specify the cylinder dimensions:  

 Height: 100; 

 Cross section: Circular; 

 Radius: 200; 

Click Apply. 

As a result, two generated entities are displayed in the Model Tree (Volume 

1 and Volume 2). 
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3. Subtract the first cylinder from the second one. 

Select volume geometry generation section on Command 

Panel (Mode — Geometry, Entity — Volume, Action — 

Boolean). Select Subtract in the list of operations. Set the 

following parameters: 

 Body ID: 2 (volumes from which other volumes will be 

subtracted); 

 Substract Body ID(s): 1 (the volumes to be subtracted); 

 Imprint. 

 Click Apply. 

As a result, only one volume is displayed in the Model Tree 

(Volume 2). 

 

 

 

 

 

 

 

4. Leave a quarter of a volume (symmetry of the problem).   

Select volume geometry generation section on Command Panel (Mode 

— Geometry, Entity — Volume, Action — Webcut). Select Coordinate 

Plane  in the list of possible webcut types. Set the following parameters:  

 Volume ID(s): 2 (the volume to be webcut); 

 Webcut with: YZ Plane; 

 Offset value: 0; 

 Imprint. 

Click Apply. 

 

Do the same for the XZ Plane: 

 Volume ID(s): 2 (the volume to be webcut); 

 Webcut with: ZXPlane; 

 Offset value: 0; 

 Imprint. 

Click Apply. 
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As a result, the original volume in the Model Tree is split into three (Volume 2, Volume 3 and Volume 4). 

 

  

 

 

 

Delete the volumes 2 and 3. To do this, select these volumes in the Model Tree holding down Ctrl and click 

Delete in contextual menu. As a result, a quarter of the original volume is left (Volume 4):  

 

 



 CAE Fidesys — User Guide (version 1.6) 

 

Meshing 

1. Select volume mesh generation section on 

Command Panel (Mode — Mesh, Entity — Volume, 

Action — Meshing). Specify the following 

parameters: 

 Select volumes: 4; 

 Select meshing scheme: Polyhedron; 

Click Apply Scheme. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

2. Go to the section Intervals on Command Panel (Mode — 

Mesh, Entity — Volume, Action — Intervals). Specify the 

following parameters: 

 Select volumes: 4; 

 Select meshing scheme: Approximate size; 

 Approximate size: 10 

Click Apply. 

Click Mesh. 

 

The resulting number of elements can be viewed in the Property Page by clicking on the inscription Volume 

4 in the Model Tree on the left.  
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To view the mesh properties, you can follow these steps: 

 Select the entire model  

 Right-click on the model 

 In the pop-up menu, select List Information – List Mesh Info  

 Information on the mesh will be displayed in Command Line  
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Setting boundary conditions 

1. Fix one side (slice) along X axis. 

Select Mode — Boundary Conditions, Entity — Displacement, Action 

— Create on Command Panel. Set the following parameters: 

 System Assigned ID; 

 Entity List: Surface; 

 Entity ID(s):  11 (or click on the left slice); 

 Degrees of Freedom: X-Component; 

 DOF Value: 0. 

 Click Apply. 

 

 

 

 

 

 

 

 

 

 

2. Fix one side (slice) along Y axis by analogy. 

Set the following parameters: 

 System Assigned ID; 

 Entity List: Surface; 

 Entity ID(s):  27 (or click on the bottom slice); 

 Degrees of Freedom: Y-Translation; 

 DOF Value: 0. 

 Click Apply. 
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3. Fix the bottom surface along Z axis by analogy.  

Select Mode — Boundary Conditions on Command Panel. Set the 

following parameters: 

 System Assigned ID; 

 Entity List: Surface; 

 Entity ID(s):  29 (or clicking on the bottom edge of the model); 

 Degrees of Freedom: Z-Translation; 

 DOF Value: 0. 

 Click Apply. 

 

 

 

 

 

 

4. Apply pressure to the inner edge. 

Select Mode — Boundary Conditions, Entity — Pressure, Action — Create 

on Command Panel. Set the following parameters: 

 System Assigned ID; 

 Entity List: Surface; 

 Entity ID(s):  30 (or click on the inner surface of the cylinder); 

 Value: 160 

Click Apply. 

 

 

 

 

All the applied boundary conditions must be displayed in the Model Tree on the left. Besides, the boundary 

conditions are available for editing from the Model Tree. 

To view all the applied boundary conditions, click Show BC in the top panel.  
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Setting material and element type 

1. Create the material.  

Select setting the material properties section on Command Panel (Mode — Blocks and Materials, Entity —

Material, Action — Create Material). Set the following parameters:  

 Name: Material1; 

 Description: Hook material 

 Property group: Hook material; 

 Young’s Modulus: 207e3; 

 Poisson’s Ratio: 0.3; 

 Yield strength: 208. 

Click Apply. 
 

Note: Since the case of perfect plasticity is regarded, the yield strength and ultimate strain are not 

introduced.   
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2. Create the block of one type of the material.  

Select setting the material properties section on Command Panel (Mode — Blocks and Materials, Entity — 

Block, Action — Manage). Select Add in the list of possible operations. Set the following parameters: 

 Block ID: 1; 

 Entity type to be united into the block: Volume; 

 ID: 4 (or by the command all). 

Click Apply. 
  

 
 
 

3. Assign the material to the block.  

Select setting the material properties section on Command Panel (Mode — Blocks and Materials, Entity — 

Block, Action — Manage). Select Assign Material to Block in the list of possible operations. Set the following 

parameters: 

 Block(s) ID: 1; 

 Select the previously created material in the list: 

Material 1. 

Click Apply.  
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4. Assign the element type.  

Select setting the material properties section on 

Command Panel (Mode — Blocks and Materials, Entity — 

Block, Action — Manage). Select Element Type in the list of 

possible operations. Set the following parameters:  

 Block(s) ID: 1; 

 Select: Volumes; 

 Volumes: HEX27. 

Click Apply. 

 

 

 

Starting calculation 

1. Set the type of the problem to be solved.  

Select calculation setting section on Command Panel (Mode — Calculation settings, Calculation settings — 

Static, Static — General). Select: 

 Dimension: 3D; 

 Model: Elasticity; 

 Model: Plasticity. 

 Nonlinear solver settings. Specify the following parameters: 

 Maximum number of iterations: 200; 

 The number of loading steps: 16; 

 Tolerance: 1е-9. 

Click Apply.  

 

2. Set up Output Fields. 

Select calculation setting section on Command Panel (Mode — Calculation settings, Calculation settings — 

Static, Static — Output Fields). For nonlinear problems, results output is available at each loading step. 

Make sure that the checkbox Output intermediate results is on. 
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Click Start Calculation. 

 

3. In a pop-up window select a folder to save the result and enter the file name. In this case, save the 

calculation in the file test.pvd. 

4. If the calculation is finished successfully, you will see a message in the Console: “Calculation finished 

successfully at <date> <time>”.  

5. For nonlinear problems, convergence of iterations at each step of loading can be checked in the file 

Convergence.txt. The file is downloaded into the folder test which is created next to the file test.pvd. 
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Open the file test\Convergence.txt: 

 

Make sure that the convergence with the set tolerance is reached at each step of loading. 
CONVERGENCE ITERATIONS 

 
LoadTime Residual 

0.071429 50700.241485535989000 
0.071429 0.000000000915691 
----------------------------- 

0,142857 50700,241485575054000 
0,142857 0,000000001017351 
----------------------------- 

0,214286 50700,241485579267000 
0,214286 0,000000001169061 
----------------------------- 

0,285714 50700,241485585524000 
0,285714 0,000000001352515 
----------------------------- 

0,357143 50700,241485593193000 
0,357143 0,000000001542185 
----------------------------- 

0,428571 50700,241485601844000 
0,428571 0,000000001740132 
----------------------------- 

0,500000 50700,241485610350000 
0,500000 0,000000001895954 

 

Results analysis 

1. Open the file with the results. You can do this in 

one of the three ways. 

 Click  Ctrl+E. 

 Select Calculation → Open Results in the Main Menu. Click Open last result. 

 Select Calculations Manager on Command Panel 

(Mode — Calculations Manager, Calculations Manager 

— Results). Click Open Results.  

 

To apply all of the filters changes automatically, click 

Apply changes to parameters automatically on 

Command Panel. 
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2. Display the Stress field Mises and the mesh on the model. 

To do this, invoke the filter Invariants by the quick access button on the Fidesys Viewer panel  

 

Leave only the checkbox Stress intensity for this filter in the tab Properties in the Model Tree.   

 

On the Fidesys Viewer toolbar, set the following parameters: 

 Representation Mode: Surface With Edges; 

 Representation Field: Stress (Mises); 

 Surface With Edges. 

 

 

 



 CAE Fidesys — User Guide (version 1.6) 

 

3. Build the Stress distribution (Mises) along the radius of the cylinder. 

To do this, open Filter – Alphabetical– Plot over line.  

In the tab Properties for the filter Graph along the line1, set parameters as it is shown in the picture below. 

After this, go to the tab Display and select only the field Stress_Mises for display: 
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As a result, the distribution graph of the stress field (Mises) along the radius of the cylinder will appear on 

the graph to the right. 

 

4. Download numerical data. 

Select File → Save Data in the Main Menu or click Ctrl+S. Enter the file name (*.csv format), leave it by 

default. Click OK. The saved file is an ordinary table of numerical data which can be opened in any text 

editor. 

 

 

Using Console Interface 

For geometry generation, meshing, setting boundary conditions and materials you can use Console 

Interface. The following program code allows performing the steps of the above-described guide, you only 

need to manually specify the full path and name of the file to be saved. 

Here is an example of the working script (the file is saved in D:/FidesysBundle/calc/example.pvd) 
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reset 
create Cylinder height 100 radius 200  
create Cylinder height 100 radius 100  
subtract body 2 from body 1  
webcut body 1 with plane xplane offset 0  
webcut body 1 with plane yplane offset 0  
webcut body 4 with plane zplane offset 0  
delete Body 5 
delete Body 1 
delete Body 3 
volume 4 scheme Auto 
volume 4 size 10  
mesh volume 4  
create material "Material 1" property_group "CUBIT-FEA"  
modify material "Material 1" scalar_properties "MODULUS" 207e3 "POISSON" 0.3 
"YIELD_STRENGTH" 208  
set duplicate block elements off 
block 1 volume 4  
block 1 material 'Material 1' 
create displacement on surface 32 dof 3 fix  
create displacement on surface 33 dof 1 fix  
create displacement on surface 35 dof 2 fix  
create pressure on surface 34 magnitude 140  
block 1 element type HEX27 
analysis type static elasticity plasticity dim3 
nonlinearopts maxiters 1000 loadsteps 10 tolerance 1e-3  
calculation start path "\\ns25\calc_MPI\nointerface1.pvd" 
calculation start path "D:/FidesysBundle/calc/example.pvd" 
 

It is also possible to run the file Example_15_Plasticity_3D.jou by selecting Journal Editor on 

Toolbar. In a pop-up window of the main menu select File → Open and open the necessary journal 

file.  
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Contact interaction modeling (3D)  

G. DUMONT: “Method of the active stresses applied to the unilateral contact” Note HI-75/93/016 

(http://www.code-aster.org/V2/doc/v10/en/man_v/v1/v1.01.246.pdf) 

The Hertz problem for the two hemispheres is being solved. The pictures below represent a geometric 

model of the problem: 

 

Due to the symmetry, ¼ part of the hemispheres is considered. The model is also fixed due to the condition 

of symmetry. On the upper side of the first hemisphere Displacement Uy = -2 mm is applied; Displacement 

Uy = 2 mm is applied on the bottom side of the second hemisphere. The material parameters are Young’s 

Modulus E = 2e4 MPa, Poisson’s Ratio ν = 0.3. 

Test pass criterion is the following:  

at the point G yy = -2798.3 MPa 

 

 

 

Geometry creation 

1. Create the first sphere. 

Select volume geometry generation section on Command 

Panel (Mode — Geometry, Entity — Volume, Action — Create). 

Select Sphere in the list of geometric elements. Set the 

sphere dimensions:  

 Radius: 50; 

Click Apply. 
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2. Move the created sphere along the Оy axis.  

Select Mode — Geometry, Entity — Volume, Action — 

Transform on Command Panel. Set the following parameters: 

 In the drop-down list, select: Move; 

 Volume (ID): 1 (or click with a mouse on the created 

sphere); 

 Select method: Distance; 

 Distance along Y: 50. 

 

 

 

 

3. Create the second sphere.  

Select volume geometry generation section on Command 

Panel (Mode — Geometry, Entity — Volume, Action — Create). 

Select Sphere in the list of geometric elements. Set the sphere 

dimentions:  

 Radius: 50; 

Click Apply. 

 

 

 

 

4. Move the second sphere along the Оy axis.  

Select Mode — Geometry, Entity — Volume, Action — Transform on Command Panel. Set the following 

parameters: 

 In the drop-down list, select: Move; 

 Volume (ID): 1 (or click with a mouse on the created sphere); 

 Select method: Distance; 

 Distance along Y: -50. 
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As a result, two generated entities are displayed in the Model Tree (Volume 1 and Volume 2). At the same 

time, both spheres contact at the point (0,0,0).  

 

 

 

5. Leave half of the first sphere. 

To do this, cut the first (upper) sphere by the ZX plane on center. 

Select Mode — Geometry, Entity — Volume, Action — Webcut on 

Command Panel. Select Coordinate Plane  in the list of possible 

webcut types. Set the following parameters: 

 Body ID: 1 (or click with a mouse on the upper sphere); 

 Set the ZX checkbox; 

 Offset value: 50. 

 Click Apply. 

As a result, the upper sphere must be split into two parts. 
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6. Leave half of the second sphere. 

To do this, cut the second (upper) sphere by the ZX plane on center. Select Mode — Geometry, Entity — 

Volume, Action — Webcut on Command Panel. Select Coordinate Plane in the list of possible webcut types. 

Set the following parameters: 

 Body ID: 2 (or click with a mouse on the upper sphere); 

 Set the ZX checkbox; 

 Offset value: -50. 

 Click Apply. 

 

As a result, the bottom 

sphere must be split into 

two parts. 

Four resulting volumes 

must be displayed in the 

Model Tree on the left.  

 

 

 

 

 

 

 

 

 

 

 

 

 

7.  Remove the excess volumes. 

It is necessary to remove the uppermost and the bottommost 

volumes. Select Mode — Geometry, Entity — Volume, Action 

— Delete on Command Panel. Set the following parameters: 

 Body ID: 3 2 (or click on the uppermost and the 

bottommost volumes holding down CTRL); 

Click Apply. 
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8. Leave a quarter of spheres (symmetry of the problem).  

Select volume geometry generation section on Command 

Panel (Mode — Geometry, Entity — Volume, Action — Webcut). 

Select Coordinate Plane in the list of possible webcut types. 

Set the following parameters:  

 Volume ID(s): all (the volumes to be webcut); 

 Webcut with: YZ Plane; 

 Offset value: 0. 

Click Apply. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Do the same for the XZ Plane: 

 Volume ID(s): all (the volumes to be webcut); 

 Webcut with: XZ Plane; 

 Offset value: 0; 

 Imprint. 

Click Apply. 
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9. Remove the excess volumes.  

Select Mode — Geometry, Entity — Volume, Action — Delete on 

Command Panel. Set the following parameters: 

 Body ID: 5 9 7 6 10 8 (or by holding down CTRL, click 

successively on all volumes, except those that are in the 

first and eighth coordinate quarter); 

Click Apply. 

 

 

 

 

 

 

 

As a result, two volumes must be left in the Model Tree on the left – Volume 1 and Volume 4. 
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Meshing 

1. Select volume mesh generation section on 

Command Panel (Mode — Mesh, Entity — Volume, 

Action — Meshing). Specify the following 

parameters: 

 Select volumes: all; 

 Select meshing scheme: Polyhedron; 

Click  Apply Scheme. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

2. On Command Panel, go to the section Intervals (Mode 

— Mesh, Entity — Volume, Action — Intervals). Specify the 

following parameters: 

 Select volumes: all; 

 Select meshing scheme: Automatically calculate; 

 Move the slider one scale division to the left  

Click Apply. 

Click Mesh. 
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The result of the actions should be the following model partition into finite elements: 

 

 

 

 

Setting boundary conditions 

1. Fix side edges at direction X. 

Select Mode — Boundary Conditions, Entity — Displacement, Action — 

Create on Command Panel. Set the following parameters: 

 System Assigned ID; 

 Entity List: Surface; 

 Entity ID(s):  25 33 (or select surfaces with the mouse as it is 

shown in the picture below); 

 Degrees of Freedom: X-Translation Disp; 

 DOF Value: 0. 

 Click Apply. 
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2. Fix side edges at direction Z by analogy  

Set the following parameters: 

 System Assigned ID; 

 Entity List: Surface;  

 Entity ID(s):  23 31 (or select surfaces with the mouse as it is 

shown in the picture below); 

 Degrees of Freedom: Z-Translation Disp; 

 DOF Value: 0.  

 Click Apply.  
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3. Set the displacement Uy = -2 on the upper edge of the first 

hemisphere by analogy 

Set the following parameters: 

 System Assigned ID; 

 Entity List: Surface; 

 Entity ID(s):  24 (or click on the upper edge of the upper 

hemisphere); 

 Degrees of Freedom: Y-Translation; 

 DOF Value: -2.  

 Click Apply.  

 

 

 

 

 

 

 

 

 

 

 

 

 

4. Set the displacement Uy = 2  on the bottom edge of the second hemisphere by analogy  

Set the following parameters: 

 System Assigned ID; 

 Entity List: Surface; 

 Entity ID(s):  34 (or click on the bottom edge of the bottom hemisphere); 

 Degrees of Freedom: Y-Translation Disp; 

 DOF Value: 2. 

 Click Apply. 
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All the applied boundary conditions should be displayed in the 

Model Tree on the left. In addition, the boundary conditions can 

be edited from the Model Tree. 

To view all the applied boundary conditions, please click Show 

BC on the top panel.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Setting contact interaction 

1. Set Contact Region 1. 

Select Mode — Boundary Conditions, Entity — Contact Region, 

Action — Create on Command Panel. Set the following 

parameters: 

 System Assigned ID; 

 Entity List: Surface; 

 Entity ID(s):  32 (or select with the mouse the convex 

surface of the bottom hemisphere); 

Click Apply. 

 

2. Set Contact Region 2. 

Select Mode — Boundary Conditions, Entity —Contact Region, 

Action — Create on Command Panel. Set the following 

parameters: 

 System Assigned ID; 
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 Entity List: Surface; 

 Entity ID(s):  26 (or select with the mouse the convex surface of the upper hemisphere); 

Click Apply. 

3.  Set the Contact pair. 

Select Mode — Boundary Conditions, Entity — Contact Pair, Action — Create. Set the following parameters: 

 System Assigned ID; 

 ID/Master region name: 1 (the bottom hemisphere); 

 ID/Slave region name: 2 (the upper hemisphere); 

 Keep all other settings of the contact pair by default  

Click Apply. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Contact Regions and Contact Pair should be displayed in the Model Tree on the left. 
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Setting material and element type 

 

1. Create the material.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity —Material, Action 

— Create Material). Set the following parameters:  

 Name: Material 1; 

 Description: Hook material 

 Property group: Hook material; 

 Young’s Modulus: 20 000; 

 Poisson’s Ratio: 0.3; 

Click Apply. 
 

 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 

2. Create the block of one type of the material.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity — Block, Action 

— Manage). Select Add in the list of possible operations. Set 

the following parameters: 

 Block ID: 1; 

 Entity type to be united into the block: Volume; 

 ID: all. 

Click Apply. 
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3. Assign the material to the block.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity — Block, Action 

— Manage). Select Assign Material to Block in the list of 

possible operations. Set the following parameters: 

 Block(s) ID: 1; 

 Select the previously created material in the list: 

Material 1. 

Click Apply. 

 

 

 

 

 

 

 

 

 

 

 

4. Assign the element type.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity — Block, Action — 

Manage). Select Element Type in the list of possible 

operations. Set the following parameters:  

 Block(s) ID: 1; 

 Select: Volumes; 

 Volumes: HEX8. 

Click Apply. 
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Starting calculation 

 

1. Set the type of the problem to be solved.  

Select calculation setting section on Command Panel (Mode — 

Calculation settings, Calculation settings — Static, Static — 

General). Select: 

 Dimension: 3D; 

 Model: Elasticity; 

 Model: Contact. 

 Nonlinear solver settings: Leave the default values.  

Click Apply. 

 

Click  Start Calculation. 

 

 

 

 

2. In a pop-up window select a folder to save the result and 

enter the file name. In this case, save the calculation in the 

file test.pvd. 

3. If the calculation is finished successfully, you will see a 

message in the Console: “Calculation finished successfully at 

<date> <time>”.  

 

For non-linear problems, convergence of iterations at each loading step can be checked in the file 

Convergence.txt. The file is downloaded into the folder test that is created next to the file test .pvd. 

 

 

 

 

Open the file test\Convergence.txt: 



 CAE Fidesys — User Guide (version 1.6) 

 

 

Make sure that the convergence with a specified tolerance is reached at each step of loading. 
CONVERGENCE ITERATIONS 

 
CONVERGENCE ITERATIONS 

 
LoadTime Residual 

0.500000 234474484.859693200000000 
0.500000 0.000000001649635 
----------------------------- 

1.000000 807631243.628153320000000 
1.000000 463217.315709784280000 
1.000000 20885.849428797028000 
1.000000 557.717737451076910 

----------------------------- 
 
 
 
 

Results analysis 

1. Open the file with the results. You can do this in 

one of the three ways. 

 

 Click Ctrl+E. 

 Select Calculation → Open Results in the Main Menu. 

Click  Open last result. 

 Select Calculations Manager on Command Panel (Mode — 

Calculations Manager, Calculations Manager — Results). 

Click  Open Results.  

 

 

 

To apply all of the filters changes automatically, click Apply changes to parameters automatically on 

Command Panel. 

 

 

2. Display the stress field yy and the mesh on the model. 

In Fidesys Viewer window set the following parameters on Toolbar: 

 Representation Field: Strain; 

 Component: 22; 

 Representation Mode: Surface With Edges. 
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3. Define the stress at the specified point G. 

This point belongs to the upper hemisphere, therefore the the lower hemisphere should be cut off. 

Open Filter – Alphabetical – Threshold to do this. Or click on the appropriate button on the Fidesys Viewer 

top panel. 

Set the following parameters for the filter Threshold in the tab Properties:  

 Scalars: InitialNodeID; 

 Lower threshold: Leave unchanged; 

 Upper threshold: 8400. 
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Thus, only the upper hemisphere is left. 

Select the bottom point of the hemisphere using the appropriate Fidesys Viewer tools. 

 

Use the button Point information  

 

As a result, the components of the Stress field for the selected point G should be displayed in the pop-up 

window Point information. 
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Compare the value of the second stress field component and the original value -2798.3 MPa. The difference 

between the resulting value -2837.1 and the original one is 1.4%. 

 

 

4. Display the Contact Status field and the mesh on the model. 

In the Model Tree on the left, please, change back focus on the calculation name test.pvd. Set the following 

parameters on Toolbar: 

 Representation Field: Contact Status; 

 Component: 1;  

 Representation Mode: Surface With Edges. 
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5. Display the Stress field in contact and the mesh on the model. 

In Fidesys Viewer window set the following parameters on Toolbar: 

 Representation Field: ContactStress; 

 Component: 11;  

 Representation Mode: Surface With Edges. 

 

 

 

6. Download numerical data. 

Select File → Save Data in the Main Menu or click Ctrl+S. Enter the file name (*.csv format), leave it by 

default. Click OK. The saved file is an ordinary table of numerical data which can be opened in any text 

editor. 

Using Console Interface 

For geometry generation, meshing, setting boundary conditions and materials you can use Console 

Interface. The following program code allows performing the steps of the above-described guide, you only 

need to manually specify the full path and name of the file to be saved. 
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Here is an example of the working script (the file is saved in D:/FidesysBundle/calc/test.pvd) 
 

reset 
create sphere radius 50  
create sphere radius 50  
move Volume 1 y 50 include_merged  
move Volume 2 y -50 include_merged  
webcut body all with plane yplane offset 50  
webcut body all with plane yplane offset -50 
delete volume 3 2 
webcut body all with plane xplane offset 0  
webcut body all with plane zplane offset 0  
delete volume 5 9 7 6 10 8  
volume all scheme Polyhedron 
volume all size auto factor 4 #14850 
mesh volume all 
create displacement on surface 23 31 dof 3 fix 0  
create displacement on surface 25 33 dof 1 fix 0  
create displacement on surface 24 dof 2 fix -2  
create displacement on surface 34 dof 2 fix 2  
create contact region on surface 32  
create contact region on surface 26  
create contact pair 1 master contact region 1 slave contact region 2 friction 0.0 
tolerance 0.0 tied off 
cpairdata id 1 normal_stiffness 1.0 tangent_stiffness 0.5 detection_tolerance 0.1 
create material "Material 1" property_group "CUBIT-FEA"  
modify material "Material 1" scalar_properties "MODULUS" 2e+04 "POISSON" 0.3  
block 1 volume all  
block 1 material 'Material 1' 
block 1 element type hex8 
analysis type static elasticity contact dim3 
nonlinearopts maxiters 100 minloadsteps 2 maxloadsteps 30 tolerance 1e-6 
spectralelement off 
usempi off 
calculation start path "D:/FidesysBundle/calc/test.pvd" 
 

It is also possible to run the file Example_16_Contact_3D.jou by selecting Journal Editor on Toolbar. 

In a pop-up window of the main menu select File → Open and open the necessary journal file.  

 

 

Composite effective properties calculation  

Кристенсен Р. Введение в механику композитов. – М., «Мир», 1982. – 334 с. 

[Christensen R., Mechanics of composite materials (translated from English), Mir publ, Moscow, 1982, 334 pages 

[in Russian]] 

The problem of finding effective material properties for the two-layer fiber-layered composite is being 

solved. The model has the following parameters: cord diameter is 6.0 mm, cord inclination angle is 30°, cord 

step is 8.0 mm, layer thickness is 16.0 mm. Thus, geometry is generated automatically via the interface with 

the specified parameters. The boundary conditions are periodic. The material properties of cords (block 1): 

Young’s Modulus 200000, Poisson’s Ratio 0.25. The material properties of the matrix (block 2): Young’s 

Modulus 2.0, Poisson’s Ratio 0.49. 

Test pass criterion is the following: as a result of solving, the following material constants are obtained: 

C_1111 = 24 852.4 MPa, C_1122 = 8 281.54 MPa, C_2222 = 2 763.12 MPa, C_1212 = 8 283.5 MPa within 3%. 
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Geometry creation  

1. Create the composite. 

Select volume geometry generation section on Command 

Panel (Mode — Geometry, Entity — Create composite). Select 

Laminated Multi Fiber from the drop-down list. Set the 

following parameters:  

 Cord Diameter: 0.6; 

 Cord Angle: 30 (degrees); 

 Cord Pitch: 8; 

 Sample Thickness: 16. 

Click Create. 

 

 

 

 

As a result, the geometry for the two-layer composite with the specified parameters is automatically 

generated. On the left in the Model Tree, all generated volumes and the corresponding blocks (Block 1 – 

thread, Block 2 – matrix) should be displayed.  
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Meshing 

1. Select volume mesh generation section on Command (Mode — Mesh, 

Entity — Volume, Action — Meshing). 

 Select volumes (specify their ID): 5 6 7 8 9 10 11 12 (or by the 

command all); 

 Select meshing scheme: Tetmesh; 

 Keep all other settings of the contact pair by default. 

Click  Apply Scheme.  

Click Mesh. 

To see the resulting number of items, you can do the following:  

 Select the entire model (by left-clicking and pressing the Ctrl key); 

 Right-click on the model; 

 In the pop-up menu, select List Information – List Mesh Info;  

 Information on the mesh will appear in Command Line  
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Setting material and element type 

1. Create the cord material.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity —Material, Action 

— Create Material). Set the following parameters:  

 Name: Material1; 

 Property group: Hook material; 

 Young’s Modulus: 200 000; 

 Poisson’s Ratio: 0.25. 

Click Apply. 
 
 

2. Create the material of matrix by analogy.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity —Material, Action 

— Create Material). Set the following parameters:  

 Name: Material2; 

 Property group: Hook material; 

 Young’s Modulus: 2; 

 Poisson’s Ratio: 0.49. 

Click Apply. 
 
 
 
 

 
 

 

3. Assign the thread material (Material1) to Block 1.  

Block 1 was automatically created when generating the 

geometry for composite. Select setting the material properties 

section on Command Panel (Mode — Blocks and Materials, 

Entity — Block, Action — Manage). Select Assign Material to 

Block in the list of possible operations. Set the following 

parameters: 

 Block(s) ID: 1; 

 Select the previously created material in the list: 

Material1. 

Click Apply. 
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4. Assign the matrix material (Material2) to Block 2.  

Block 2 was automatically created when generating the geometry for composite. Select setting the material 

properties section on Command Panel (Mode — Blocks and Materials, Entity — Block, Action — Manage). 

Select Assign Material to Block in the list of possible 

operations. Set the following parameters: 

 Block(s) ID: 2; 

 Select the previously created material in the list: 

Material2 

Click Apply. 

 

 

 

5.  Assign the element type.  

Select setting the material properties section on Command 

Panel (Mode — Blocks and Materials, Entity — Block, Action — 

Manage). Select Element Type in the list of possible 

operations. Set the following parameters:  

 Block(s) ID: 1 2 (or all); 

 Select: Volumes; 

 Volumes: TETRA4. 

Click Apply. 

 

 

 

 

Setting boundary conditions and Starting calculation 

1. Type of boundary conditions is set directly in the the 

calculation settings. Select Mode — Calculation Settings, 

Calculation Settings — Effective properties, Effective 

properties — General on Command Panel.  

Select Type of BC on the Panel:  

 Periodic. 

 Click Apply. 

Start the calculation by clicking Start calculation. 

 

2. If the calculation is finished successfully, you will 

see a message in the Console: “Calculation finished 

successfully at <date> <time>”.  
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Results analysis  
 

1. Calculation results of the composite effective properties will be displayed in the window Process 

effective properties data. 
 

 

The calculation results are also displayed in Command Line. 
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2. Define the required material constants. 

 

 The difference between C_1111 = 24 496 and the original one 24 852.4 MPa is 1.5%; 

 The difference between C_1122 = 8 227.62 and the original one 8 281.54 MPa is 0.7%; 

 The difference between C_2222 = 2 825.56 and the original one 2 763.12 MPa is 2.2%; 

 The difference between C_1212 = 8 271.82 and the original one 8 283.5 MPa is 0.1%. 

 

3. Process the received data. 

 

In the window Process effective properties data, select: 

 Material Type: Isotropic  

Click Process data. 

In the left column new material constants should appear. 

 
 

4. Export of calculation results. 

 

To export the material into the XML file, select the button Export Material….  

You must select a name for effective material and a name of the XML file to export to. 
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Using Console Interface 

For geometry generation, meshing, setting boundary conditions and materials you can use Console 

Interface. The following program code allows performing the steps of the above-described guide, you only 

need to manually specify the full path and name of the file to be saved. 

Here is an example of the working script (the file is saved in D:/FidesysBundle/calc/test.pvd) 
 
reset 
create brick width 16 depth 9.2376 height 16 
create cylinder height 50.4752 radius 3 
volume 2 rotate 90.0 about y 
volume 2 rotate 30 about z 
volume 2 move y -9.2376 
create cylinder height 50.4752 radius 3 
volume 3 rotate 90.0 about y 
volume 3 rotate 30 about z 
volume 3 move y 0 
create cylinder height 50.4752 radius 3 
volume 4 rotate 90.0 about y 
volume 4 rotate 30 about z 
volume 4 move y 9.2376 
intersect volume 1 2 keep 
intersect volume 1 3 keep 
intersect volume 1 4 keep 
delete volume 2 
delete volume 3 
delete volume 4 
subtract volume 5 6 7 from volume 1 keep 
delete volume 1 
volume all move z 8 
volume all move z 16 copy 
volume 9 10 11 12 reflect 1.0 0.0 0.0 
imprint volume all 
merge volume all 
block 1 volume 5 6 7 9 10 11 
block 2 volume 8 12 
volume all scheme Tetmesh 
set tetmesher interior points on  
set tetmesher optimize level 3 overconstrained off sliver off  
set tetmesher boundary recovery off  
volume all tetmesh growth_factor 1.0 
delete mesh volume all propagate 
volume all scheme Tetmesh 
set tetmesher interior points on  
set tetmesher optimize level 3 overconstrained off sliver off  
set tetmesher boundary recovery off  
volume all tetmesh growth_factor 1.0 
mesh volume all 
create material "Material1" property_group "CUBIT-FEA"  
modify material " Material1" scalar_properties "MODULUS" 2e+05 "POISSON" 0.25  
create material " Material2" property_group "CUBIT-FEA"  
modify material " Material2" scalar_properties "MODULUS" 2 "POISSON" 0.49  
block 1 material ' Material1' 
block 2 material ' Material2' 
analysis type effectiveprops elasticity dim3 
nonlinearopts maxiters 100 minloadsteps 1 maxloadsteps 10 tolerance 1e-6 
spectralelement off 
usempi off 
periodicbc on 
calculation start path 'D:/FidesysBundle/calc/test.pvd'   
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Contacts  

http://www.cae-fidesys.com 

support@cae-fidesys.com 

+7 (495) 930-87-53 

 

http://www.cae-fidesys.com/
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